Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    26

    Default Lousy Vodafone 3G data + voice performance vs. EDGE/GPRS

    Hey everyone,

    I've been with Vodafone for 2 years with both the iPhone 3G + the 3GS.

    Throughout all this time, I have notice (regardless of which iOS version is used) that Vodafone seems to have very lousy data performance when on the 3G network. Data will simply not load at all, despite that spinning symbol in the status bar. And on those odd days where data does seem to flow to the phone, it is painfully slow.

    In addition placing calls can take even as long as 30 secs before you even start to hear the phone ring. This has been my experience with 3 different iPhone handsets I have used (3G + my first 3GS, and my second replacement 3GS Apple provided me when I called AppleCare about this issue).

    What I've noticed is that when you disable 3G - and the phone switches to EDGE or GPRS - all these issues seem to either disappear completely or drastically improve. All issues with voice calls are resolved (in my experience at least) and data actually loads first time, every time (though slower compared to typical 3G speeds).

    Has anyone else noticed this? or perhaps totally different experiences on the Vodafone network comparing 3G and 2G?

    I have tried speaking to Vodafone about these issues many times during the 2 years I've been with them, and besides the smug and incompetent attitude or advising a network reset - they are rather useless.

  2. #2

    Join Date
    Feb 2004
    Location
    Sydney, NSW, Australia
    Posts
    1,072

    Default

    Have you complained? I did, for two specific locations where this occurred for me and it was fixed within about 3 months. It could be coincidental, but I don't think so.
    2012 Mac Mini 2.6 w/ 1TB Fusion Drive & 16GB RAM, Dell U2713HM Monitor | 15" MBP Unibody 2.66 | iPhone 5s Space Gray 32GB on Vodafone & iPhone 5 Black | iPad Retina (3rd Gen) on Vodafone | AppleTV 3 | Original Airport Express

  3. #3

    Join Date
    Feb 2008
    Location
    Queensland
    Posts
    820

    Default

    I think Vodafone are gonna have alot of customers leave their network !

    Check the other thread for details........
    15" MBP UniBody | 27" Cinema Display | Mac Mini UniBody 2010 | iPad 64GB 4G White | iPad 2 64GB 3G White | iPad 64GB 3G | iPhone 4S 64GB White | iPhone 4 32GB White | iPhone 3GS 32GB White

  4. #4

    Join Date
    Sep 2008
    Location
    Sydney
    Posts
    304

    Default

    Nexuss, this is the same thing that happens to me. I dont ever have my 3G turned on for this exact reason. I dont know if the iphone 4 will fix this problem but i hope so.

  5. #5

    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    26

    Default

    I've been having this issue since day 1 with the Vodafone network (granted I've only had iPhones on the network - have no idea what its like with a different handset).

    What really annoyed me was seeing a mate's iPhone on the Three network with full bars and really fast broadband data performance in almost any area - whilst my phone on Vodafone stuck at 3 bars at most, and no data at all being received.

    I'm very tempted to switch networks... the only thing Vodafone has done right is visual voicemail, but you sure do pay for it with a crippled pathetic network.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •