Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 7 of 7
  1. #1

    Join Date
    Sep 2006
    Location
    Perth
    Posts
    1,695

    Default 3 Kernel Panics in the past week

    OK, this is starting to annoy me now.

    I've had 3 kernel panics in the last week on my refurb MP (2 x 2.26).

    The first two seem to mention "simple deadlock detection".

    This is the first one - nothing specific I could see.

    Fri Jul 31 14:16:42 2009
    panic(cpu 13 caller 0x0019FEE7): "simple lock deadlock detection: lock=0x522b20, cpu=13, owning thread=0x12e63e40"@/SourceCache/xnu/xnu-1228.12.14/osfmk/i386/locks_i386.c:317
    Backtrace (CPU 13), Frame : Return Address (4 potential args on stack)
    0xa2053f08 : 0x12b4c6 (0x45ec20 0xa2053f3c 0x13355c 0x0)
    0xa2053f58 : 0x19fee7 (0x4671b8 0x522b20 0xd 0x12e63e40)
    0xa2053f78 : 0x13ec0f (0x522b20 0x0 0x1a436f 0x11a2f998)
    0xa2053fc8 : 0x1a14ec (0x522b60 0x0 0x1a40b5 0x1ad957d8)
    Backtrace terminated-invalid frame pointer 0

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9J61

    Kernel version:
    Darwin Kernel Version 9.7.0: Tue Mar 31 22:52:17 PDT 2009; root:xnu-1228.12.14~1/RELEASE_I386
    System model name: MacPro4,1 (Mac-F221BEC8)
    This is the second one - I had just started a handbrake encode

    nterval Since Last Panic Report: 323611 sec
    Panics Since Last Report: 1
    Anonymous UUID: 037AE4F7-CAEB-4735-B7C2-D5A3EB80907C

    Tue Aug 4 18:39:01 2009
    panic(cpu 11 caller 0x0019FEE7): "simple lock deadlock detection: lock=0x528be0, cpu=11, owning thread=0x1c69c128"@/SourceCache/xnu/xnu-1228.12.14/osfmk/i386/locks_i386.c:317
    Backtrace (CPU 11), Frame : Return Address (4 potential args on stack)
    0x8be53e18 : 0x12b4c6 (0x45ec20 0x8be53e4c 0x13355c 0x0)
    0x8be53e68 : 0x19fee7 (0x4671b8 0x528be0 0xb 0x1c69c128)
    0x8be53e88 : 0x14014b (0x528be0 0x19f5a8b8 0xa4481b 0x86)
    0x8be53ed8 : 0x19c361 (0x8be4f04c 0x1b488edc 0xf9c5 0x0)
    0x8be53f28 : 0x1aa132 (0x1 0x509ad3 0x0 0x193d1d)
    0x8be53f78 : 0x1b1680 (0x19f1c8c0 0x8be7e000 0x8be53fa8 0x86)
    0x8be53f98 : 0x44d6ee (0xde 0x19f1c8c0 0x19cd87d8 0x1)
    0x8be53fd8 : 0x1a18c4 (0x19f1c8c0 0x0 0x0 0x0)
    Backtrace terminated-invalid frame pointer 0xb3

    BSD process name corresponding to current thread: HandBrake

    Mac OS version:
    9J61

    Kernel version:
    Darwin Kernel Version 9.7.0: Tue Mar 31 22:52:17 PDT 2009; root:xnu-1228.12.14~1/RELEASE_I386
    System model name: MacPro4,1 (Mac-F221BEC8)
    And this the third one - nothing specific happening here, just browsing Mactalk.

    Interval Since Last Panic Report: 165000 sec
    Panics Since Last Report: 1
    Anonymous UUID: 037AE4F7-CAEB-4735-B7C2-D5A3EB80907C

    Fri Aug 7 20:53:04 2009
    Machine-check capabilities (cpu 11) 0x0000000000001c09:
    family: 6 model: 26 stepping: 5 microcode: 15
    Intel(R) Xeon(R) CPU E5520 @ 2.27GHz
    9 error-reporting banks
    threshold-based error status present
    extended corrected memory error handling present
    Machine-check status 0x0000000000000004:
    machine-check in progress
    MCA error-reporting registers:
    IA32_MC0_STATUS(0x401): 0x0000000000000800 invalid
    IA32_MC1_STATUS(0x405): 0x0000000000000800 invalid
    IA32_MC2_STATUS(0x409): 0x0000000000000000 invalid
    IA32_MC3_STATUS(0x40d): 0x0000000000000000 invalid
    IA32_MC4_STATUS(0x411): 0x0000000000000000 invalid
    IA32_MC5_STATUS(0x415): 0xbe00000000800400 valid
    MCA error code: 0x0400
    Model specific error code: 0x0080
    Other information: 0x00000000
    Threshold-based status: Undefined
    Status bits:
    Processor context corrupt
    ADDR register valid
    MISC register valid
    Error enabled
    Uncorrected error
    IA32_MC5_ADDR(0x416): 0x000000000040eebc
    IA32_MC5_MISC(0x417): 0x0000000000000000
    IA32_MC6_STATUS(0x419): 0x0000000000000000 invalid
    IA32_MC7_STATUS(0x41d): 0x0000000000000000 invalid
    Package 1 logged:
    IA32_MC8_STATUS(0x421): 0x0000000000000000 invalid
    Package 0 logged:
    IA32_MC8_STATUS(0x421): 0x0000000000000000 invalid
    panic(cpu 11 caller 0x001AAA68): Machine Check at 0x0040eebc, thread:0x10a6f128, trapno:0x12, err:0x0, registers:
    CR0: 0x8001003b, CR2: 0x28c6e7fc, CR3: 0x01261000, CR4: 0x00000660
    EAX: 0x10cb64c0, EBX: 0x00000001, ECX: 0x00000001, EDX: 0x00000010
    ESP: 0x8c47fe10, EBP: 0x8c47fe38, ESI: 0x10a56cc0, EDI: 0x20fc3480
    EFL: 0x00010206, EIP: 0x0040eebc

    Backtrace (CPU 11), Frame : Return Address (4 potential args on stack)
    0x8be82fb8 : 0x12b4c6 (0x45ec20 0x8be82fec 0x13355c 0x0)
    0x8be83008 : 0x1aaa68 (0x468bc0 0x40eebc 0x10a6f128 0x12)
    0x8be830e8 : 0x1a2553 (0x8be83100 0x401ff4ab 0x803fe956 0x7fd2ad)
    0x8c47fe38 : 0x41fe28 (0x10c89000 0x10a56cc0 0x10 0x12849d78)
    0x8c47fe68 : 0x4209bc (0x10c89000 0x20fc3480 0x0 0x12849d80)
    0x8c47feb8 : 0x41b133 (0x10c89000 0x20fc3480 0x10cb65c0 0x4f9880)
    0x8c47fee8 : 0x420e1d (0x10cb65c0 0x8bf0b024 0x19fec4 0x528be0)
    0x8c47ff28 : 0x41c944 (0x10c89000 0x20fc3480 0x10a8cec0 0x1a436f)
    0x8c47ff68 : 0x425118 (0x10a8cec0 0x23dd808c 0x23dd8064 0x13ec8f)
    0x8c47ff98 : 0x424dfa (0x10a8cfc0 0x0 0x23dd8048 0x132386)
    0x8c47ffc8 : 0x1a14ec (0x10a8cfc0 0x0 0x1a40b5 0x23dd8048)
    Backtrace terminated-invalid frame pointer 0

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9J61

    Kernel version:
    Darwin Kernel Version 9.7.0: Tue Mar 31 22:52:17 PDT 2009; root:xnu-1228.12.14~1/RELEASE_I386
    System model name: MacPro4,1 (Mac-F221BEC8)
    I did an extended AHT after the last but one panic - didn't come up with anything.

    Short of reloading the OS or contacting Apple (MP is less than one month old) is there anything obvious there to anybody?
    Kushti

  2. #2

    Join Date
    Mar 2009
    Location
    Brisbane
    Posts
    62

    Default

    did you plug in anything new (ie USB drive, mouse, new ram) or install any new software since it went all screwy?

    Do you have a Time Machine backup of your system before the problemns started? If so, maybe reverting to that may help

    lastly- maybe reseat the RAM (though that's usually for kernel panics during startup)
    controller1.com
    20" iMac CD 2.0, 12" Powerbook 1.5, G5 Quad PowerMac 16GB, Mac Pro 2.93 Quad, iPad

  3. #3

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    I think... you should take it back on the possibility of a problem with the logic board.

  4. #4

    Default

    Kernel Panics are frustrating. I was in exactly the same position as you with a new machine. Sometimes they are due to software conflicts. Does it occur with the same program at the same time? Have you updated the OS recently? Have you installed any new peripherals? Sometimes they can be indicative of a hardware problem, eg motherboard for example. I had never had a KP until I got my machine. Turned out to be a lemon. Maybe also run Apple Hardware Test and a few other system utilities, see how it goes. If not, return to apple. Seems strange though, as they run the Refurbs for days to make sure they are OK before selling

    Try this Resolving Kernel Panics

    Wokka

  5. #5

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    Quote Originally Posted by Mac Ram View Post
    I did an extended AHT after the last but one panic - didn't come up with anything.
    He's already done an Apple Hardware Test.

    There's nothing that stands out in those logs.

    1 month old. Take it and those logs back into a Service Centre.

  6. #6

    Join Date
    Sep 2006
    Location
    Perth
    Posts
    1,695

    Default

    I did run the AHT, however after talking with Apple support, I realise I didn't run it in loop mode. I shall do this tonight and see if it comes up with anything.

    My fault for not reading the instructions properly....
    Kushti

  7. #7

    Join Date
    Sep 2006
    Location
    Perth
    Posts
    1,695

    Default

    An update.....

    Ran AHT for 12 hours yesterday - found no issues.

    I was able to replicate the error at will yesterday - simply run a handbrake encode.

    Today I have reloaded the OS and all apps. Have got rid of a lot of crud that had amassed over the years and migrated between machines.

    Ran the handbrake encode, went ok.

    Fingers crossed it was some rogue bit of s/w.
    Kushti

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •