Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 14 of 14
  1. #1

    Join Date
    Aug 2008
    Location
    Thursday Island
    Posts
    201

    Default Command+Z not working

    I have a Macbook and my Command+Z does not work.

    It actually performs the shortcut for Command+C or just C depending on which application I am in.

    I can still do Command+C, can type Z and C and otherwise my keyboard works as normal.

    Any ideas?

    Cheers, Jack

  2. #2

    Join Date
    Apr 2009
    Location
    QLD, Australia
    Posts
    881

    Default

    try looking in system preferences > keyboard and mouse > keyboard shortcuts > restore defaults.

    should fix your problem. i had similar, and solved it this way.

  3. #3

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    Is it System wide or is it only in one Application?

  4. #4

    Join Date
    Aug 2008
    Location
    Thursday Island
    Posts
    201

    Default

    No, I already tried that, thanks though.

    Cheers, Jack

  5. #5

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    Is it System wide or is it only in one Application?

    Is the Undo function not occurring with any application, or just one, or just a few?

    If so, which ones?

  6. #6

    Join Date
    Aug 2008
    Location
    Thursday Island
    Posts
    201

    Default

    It definitely doesn't work in iPhoto or Photoshop, are there any others I should check?

  7. #7

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    Try it in TextEdit - the simplest test Application - type some text - gobbledygook - and then hit Apple-Command key + Z key, to Undo that text.

  8. #8

    Join Date
    Aug 2008
    Location
    Thursday Island
    Posts
    201

    Default

    It didn't work in text edit and I tried it unsuccessfully while replying to this thread so it doesn't work in Safari either.

    Cheers, Jack

  9. #9

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    Simplest.

    Could you shut down your Mac - then leave it for a minute, and then power it up again.

    Also check if clicking on menu item: Edit and scrolling down to: Undo - works or not.

  10. #10

    Join Date
    Aug 2008
    Location
    Thursday Island
    Posts
    201

    Default

    I shut down for around 5 minutes but it still doesn't work.

    I can undo via mouse click from the drop down menu under edit.

    Cheers, Jack

  11. #11

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    In your System Preferences, in Speech, have you set Text to Speech up with Z, in the Speak selected text when the key is pressed - Set Key... button?

    Or - set Z to perform any other automated action as a hot key, recently?

  12. #12

    Join Date
    Aug 2008
    Location
    Thursday Island
    Posts
    201

    Default

    Clockwork, you are a genius.

    I have never been into the Speech settings but when I went there it had Command+Z as the button.
    I couldn't figure out how to set it to no button so it is now set as Command+W.
    Will that affect anything else?

    Command+Z now works as the undo in Text Edit and Safari, I will now check it in iPhoto and Photoshop.

  13. #13

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    It's possible that OS X automatically put that feature in during installation.

    Mac OS X 10.5.7 is one bad ass OS.

    Read it mods.

  14. #14

    Join Date
    May 2006
    Location
    Royston Vasey
    Posts
    9,549

    Default

    Quote Originally Posted by jacke View Post
    I couldn't figure out how to set it to no button so it is now set as Command+W.
    Will that affect anything else?
    + W allows you to Close Window, and + option + W allows you to Close All Windows.

    In Text to Speech, just untick the Speak selected text when the key is pressed check box, and the whole Set Key... option will grey out, so you don't need to set it to anything.

    No more disabled key commands.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •