Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 20 of 20
  1. #1

    Join Date
    May 2005
    Location
    Melbourne
    Posts
    273

    Default

    How do I get my Powerbook to automatically connect to my wireless network when it is woken up from being asleep???

    I can't figure it out....


    Thanks.

    ppops.

  2. #2

    Default

    My iBook does it by default - even after power off.
    Running 10.4.1?
    Notebook: Apple 15" MacBook Pro 2.4GHz (Penryn)

  3. #3

    Default

    I was just about to post the exact same question. At the moment I've gotta click on airport and choose the single network available everytime I open the powerbook from sleep. there must be some way around this.

  4. #4

    Default

    I'm running tiger.

  5. #5

    Join Date
    Jul 2004
    Location
    The Shire, Sydney
    Posts
    1,207

    Default

    My PowerBook has done that since the day I got wireless. I was using Panther then, and it seemed to do it by default. Have a look in System preferences and in internet connect and see if there is anything in there to click for AutoConnect.


    -Andrew

    This is an email virus for Mac OS X. It works on the honor system. Please start deleting random files on your system and forward this message to everyone in your address book.

  6. #6

    Join Date
    May 2005
    Location
    Melbourne
    Posts
    273

    Default

    Yeah I'm running 10.4.1

    I had a look, couldn't find any options. Dunno......

  7. #7

    Join Date
    Dec 2004
    Location
    Brisbane
    Posts
    694

    Default

    Mine connects automatically after sleep and startup. At a quick search, the only thing i can find which i think MIGHT do it is...

    System preferences > Network > Select Airport, then click on configure btn > Location set to "automatic" > show airport > then under airport section "by default join" > automatic

    also might have to add network password to keychain

    hope this helps

    Edit - sorry, left out a small step, now ammended
    Pain is temporary. Quiting lasts forever.

  8. #8

    Join Date
    Nov 2004
    Location
    Parramatta
    Posts
    3,357

    Default

    i also have this problem... how to fix.. i got no idea..
    Just Chillin.

  9. #9

    Join Date
    Jul 2004
    Location
    Dubai - Mactalk Mid East Correspondent
    Posts
    250

    Default

    i cant remember ever doing anything - but mine connects to both work and home automatically - without need for passwords on either.

    under the 'by default join' mine says 'preferred networks', and in it i have added in the networks i want it to choose from than just scanning the area for any avaliable.

    *edit spelling*
    C2D 2.16ghz Macbook Black, iPod Video 30GB Black 5G, iPod Nano Red 5G 16Gb, iPod Shuffle Black 4GB, 24in C2D iMac 2.4ghz, Time Capsule 500GB (dead), Airport Express 1G x 2, Airport Extreme, Apple TV, iPad 64GB 3G, iPhone 4, Apple TV 2

  10. #10

    Join Date
    Apr 2005
    Location
    Melbourne
    Posts
    2,671

    Default

    Yeah all working here on a Mini
    MacBook Pro Core 2 Duo 15" | iMac Core 2 Duo 20"
    iPod 5G 30GB | iPod nano 4GB | Apple TV 40GB | iPhone 3G 8GB

  11. #11

    Default

    Never had this problem with the two powerbooks in my home. I have had it not find a network when booted a couple of times. fixed this by turning airport off and then on again...

  12. #12

    Default

    Try deleting any wireless network passwords in your Keychain Access app.

  13. #13

    Join Date
    Jan 2004
    Location
    Brisbane, QLD.
    Posts
    124

    Default

    I had this problem go to system preferences, network and make sure your airport connection is on the top. I don't remember exactly but you either do it by clicking and dragging or pressing configure. Would try but i'm on the UQ wireless and i really should be studying. Hope this helps.

    Edit: I think your location will also have to be set to automatic, I think there has been a previous thread about this, I think thats where i got my solution but i'm really not too sure

    2.3 GHz Intel Core i5 Mac mini, 8GB Ram

  14. #14

    Join Date
    May 2005
    Location
    Melbourne
    Posts
    273

    Default

    OK, I had a real fiddle around with this and tried a few things.

    First I disabled WEP encryption hence not needing a password and the damn thing worked. It connected automatically when I restarted and woke it up from sleeping. But this is not a solution I'm willing to live with.....I want encryption on my network.
    So obviously it must have something to do with the password and/or keychain manager......I tried everything with that but I couldn't get it to work with a password.

    Thanks for the help so far.


    ppops.

  15. #15

    Join Date
    Jul 2004
    Location
    Brisbane, Australia
    Posts
    3,215

    Default

    Howdy ppops,

    Since recently going wireless with my Airport Express and my 15" PB, it has reconnected everytime so I'm not sure what to suggest as far as a Settings solution.. have you checked to see if there is anything in the official Apple website discussion boards? might be worth a look-see in case the issue's been raised there.. if you find out and get it fixed, it'd be great if you could post back with the solution/fix so others in the future can read the thread and find the same answer.. cheers.

    Anyways, the reason for my post is that I noticed you are using WEP encryption for your wireless network with your PowerBook? Any reason why you aren't using the much more secure WPA encryption?

    Just recently this site listed in its news articles a report on how easy it was to crack the WEP encryption, so it might be worth looking into moving to the WPA encryption system if your hardware is capable.. I imagine that no wireless system is 100% secure, but i feel more comfortable using WPA when i've got no less than 3 other networks around me in my converted terrace house apartment block, and none of them bother with locking down their access..

    Have a Google on both methods to learn more.. here's a really basic article but its a start.

  16. #16

    Join Date
    May 2005
    Location
    Melbourne
    Posts
    273

    Default

    My wireless router doesn't support WPA. Doh!

    Thanks for the info! I'm gonna check out the Apple discussion boards now!!

  17. #17

    Join Date
    May 2005
    Location
    Melbourne
    Posts
    273

    Default

    Wooohoo!!! I've fixed it! It looks like a lot of ppl were having trouble with this on the Apple Discussion boards......this worked for me but not everyone, so I hope it works for you guys.


    I'm not sure why this worked but it did. lol


    1. Delete all locations.

    2. Add your location again.

    3. Make sure it looks like this:



    Mine didn't before. Instead of "Preferred Networks" it had "A Specific Location".

    Weird but it looked different underneath that as well.

    Hope this helps anyone with the problem......

  18. #18

    Join Date
    Apr 2005
    Location
    Melbourne
    Posts
    60

    Default

    yeah someone else was saying that you could delete the airport preferences in

    /Library/Preferences






  19. #19

    Join Date
    Nov 2004
    Location
    Parramatta
    Posts
    3,357

    Default

    doesnt work for me
    Just Chillin.

  20. #20

    Default

    I had this issue with my imac g5 when i had a 802.11b wireless access point. I setup the automatic preferences, but would never connect.
    I upgraded my access point to a 802.11g and now the imac connects automatically.

    maybe a coincidence, but it's now working ....
    Successful trades - islayer

    G4 QS 933MHz 512/2x60GB SuperDrive
    iMac G5 20" 1GB/160GB SuperDrive AirPort Extreme Bluetooth
    iPod Mini 4GB
    iPod 4G 20GB Clickwheel

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •