Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 5 of 5
  1. #1

    Default Pismo wont power on...

    G'day,

    I just grabbed the Pismo, which was sitting with the yoyo connected, flashing in standby mode... unplugged, and opened it up... but it didn't turn on. The standby light stopped flashing - even when I shut it back up, and tried to open it again to wake it.

    I tried the power button... but no good. Would neither power off, or power on.

    Checked the battery - 4 solid green lights. Tried plugging the yoyo back in - still no good.

    Pulled the battery out, and put it in the optical drive side. Power button - nothing.

    Tried holding COM OPT P R and powering on... got a solid BEEP (lasted maybe 3 seconds), and then nothing.

    Tried the power button a few more times... one time the screen flashed white for all of a millisecond, but that's all.

    The PRAM battery is most certainly dead. Haven't replaced it, cos they're rare as hens teeth, and so I just try keep the battery charged so it doesn't "go out".

    Any suggestions/thoughts what's happened? Gonna be sad if she's died...


    cheers

    cosmic
    MacTalk - the bianca's of geekdom
    thecosmichobo - as seen on YouTube - "How Doomsday Should Have Ended!" "Bigger on the Inside?" "The Doctor Falls - With Hartnell!" and lots more!

  2. #2

    Default

    :o Just tried the reset button under the flap... she's started up ok now.
    MacTalk - the bianca's of geekdom
    thecosmichobo - as seen on YouTube - "How Doomsday Should Have Ended!" "Bigger on the Inside?" "The Doctor Falls - With Hartnell!" and lots more!

  3. #3

    Join Date
    Oct 2008
    Location
    Perth, WA
    Posts
    1,068

    Default

    Thank God..

  4. #4

    Join Date
    Feb 2005
    Location
    Brunswick, Victoria
    Posts
    4,780

    Default

    Rare as hen's teeth???

    NewerTech Replacement PRAM/clock battery for... (922-3829) at OWC <-- Thats the PRAM battery right there.

    besides its a pain in the arse to install these, I did it on a PowerBook 540C. well just to make my own..

    Probably easier if you did make your own, just get the same type of batteries, replace them with the ones in the cell, resolder and put black tape over them..

    Thats all you have to do!

  5. #5

    Join Date
    Nov 2004
    Location
    Adelaide
    Posts
    1,442

    Default

    Quote Originally Posted by cosmichobo View Post
    The PRAM battery is most certainly dead. Haven't replaced it, cos they're rare as hens teeth, and so I just try keep the battery charged so it doesn't "go out".
    I got one on ebay from the US just before Christmas for $12. There was quite a number to choose from.

    I guess with computers this old now, there's always a chance when you turn them on that something will go wrong and they'll fail to start up...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •