Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 7 of 7
  1. #1

    Join Date
    Oct 2007
    Location
    Brisneyland
    Posts
    393

    Default Can't get Skype to stay in the dock

    Every time I try to drag Skype.app into the dock, it stays there for a few seconds then "poofs" off to the right without me doing anything. I've had Skype in the dock for this whole year, and this just started happening yesterday, so it's not an issue of me running it from the dmg or something.

    I've tried to capture a video of it happening, so hopefully this works:

    VIDEO NO WORKY

    I do have MobileMe, but I have Dock Syncing turned off:


    Click for full size - Uploaded with plasq's Skitch

    I've rebooted and repaired permissions, but that's all I've tried as I'm not sure what else I can do.

    Any tips?

  2. #2

    Join Date
    Oct 2007
    Location
    Brisneyland
    Posts
    393

    Default

    Bumpzies!

  3. #3

    Join Date
    Jun 2004
    Location
    Canberra ACT
    Posts
    3,171

    Default

    Rather than drag it to the dock...
    double click on it (to open the app)
    then once it is open - have you tried right clicking on the icon, and selecting the "Keep In Dock" option?
    mulitple iOS devices - iPhone, iPad Air, and iPod nano
    Mac OS X
    - 13 MacBook Pro with Retina, Mac mini for media server, and a Mac Book Air here somewhere still too

  4. #4

    Join Date
    Aug 2005
    Location
    Melbourne
    Posts
    1,449

    Default

    You can also try re-downloading Skype. There may be a newer version of this that fixes this "bug." I know you said it has been working fine for ages. Very possibly, the file got corrupted somehow.
     Mac Pro 2x2.26GHz Quad-Core Intel Xeon/16GB/3x1TB WD (Black) + 80GB Intel X-25M G2 |  24" LED Cinema Display |  MBP 13" 2.26GHz/4GB/120GB Intel X-25M SSD + 500GB (Optical Bay) |  Mac Mini 2.0GHz/4GB/320GB/256MB 9400M.

  5. #5

    Join Date
    Oct 2007
    Location
    Brisneyland
    Posts
    393

    Default

    Quote Originally Posted by DJY View Post
    Rather than drag it to the dock...
    double click on it (to open the app)
    then once it is open - have you tried right clicking on the icon, and selecting the "Keep In Dock" option?
    Good idea... but it only says Remove From Dock, no Keep in Dock in sight


    Click for full size - Uploaded with plasq's Skitch

    Quote Originally Posted by DeanCorp View Post
    You can also try re-downloading Skype. There may be a newer version of this that fixes this "bug." I know you said it has been working fine for ages. Very possibly, the file got corrupted somehow.
    Tried this. No luck.

  6. #6

    Join Date
    Aug 2005
    Location
    Melbourne
    Posts
    1,449

    Default

    Try Repairing Disk/Permissions.
     Mac Pro 2x2.26GHz Quad-Core Intel Xeon/16GB/3x1TB WD (Black) + 80GB Intel X-25M G2 |  24" LED Cinema Display |  MBP 13" 2.26GHz/4GB/120GB Intel X-25M SSD + 500GB (Optical Bay) |  Mac Mini 2.0GHz/4GB/320GB/256MB 9400M.

  7. #7

    Join Date
    Jun 2008
    Location
    Brisbane
    Posts
    480

    Default

    Try deleting the preference files for it. They're located here:

    /Library/Preferences/com.skype.skype.plist
    ~/Library/Preferences/com.skype.skype.plist
    ~/Library/Preferences/com.skype.skype.plist

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •