Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 5 of 5
  1. #1

    Join Date
    Mar 2007
    Location
    Sydney
    Posts
    921

    Default can't disconnect from shared external HD

    We have a Freeagent drive attached to the Pee Cee which I share with the macs. Recently I have had a new problem with one particular folder - the machine won't let me disconnect, telling me it is 'in use'. What could be causing this, and does anyone have any ideas on how to fix it?

    Thanks,
    Deb
    Macintosh SE (OS 7.1); 15" MBP Intel Core i5 2.4ghz (Snow Leopard); too many iGadgets

  2. #2

    Join Date
    Feb 2004
    Posts
    9,050

    Default

    It means some or other program is using a file or files on that drive. Quit programs until you are able to eject the drive. If that doesn't work, there are other ways to work out what program is responsible.
    The discussion has continued at AppleTalk Australia.

  3. #3

    Join Date
    Mar 2007
    Location
    Sydney
    Posts
    921

    Default

    Thanks, Currawong. I have quite everything and it still won't budge. I have tried looking at activity monitor to see what it is but it is all gobbldygook to me! What should I be looking for?

    Thanks,
    Deb
    Macintosh SE (OS 7.1); 15" MBP Intel Core i5 2.4ghz (Snow Leopard); too many iGadgets

  4. #4

    Join Date
    Feb 2004
    Posts
    9,050

    Default

    Open the Terminal and type this:

    lsof -n | grep "Hard Drive Name"

    Replace HardDriveName with the name of the disk. Make sure you get the capitalisation of the drive name right as it's case-sensitive. It will list what programs and files are open on that drive. Paste the results here.
    The discussion has continued at AppleTalk Australia.

  5. #5

    Join Date
    Mar 2007
    Location
    Sydney
    Posts
    921

    Default

    I think I must have done it wrong, because I get this....
    grep: HD: No such file or directory


    Should I be typing the name of the external HD or my computer's main HD?

    Ta
    Macintosh SE (OS 7.1); 15" MBP Intel Core i5 2.4ghz (Snow Leopard); too many iGadgets

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •