Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 5 of 5
  1. #1

    Join Date
    Dec 2006
    Location
    Sydney Metropolitan
    Posts
    2,079

    Default A couple of System Prefs changing of their own accord

    One problem has me scratching my head and the other has me feeling a little sheepish.

    Every now and then some of my preferences seem to change. Not all of them, just a couple.
    Changing the volume sometimes makes pop noises but when I check Sound preferences the checkbox for giving feedback is unticked (I tick and untick and the pops go away).
    My international menu should always have menus for showing the Character Palette and the Keyboard Viewer. Sometimes both of these options disappear (and I have to re-enable them in International preferences). I haven't been fiddling with things that would make these randomly change, at least I don't think so...

    The other problem is [SOLVED] some of the toolbar buttons in things like the Finder, ARD, etc. They just look wrong. Examples are:





    I had installed CrystalClear interface (Musings from Mars ) and uninstalled it and everything was ok, then I replaced the Extras2.rsrc in the Carbon.framework (yeah, System folder, I know I'm not supposed to touch but I wanted iTunes-like scroll bars in the Finder, instead of those Aqua/Candy ones that are so 2001) and then that was ok for a while, but then I decided to show off and installed the CrystalClear interface again (without the Scrollbar, etc. gui hacks) and uninstalled it and now I'm stuck with these crappy looking buttons.

    Any suggestions? I've replaced the Extras2.rsrc file a couple of times to no effect... I think I'm almost out of ideas here.
    Should/Could/Would

  2. #2

    Join Date
    Dec 2006
    Location
    Sydney Metropolitan
    Posts
    2,079

    Default

    bump - finished the edit (sorry for a false start, I'm VNC'ed to a Linux box...)
    Should/Could/Would

  3. #3

    Join Date
    Jan 2004
    Location
    Adelaide
    Posts
    6,201

    Default

    Quote Originally Posted by iPirate View Post
    I had installed CrystalClear interface (Musings from Mars ) and uninstalled it and everything was ok
    Install that again, but this time when Installer.app opens, enable the log viewer window to show you what all the changes it makes are.

    I'd bet there's a 90% chance that app caused your problem.
    Read my drivel, be dazzled by my Twitter

    Are you some kind of devil trying to keep me from using my time usefully? - Currawong
    "You're an enigma wrapped in a ferreo roche" - fulltimecasual

  4. #4

    Join Date
    Dec 2006
    Location
    Sydney Metropolitan
    Posts
    2,079

    Default

    I bet it is... so how do I change it back..? Lol.

    In the finder it just seems to be the first two sets of buttons. As for ARD, the buttons look even worse in the Crystal Clear interface, so that mightn't be such a crystal clear-affected thing.

    The logs weren't particularly helpful, so maybe I'll just run the uninstaller again and try to remember how do all the things that got me to where I was happier this morning.
    Should/Could/Would

  5. #5

    Join Date
    Dec 2006
    Location
    Sydney Metropolitan
    Posts
    2,079

    Default

    Check that, the logs were helpful after all, they complained that some program called "GraphicsToggle" didn't exist. I found it in the disk image installer thingy and ran it and it's fixed the buttons.

    Many thanks...

    Now to those pesky preferences changing... although that's not so pressing.
    Should/Could/Would

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •