Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 8 of 8
  1. #1

    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    6,561

    Default Aperture 2.1 - Imported pictures saving to Pictures folder, not the Aperture library

    As a recent purchaser of Aperture, I am running 2.1 and having an issue with regards to the importation of pictures.
    When I connect my Canon G6 to my computer I have set Aperture to be the default app that opens. I begin a new Project, name it what I want and then import from the camera into this project. What I have found is that these pictures are not stored in the Aperture Library package, but rather are put into my Pictures folder in their own folder, which has the same name as the project. I don't like this as it is making a mess of my pictures folder by having too many folders in there. How can I make the pictures that I have imported from camera automatically go into the Aperture Library package file.

    I have previously imported photo's from an external HDD and they were put into the Aperture library package. Why is this not occurring when I import directly from a camera? I am importing RAW files from the G6.
    Something about Jimby.

  2. #2

    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    6,561

    Default

    Bumping. Does anyone have a clue as to why this is happening? Does it have something to do with importing RAW files?
    Something about Jimby.

  3. #3

    Default

    I'm going to presume that you've selected the library location in preferences and double checked that??
    PHOTOGRAPHY | FACEBOOK FANPAGE | BLOG
    Professional Photographer | Sydney, Australia

  4. #4

    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    6,561

    Default

    I want the pictures to be put into the Aperture library package file. What I am finding is that my photos are being put into the /user/Pictures folder and not being incorporated into the /user/Pictures/Aperture.library file. Will check preferences, but this has only been happening since 2.1 and only when I import directly from the camera. Does not happen if I import pictures from an external HDD.
    Something about Jimby.

  5. #5

    Join Date
    Mar 2007
    Location
    Ellenbrook, WA
    Posts
    6,102

    Default

    When you click on the external source for your importing pictures there is a section that appears on the right hand side of the display, top section deals with Image Information - next block down says Store Files - with a drop down - change it to Aperture Library - make sure it stays on this when you select the media you are importing from.
     iPhone & iPhone 3GS, Macbook Pro 17" C2D 2.8ghz. iMac alu. 20" C2D 2ghz. iMac 20" CD 2ghz & Cube 450mhz. Website

  6. #6

    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    6,561

    Default

    Quote Originally Posted by Lutze View Post
    When you click on the external source for your importing pictures there is a section that appears on the right hand side of the display, top section deals with Image Information - next block down says Store Files - with a drop down - change it to Aperture Library - make sure it stays on this when you select the media you are importing from.
    Thanks for that. Will try when I get back home.
    Something about Jimby.

  7. #7

    Join Date
    Oct 2005
    Location
    Melbourne
    Posts
    6,561

    Default

    Thanks Lutze. Never noticed that drop down. Was driving me up the bend as I had the Aperture library set in my preferences as default, but it wasn't occurring. All good now.
    Something about Jimby.

  8. #8

    Join Date
    Mar 2007
    Location
    Ellenbrook, WA
    Posts
    6,102

    Default

    Glad to be of help!
     iPhone & iPhone 3GS, Macbook Pro 17" C2D 2.8ghz. iMac alu. 20" C2D 2ghz. iMac 20" CD 2ghz & Cube 450mhz. Website

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •