Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 18 of 18
  1. #1

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default BlackBook 2.0 C2D weird interference/soft squealing/buzzing noise..!

    Hello,

    As per a thread of a few days ago, I grabbed a refurb blackbook from the apple website. It's a 2.0Ghz C2D, 1gb RAM, 120Gb HD.

    I'm really happy with it - frontrow is fantastic and I've never had an iSight before - except for one thing :

    There is a weird soft squealing, very electrical noise that is intermittently coming from under the keyboard - around the W key.

    It's hard to describe. It's kind of like a very high-pitched buzz, (lower than the noise a fan makes though), that is very electrical in nature. It kind of goes Bzzzzzzzz-bz-bzzzzzt-bzzzzzzzzzzz..

    It's very soft and but I can clearly hear it with the MB sitting on my lap, and the TV on in the next room. It seems to come and go, but I can't yet discern a pattern.

    What I am certain of, though, is that it is somehow related to the processor or a function of the computer; at least, it's not a fan. I know this because the noise is related to what is happening on-screen; the best example is if I go into System Preferences, the noise pauses briefly in the transition between loading different preference panes.

    I have a mic and I might try to capture this noise if it's not familiar to anyone.. will post immediately when/if I do.

    As I mentioned before, this is a refurb unit, and I am really happy with everything else about it. It was in great condition, and they even included two apple remotes (oops)
    Not sure what to do; should I ring Apple?

    Cheers,

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  2. #2

    Join Date
    Jul 2007
    Location
    Adelaide
    Posts
    23

    Default

    I would take it to your local Apple service centre as it is under warranty. Might take a week or more to get fixed but at least you will have peace of mind
    15" Macbook Pro 2.5GHz C2D, 16GB Black iPhone 3GS

  3. #3

    Join Date
    Jun 2007
    Location
    Brisbane
    Posts
    2,432

    Default

    I think I know what you are talking about.

    I seem to only get it on my C2D Macbook when the charger is plugged in and the battery is fully charged (ie it's running on AC power) I have found that scrolling using the two finger track pad technique temporary stops it. Try those two things...is that the noise your talking about?

    I have no idea what it is or how to stop it though. But based on my observations I am guessing something to do with the Magsafe connecting magnetically to the MacBook although I don't know why scrolling would affect that

    Cheers.

  4. #4

    Join Date
    Jul 2006
    Location
    UK - AUS - NZ
    Posts
    2,296

    Default

    If you connect a bluetooth device it should stop.... try this. Either way- its a warranty issue i think
    My Mountain Bike Blog

    Sweet trades simo, avolve, Jedda, zmit, ryano (x2), emerson, Nevets_Anderson, cbennie, step_andy and more...

  5. #5

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    SA, thanks, I think I will take it in to the apple store but hoped to get some opinions here before I went in.

    Andrew - yeah, I think it's similar - mine stops very briefly when I pull the magsafe out, and changes slightly.. When I plug it back in, it seems to get more ferocious as the LED goes green.

    Cant figure out whether it's CPU, GPU, or power related; it doesn't seem to be affected when I dim/turn off the LCD so I dont think its the inverter (but it sounds like a capacitor or coil is no good anyway)

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  6. #6

    Join Date
    Feb 2006
    Location
    Melbourne
    Posts
    454

    Default

    Hey again Jeremy!

    Congrats on the new Mac.

    The sound that you are hearing has to do with CPU throttling and napping for your processor.

    Your processor has a feature called 'napping', which enables it to throttle its power draw when idling. It is these fluctuations in power draw that cause the 'hissing' or 'chirping' sound that you are hearing.

    It's pretty standard processor noise, and unfortunately, Apple will tell you that this is normal operation, and not to worry. There are however, a few things that you can try to at least calm the noise down.

    A google search reveals a fair bit of stuff : http://www.google.com/search?q=macbook%20hiss%20napping

    You can actually disable processor napping using some tools, and this will certainly get rid of it.

    If it is still bothering you, shoot me an email, and i'll look into it further for you.

  7. #7

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    Quote Originally Posted by ilostmypassword View Post
    If you connect a bluetooth device it should stop.... try this. Either way- its a warranty issue i think
    That's amazing - how'd you know?

    When I sent a file over bluetooth, it did stop, until the file was transferred. Now it's back.
    It didn't stop completely, I felt I could still hear it slightly.. But it's good enough to blame bluetooth

    Thanks!

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  8. #8

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    Quote Originally Posted by Jedda View Post
    Hey again Jeremy!

    Congrats on the new Mac.

    The sound that you are hearing has to do with CPU throttling and napping for your processor.

    Your processor has a feature called 'napping', which enables it to throttle its power draw when idling. It is these fluctuations in power draw that cause the 'hissing' or 'chirping' sound that you are hearing.

    It's pretty standard processor noise, and unfortunately, Apple will tell you that this is normal operation, and not to worry. There are however, a few things that you can try to at least calm the noise down.

    A google search reveals a fair bit of stuff : http://www.google.com/search?q=macbook%20hiss%20napping

    You can actually disable processor napping using some tools, and this will certainly get rid of it.

    If it is still bothering you, shoot me an email, and i'll look into it further for you.
    Cheers Jedda,
    I'll look into that in a bit; back in 45

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  9. #9

    Join Date
    Jul 2006
    Location
    UK - AUS - NZ
    Posts
    2,296

    Default

    Quote Originally Posted by jubilantjeremy View Post
    That's amazing - how'd you know?

    When I sent a file over bluetooth, it did stop, until the file was transferred. Now it's back.
    It didn't stop completely, I felt I could still hear it slightly.. But it's good enough to blame bluetooth

    Thanks!

    - Jeremy
    I'm glad it worked The other options look good and may work better- let us know how you go
    My Mountain Bike Blog

    Sweet trades simo, avolve, Jedda, zmit, ryano (x2), emerson, Nevets_Anderson, cbennie, step_andy and more...

  10. #10

    Join Date
    Jun 2005
    Location
    Cupertino, CA
    Posts
    295

    Default

    Another technique is to open up photobooth. That yields the same as sending a file over BT by giving the cpu a little something to do in the background. Downside of it is your iSight is out of action while it's open.

  11. #11

    Join Date
    Jul 2006
    Location
    UK - AUS - NZ
    Posts
    2,296

    Default

    Here you go- run this - does it help?

    http://www.macupdate.com/info.php/id/22091

    or simply tell photobooth to start on bootup (as mentioned)

    My Mountain Bike Blog

    Sweet trades simo, avolve, Jedda, zmit, ryano (x2), emerson, Nevets_Anderson, cbennie, step_andy and more...

  12. #12

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    ilostmypassword -

    That page you linked certainly DID do the trick. I downloaded the .app the guy compiled and it pretty much completely eliminates the noise.

    However, the fact that I have to do that at all is very lame.

    You guys have been such a help, but I now have a few more questions :

    1. The following terminal code is provided on the page ilostmypassword linked :

    main()
    {
    char* dummy = "blastedPentiumM";

    // Give this process the lowest possible priority
    (void) nice(20);

    // "Use" that CPU
    while (dummy[0] != 'l')
    {
    // Give the CPU a rest. Use a lower value if it's still noisy.
    usleep(100);
    }
    }
    He's compiled that into an .app which I've run, but is there a way to have this run transparently in the background at startup?

    2. Is [running the above code/app] presenting any significant drain on my battery?

    3. Is this likely to fall on sympathetic ears if I ring up Apple? I don't really feel this machine should have been sold to me while it was making this noise, and it if wasn't for you guys helping me out here I'd just have to live with it - or would I?

    Thanks guys,

    Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  13. #13

    Join Date
    Feb 2006
    Location
    Melbourne
    Posts
    454

    Default

    I have compiled the script into a command line tool, that you should be able to drop into startup items. This will run it when you boot your machine.

    http://www.blargsoft.com/files/Quiet.zip

    Give it a go - untested by myself, and it IS past midnight, but it should work.

  14. #14

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    PS,

    There is a larger apple support discussions thread that seems to address the same issue..

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  15. #15

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    Quote Originally Posted by Jedda View Post
    I have compiled the script into a command line tool, that you should be able to drop into startup items. This will run it when you boot your machine.

    http://www.blargsoft.com/files/Quiet.zip

    Give it a go - untested by myself, and it IS past midnight, but it should work.
    Cheers mate,

    Downloaded that and it does the trick beautifully, added it to my startup items.
    On the .app I downloaded there was a slider, and I found that setting the delay to under 110ms or 100ms seemed to make the noise disappear completely. Tried opening your executable in textedit, but I was clearly mistaken about how they worked

    Oh and it's not past midnight here, it's only 10PM, so get back to coding up Ration will you

    Thanks everyone,

    Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  16. #16

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    Update : I tried to take it to an Apple Authorised Service place today, but when I got there it was shut

    I rang apple and spoke to a guy, but he hadn't really heard of the problem - he could only find KB articles in reference to the MBP, and only when the power adapter was in (I get the noise regardless)

    So will take it in again on Monday I guess.. shame..

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


  17. #17

    Join Date
    Jul 2005
    Location
    Sydney
    Posts
    12,045

    Default

    I have the same issue with my white Core Duo MacBook.
    I only noticed it just then,

    It does stop with PhotoBooth running though.

    Now, as I type this, it has stopped completely? I am currently charging my MacBook if that helps...

  18. #18

    Join Date
    Jan 2007
    Location
    Perth
    Posts
    1,725

    Default

    Yeah it seems to stop under intense CPU load, with bluetooth going, with photobooth going, or with the mirror widget going..

    My MB's in the service center atm - hopefully it gets resolved.

    - Jeremy
    Join SqueekyTee (by Rushfaster) using this invite code!
    norobots.net.au - My blog.
    - Lots of macs : MB (black) C2D 2Gb, eMac 1.42Ghz 1.5Gb, eMac 700Mhz, Sawtooth AGP 400Mhz, iBook 800Mhz, iMac 350Mhz, iPod mini, iPod Touch 8Gb and one pretty disorganised life


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •