Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 7 of 7
  1. #1

    Default LameLib in Audacity

    Dear guys,

    I want to export an aup file as an mp3 from audacity. I've downloaded LameLib mp3 encoder and now i'm completely lost. non of the applications within the zip file open and I can't locate the specific file in order to convert to mp3.

    Can anyone help?

    Cheers

  2. #2

    Join Date
    Mar 2005
    Location
    Adelaide
    Posts
    1,423

    Default

    I tried this the other day for the first time. I simply unzipped the Lamelib zip contents to my desktop. When you go to export your MP3 from Audacity, simply point it to the Lamelib file on your desktop when prompted and it'll start encoding. Easy

  3. #3

    Join Date
    Oct 2004
    Location
    Seymour, Vic.
    Posts
    265

    Default

    Not a bad idea to put the unzipped file in a sensible place first. I placed it in the main Audacity folder in Applications.
    'He who controls rhythm, controls.' John Lee Hooker

  4. #4

    Default

    Hi!
    Im trying to get audacity to save files as MP3 for a class and I downloaded LameLib but when I locate it on the disk to show the program where it is it tells me that it was looking for a library named LameLib not libmp3lame.dylib. Any ideas? I placed it in the main audacity folder in applications and everything.

  5. #5

    Join Date
    Mar 2009
    Location
    USA
    Posts
    1

    Default

    Sharpy & Crystal... I had the same problem you describe, and none of the answers given here were helpful. They, in fact, do not seem to understand what the problem is.

    I solved it by going back to the downloads page and downloading the Carbon version of the file, instead of the one that the directions seemed to indicate that I needed. The directions made me end up with a file that was named "libmp3lame.dylib" but Audacity could not recognize it and seemed to be looking specifically for a file named "LameLib". (For the record, I am using Audacity 1.2.6, but since my problem is exactly as you described, my fix might work for you as well.)

    One other important point: After I had unstuffed the LameLib download and placed it in the Audacity folder (since this wasn't an automatic installation), Audacity could find it but it appeared as a grayed-out file and Audacity could not select it. After I restarted Audacity, it was happy to accept this file. I've restarted and exported since then, and Audacity remembers to use this file.

  6. #6

    Join Date
    Jan 2009
    Location
    Canada
    Posts
    18

    Default LameLib in Audacity

    Delighted to find this thread, and hoping you're all still around 6 months later ;-)
    I have the right lamelib download, in the Audacity folder, and have the same greyed-out-hence-unavailable problem. Quitting and restarting Audacity doesn't help. Frustrating! Suggestions? Many TIA. Ch.S.

  7. #7

    Default LameLib carbon version installation

    [I solved it by going back to the downloads page and downloading the Carbon version of the file, ...]

    Thank for the advise to install "LameLib carbon version". I use it without problems.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •