Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

» Join the discussions, Register Now!
Results 1 to 11 of 11
  1. #1

    Join Date
    Apr 2006
    Location
    Langwarrin, VIC
    Posts
    220

    Default Personal Web Sharing is broken

    Hi all,

    I like to play around with things and I have managed to break something this time. The 'Personal Web Sharing' no longer starts for me in the sharing section of the preferences. I use this quite a bit to test a lot of the stuff I have been doing for work lately but hit a snag when I needed PHP to run something. I had successfully done this by using the install package from http://www.entropy.ch/software/macosx/php/ on my Mac Mini some time ago.

    Long story short it didn't work on my MacBook and so then I attempted to get Apache2 and PHP working together, so I found some instructions to do a "build" I guess you call it, I just like to watch stuff happen in Terminal. That didn't work either plus it's not an ideal solution as I like to turn off the 'Personal Web Sharing' from time to time and also like to have it start automatically. I therefore removed where Apache2 was installed which was by itself in something like ~/Apache2 (as the instructions I had found told me to if I wanted to remove it).

    Which brings me back to the 'Personal Web Sharing' does not start. I found the httpd.conf file and restored it to it's default but this has not helped, it's refuses to start from the preferences pane. Any and all help/suggestions are welcomed.

    Thanks!
    Matt
    "Those who dream by day are cognizant of many things which escape those who dream only by night"Quote by Edgar Allan Poe

  2. #2

    Default

    do this at a terminal and tell us the results

    sudo tail /var/log/httpd/error_log

  3. #3

    Join Date
    Apr 2006
    Location
    Langwarrin, VIC
    Posts
    220

    Default

    Quote Originally Posted by Linux_insidev2 View Post
    do this at a terminal and tell us the results

    sudo tail /var/log/httpd/error_log
    This is what I got.. doesn't seem to offer anything helpful though from the look of it. It was last night that I managed to break it and I've tried to restart it today but it just doesn't start even though the first line seems to say it did start.

    [Thu Apr 26 05:24:23 2007] [notice] Apache/1.3.33 (Darwin) PHP/5.2.1 configured -- resuming normal operations
    [Thu Apr 26 05:24:23 2007] [notice] Accept mutex: flock (Default: flock)
    [Wed Apr 25 19:53:25 2007] [error] [client 192.168.0.14] File does not exist: /Library/WebServer/Documents/favicon.ico
    [Wed Apr 25 19:53:29 2007] [error] [client 192.168.0.14] File does not exist: /Library/WebServer/Documents/favicon.ico
    [Wed Apr 25 22:02:40 2007] [error] [client 192.168.0.4] File does not exist: /Library/WebServer/Documents/favicon.ico
    [Wed Apr 25 22:03:03 2007] [error] [client 192.168.0.4] File does not exist: /Library/WebServer/Documents/favicon.ico
    [Wed Apr 25 22:05:23 2007] [error] [client 192.168.0.4] File does not exist: /Library/WebServer/Documents/favicon.ico
    [Wed Apr 25 22:05:28 2007] [error] [client 192.168.0.4] File does not exist: /Library/WebServer/Documents/favicon.ico
    [Wed Apr 25 22:14:48 2007] [notice] caught SIGTERM, shutting down
    "Those who dream by day are cognizant of many things which escape those who dream only by night"Quote by Edgar Allan Poe

  4. #4

    Default

    [Wed Apr 25 22:14:48 2007] [notice] caught SIGTERM, shutting down

    Something, either you or another process is commanding the service to shut down,

    Try this:

    sudo apachectl configtest < this should return Syntax OK

    Also, try running

    sudo httpd -X

  5. #5

    Join Date
    Apr 2006
    Location
    Langwarrin, VIC
    Posts
    220

    Default

    Got this:

    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    fopen: No such file or directory
    httpd: could not open document config file /private/etc/httpd/users/+entropy-php.conf


    Tried to reinstall the package for the PHP install again and now have this:

    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    Processing config file: /private/etc/httpd/users/matthew.conf
    Syntax OK


    And it all seems to be working, thanks for the help Linux_insidev2 you've saved me a headache
    "Those who dream by day are cognizant of many things which escape those who dream only by night"Quote by Edgar Allan Poe

  6. #6

    Default

    Quote Originally Posted by mini_Matt View Post
    Got this:

    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    fopen: No such file or directory
    httpd: could not open document config file /private/etc/httpd/users/+entropy-php.conf


    Tried to reinstall the package for the PHP install again and now have this:

    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    Processing config file: /private/etc/httpd/users/matthewclements.conf
    Syntax OK


    And it all seems to be working, thanks for the help Linux_insidev2 you've saved me a headache
    Yep sounds like entropy left an entry in httpd via /private/etc/httpd/users/ - by the looks of it apache just loads all entries in there, i didn't use entropy, i compiled my own Apache, MySQL and PHP toolchain because my background is in Linux server administration.

    More than happy to help, i hope you have a good time with it. OSX Makes a great web server.

    My website (http://www.cactuar.net/index.php) is powered by a PowerMac G4 and tiger

  7. #7

    Join Date
    Apr 2006
    Location
    Langwarrin, VIC
    Posts
    220

    Default

    Ok well my last problem was solved now I have a different issue on another machine still related to this. Again trying to get php to play nice with me, using the info on this page I did the following.

    sudo tail /var/log/httpd/error_log
    Expected in: flat namespace

    dyld: lazy symbol binding failed: Symbol not found: _ap_php_slprintf
    Referenced from: /usr/local/php5/lib/php/extensions/no-debug-non-zts-20060613/mhash
    Expected in: flat namespace

    dyld: Symbol not found: _ap_php_slprintf
    Referenced from: /usr/local/php5/lib/php/extensions/no-debug-non-zts-20060613/mhash
    Expected in: flat namespace




    sudo httpd -X
    Processing config directory: /private/etc/httpd/users/*.conf
    Processing config file: /private/etc/httpd/users/+entropy-php.conf
    Processing config file: /private/etc/httpd/users/Matthew.conf
    Trace/BPT trap


    Any suggestions on how to fix or what the problem is are appreciated.

    Thanks,
    Matt
    "Those who dream by day are cognizant of many things which escape those who dream only by night"Quote by Edgar Allan Poe

  8. #8

    Default

    Symbol not found errors usually indicate version mismatches between the app and the library it's accessing.

    What version is OSX on that machine? if it's 10.4.9 check the website for that package you are using.

  9. #9

    Join Date
    Mar 2004
    Location
    Berkeley, CA
    Posts
    1,215

    Default

    Just a few comments:

    php is bundled with OS X and needn't be installed. The current version of php on OS X 10.4.9 is 4.4.4

    In order to enable php on OS X, all one needs to do is uncomment its load and add modules lines in /etc/httpd/httpd.conf

    There is no need to use "sudo" to read Apache's log files. Simply tail (or tail -f) /var/log/httpd/error_log will suffice.


    Yep sounds like entropy left an entry in httpd via /private/etc/httpd/users/ - by the looks of it apache just loads all entries in there, i didn't use entropy, i compiled my own Apache, MySQL and PHP toolchain because my background is in Linux server administration.
    Yes, Apache loads all .conf files in /etc/httpd/users due to this line in httpd.conf:

    Include /private/etc/httpd/users/*.conf

    The only files that are supposed to be in "users" are the user.conf files that OS X's Apache creates each time a new account is created.

    Personally, I add a line to httpd.conf like so for additional .conf files such as global vhosts, gzip.conf files and other stuff:

    Include /private/etc/httpd/conf.d/*.conf

    I used conf.d as I like Debian. =)

    Dave

  10. #10

    Join Date
    Apr 2006
    Location
    Langwarrin, VIC
    Posts
    220

    Default

    Quote Originally Posted by Linux_insidev2 View Post
    Symbol not found errors usually indicate version mismatches between the app and the library it's accessing.

    What version is OSX on that machine? if it's 10.4.9 check the website for that package you are using.
    Thanks, it turns out the install package I downlaoded was corrupt for some reason. Downloaded again and it works a treat now.

    Matt
    "Those who dream by day are cognizant of many things which escape those who dream only by night"Quote by Edgar Allan Poe

  11. #11

    Default

    Quote Originally Posted by macdave View Post

    I used conf.d as I like Debian. =)

    As do I,

    Had the joy of working with it daily at Inspired Networking when i was still working there, i only wish i could get Debian to install on my MBP using an external HDD - elilo is bunk.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •