Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

» Join the discussions, Register Now!
Results 1 to 3 of 3
  1. #1

    Join Date
    Mar 2004
    Location
    Geelong
    Posts
    8

    Default

    Does anyone in here ever flashed the Radeon 7000 from PC platform to use on Macintosh?? if so what problems are there? do you have problems from waking up from sleep mode? is there a way of solving the problem?

    Cheers
    Tristan

  2. #2

    Join Date
    Jan 2004
    Location
    Melbourne
    Posts
    6,927

    Default

    Hi Tristan - welcome to the forums

    You've seen this article here, right? It explains how to flash a common Powercolor ATI 7000 32MB PCI card, easily found at Melbourne swapmeets to a Mac version.

    No problems waking from sleep here - once flashed, the card acts just the same as it's original ATI equivalent - but with DVI and TV-out as well

    JB

  3. #3

    Join Date
    Mar 2004
    Location
    Geelong
    Posts
    8

    Default

    Okay I have Radeon VE/7000 Excalibur Video Card that has VGA, s-video & component video, its a PCI 64 meg card.

    When I came home after buying it I put it in my old Pent II 350 mhz PC (spare computer with dust building up on it&#33 that has AGP video card in it.. I put the Radeon 7k in the PCI slot, downloaded the drivers from -

    http://www.appletalkaustralia.com/articles...000flashkit.zip

    I went through the process of flashing it, typed -

    Flashrom -i
    It came up with -

    Adaptor 0
    bn 00
    dn 58
    dID 5159
    asic DDR64
    flash -
    ID -
    Flash type ATMEL
    remap -
    Lock - yes
    Rom size 0x2000

    Then I saved the old ROM from PC, then upload the Mac Flash -

    Flashrom -pm 0 mac7k.bin -f

    Serial Rom
    BIOS Device ID = 0x5144
    ASIC Device ID = 0x5159
    Flash Type ATMEL
    65536 of 65536 bytes verified

    Then I shutdown the PC, take out the Card and put it in My Power Mac 8600, to flash it for Macintosh, run the program -

    "RADEON 7000 Mac ROM v208 Update"

    Go thru agreement etc, then click on 208 flash update, then while its updating I get a message saying -

    ERROR programming devices

    Slot - A1:RV100-A12

    Is it because the video card I have isn't real Radeon 7k or has wrong flash for that type of card?

    Then I got another flash ROM from -
    http://people.freenet.de/amichalak/flashrm2new.sit
    under http://cubeowner.com/kbase/index.php...x_v2&id=62&c=2

    Downloaded it, load it on PC load it as -
    Flashrom -pm 0 m208full.bin -f

    Came up -

    Serial Rom
    BIOS Device ID = 0x5159
    ASIC Device ID = 0x5159
    Flash Type ATMEL
    131072 of 131072 bytes verified

    Then I shut down the PC and put it in Power Mac 8600 and load the program - RADEON 7000 Mac ROM v208 Update, Go thru agreement etc, then click on 208 flash update, waited for a few mins then it comes up to restart, then I restart the computer, connect up 2nd display with that card, came up with black & white virtual lines, then I waited to load in the OS 9.2.2 and went to monitors, the monitors can see the 2nd display, but changed the resolutions but the resolutions are too high for my monitor, only accepts 640x480 75hz, others are like 200hz which is too high (I am using Apple Scan Display 15") as this display is maximum 1024x768 75hz

    Then I flashed the ROM back to PC, the video card is working fine!!

    So either that I have the wrong card that Macintosh wouldn’t accept? Or some sort of programming error?

    What should I do next? If there is anything wrong above or specific ROM flash?

    I was aiming to put this PCI card in the G3 upgraded 8600 or use it in G4 mini tower with TV out hence that is why I wanted a TV out card so can record on the VCR for PowerPoint presentation for work.

    Cheers & thankyou so much for your help.
    Tristan

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •