Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 17 of 17
  1. #1

    Join Date
    Oct 2004
    Location
    Aberfoyle Park
    Posts
    144

    Default

    I have a massive problem here, my PC and my G4 wont network. I have designated them both static IP's, there are no IP conflicts, i can ping each computer succesfully, its just that i cant access each computers files from the other computer. Its been driving me nuts, any help?
    Jam Jam Jam.....Jam Jam Jam

    Macbook 2.4GHZ 4GB RAM 500GB :: MacBookPro 13" 2.16GHZ 2GB RAM 160GB

  2. #2

    Join Date
    Jan 2004
    Location
    Adelaide
    Posts
    6,201

    Default

    OS X 10.3.5 & WindowsXP SP2?

    I assume you have windows filesharing enabled on the mac?
    I did a post here somewhere that summarises it pretty well. I'll do a search. hangon.
    Read my drivel, be dazzled by my Twitter

    Are you some kind of devil trying to keep me from using my time usefully? - Currawong
    "You're an enigma wrapped in a ferreo roche" - fulltimecasual

  3. #3

    Default

    Are they both on the same subnet? i.e. 192.168.1.*

    Have you got Windows Sharing on in the Sharing preferences?

    Try command + k in finder and typing in smb://your.pc.ip.address/

  4. #4

    Join Date
    Jan 2004
    Location
    Adelaide
    Posts
    6,201

    Default

    here it is:

    Ethernet
    Mac:
    - open System Prefs
    - click 'sharing'
    - tick 'windows file sharing' and 'ftp' then click apply
    - go back to system prefs, then into networking
    - make sure you're PC and your mac can see each other, if not assign ip's so they can.

    PC:
    - type the ip address of the mac into the address bar, or browse to it in 'my network places'
    - authenticate in the file menu
    - if this fails, use ftp://<ip address of mac>
    Read my drivel, be dazzled by my Twitter

    Are you some kind of devil trying to keep me from using my time usefully? - Currawong
    "You're an enigma wrapped in a ferreo roche" - fulltimecasual

  5. #5

    Join Date
    Aug 2004
    Location
    Melbourne
    Posts
    127

    Default

    well, i had the same config (osx and xpsp2) and with my gal nagging at me, i fixed the issue.

    First, lets start with user on OSX going to XP
    1 - OSX have &#39;Windows Sharing&#39; turned on
    2 - There are issues with looking for the XP on OSX. I find it easiest to &#39;Connect to Folder&#39; the easiest way. Click tat and type
    smb://192.168.x.x/c&#036; (or d&#036; watever drive you wanna connect to) You may wish to add that to the list. (I personally do not like to have connected folders all the time as it slows things down as my laptop connects to 4 different networks.
    3 - It will prompt for the pass. Just enter it with the admin user name and pass. You might need to do it twice to mount the drive.
    4 - You will be able to see the icon on ur desktop. Its connected.

    Next, XP to OSX
    1 - Once you got &#39;Windows Sharing&#39; turned on on OSX, go to &#39;Workgroup&#39; (best by the long way Entire Network -> Microsoft Windows Network -> Workgroup (or some other domain/workgroup name))
    2- You will be able to see the mac there. You should. In the event you don&#39;t, Use the "Search for Computers" function on Windows Explorer search and type the ip address in to "force" a search.
    3- IF THAT STILL FAILS, and u know u can ping it, do a mount (map in windows term)
    4- Open up windows Explorer -> Map Network Drive -> &#092;&#092;192.168.x.x&#092;<acc name>

    OK, I do not have my pbook now, so there might be some errors in my instructions. Generally thats my approach and the rest may help correct some of the steps.

  6. #6

    Join Date
    Feb 2004
    Location
    Behind you
    Posts
    2,699

    Default

    I have noticed on the majority of occasions, if there is no file/directory shared on the Windows box. The machine will not show up at all. Not until you share something.

    pipsqeek
    WTF is Harmonytech? | The iBook Saga. | Successful Trades: Currawong, Byrd, xedos, Decryption, Greenie, Mivory
    sudo chmod 327 /etc/car/subaru

  7. #7

    Join Date
    Aug 2004
    Location
    Melbourne
    Posts
    127

    Default

    But if its an XP box, by default there is a shared folder (unless its turned off)

  8. #8

    Join Date
    Feb 2004
    Location
    Behind you
    Posts
    2,699

    Default

    It could be.

    I don&#39;t use Windows much (only to game) so I can&#39;t say if that may be the case or not.

    pipsqeek
    WTF is Harmonytech? | The iBook Saga. | Successful Trades: Currawong, Byrd, xedos, Decryption, Greenie, Mivory
    sudo chmod 327 /etc/car/subaru

  9. #9

    Join Date
    Jan 2004
    Location
    Melbourne
    Posts
    6,927

    Default

    Originally posted by Jmi@Oct 28 2004, 10:53 AM
    But if its an XP box, by default there is a shared folder (unless its turned off)

    I don&#39;t need Windows File Sharing turned on to access Windows files on my iBook.

    JB
    There is a shared &#39;My Documents&#39; folder, but like Steve I need to share a drive (eg. C for OS X to pick it up.


  10. #10

    Join Date
    Oct 2004
    Location
    Melbourne
    Posts
    1,156

    Default

    Originally posted by bYrd@Oct 28 2004, 01:08 PM
    There is a shared &#39;My Documents&#39; folder, but like Steve I need to share a drive (eg. C for OS X to pick it up.
    while there are folders that are shared i still notice that at times i can not see anything on clients pcs until i activate a shared folder that wasn&#39;t shared before. ie the whole c drive or something
    ________________________________________________

    There are 10 types of people in this world. Those who understand binary and those who don't.

    www.macmate.com.au

    Leader of: Apple General, Help! & iPods, iTMS & Accessories

  11. #11

    Join Date
    Oct 2004
    Location
    Australia
    Posts
    1,533

    Default

    It took me a while to get my two XP machines networking correctly. So I would imagine it is much harder to network an XP and OS X sytem.

    I found this site for you http://joelshoemaker.com/computer/mac/mxpfs.html seems to have a fair bit of info on networking. I did a search on google for OSX XP networking, a few more results came up.


    Hope this helps.



    -Adam.

  12. #12

    Join Date
    Aug 2004
    Location
    Melbourne
    Posts
    127

    Default

    For ppl who wish to know,
    In win2k/XP, all drives have a default admin share prefix with a &#036; sign. It is always there and I have yet to gather enough courage to remove that share LOL (i do not think that is possible even though you have full "root" access)

    c&#036; will always be available unless there is no drive name c
    So you do not have to actually make a share

  13. #13

    Join Date
    Feb 2004
    Location
    Behind you
    Posts
    2,699

    Default

    I can&#39;t remember which way but either before or after the character representing your drive, ie: C:&#092; or D:&#092; or whatever, will either have a "&#036;" sign in front or after it.

    This can make the share visible or invisible.

    I&#39;m reaching deep into the vault here.

    Pipsqeek doesn&#39;t DO Windows. :P

    You will also find that with Windows, its far easier and quicker to search for the computer you want to connect to rather then wait for it to pop up in the network browser. I have found that in OS X this doesn&#39;t take as long. Either way, SMB is arse and its only there to play nice with Windoesn&#39;t


    pipsqeek
    WTF is Harmonytech? | The iBook Saga. | Successful Trades: Currawong, Byrd, xedos, Decryption, Greenie, Mivory
    sudo chmod 327 /etc/car/subaru

  14. #14

    Join Date
    Jan 2005
    Location
    Sydney
    Posts
    656

    Default

    Hi,
    I&#39;ve tried everything mentioned here to get my Pc and Mac to play nice, but they just won&#39;t&#33; The setup is:
    Broadband connection into router, Mac and PC connected to router. When i try manually typing in the ip.address/c&#036; i get the error message attatched. What am i doing wrong? Thanks for your help,
    Zeddie

  15. #15

    Default

    The only problem i have sharing files between OS X and XP is that the machines often won&#39;t show up in each others network browsers, once they do however it&#39;s advisable to make a short cut, this prevents any issues as it no longer matters whether you can see the machines in the network browser. Also the Max is accessible from the PC my name, you don&#39;t have to use the IP address. Also the only XP shares that show up on my Mac are the ones I create.
    2.5 GHz 15" MacBook Pro, 27" iMac, G4 Cube, 2 x Colour Classic, 840AV, iPhone, iPad

  16. #16

    Default

    Time for my 2c.
    In Windows, share the folder you want to access from your Mac. e.g: C:&#092;Music. To do that, right click the folder icon and choose Sharing and Security, then a new window will pop up. Tick the box saying, "Share this folder on the network." then tick "Allow network users to change my files." Enter a name for the share in the field above, (in this example, music, is a suitable share name.)

    Click OK and go on your Mac.

    On the Mac, go to the Finder, and press Cmd+K. And type in smb://192.168.1.7 (or whatever the IP of the Windows machine is). It might take a few seconds, but a window will pop up saying to authenticate yourself. If you created the share logged in as a certain user (e.g: rudiger53) type in the username and password for that account here. If you didn&#39;t enter in any username when you logged in to Windows, use the username Administrator and the password that goes with it.

    Once you&#39;ve authenticated, a new window will come up askign you to choose the share you want to connect to. Choose the one you want and click connect and it will mount in the Finder ready for you to use.

  17. #17

    Join Date
    Jan 2005
    Location
    Sydney
    Posts
    656

    Default

    Thanks for your quick reply, but i still get the error messsage? The folder I am trying to connect to iis just the default "Shared Documents" folder. Any ideas what wrong??

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •