Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 24
  1. #1

    Join Date
    May 2008
    Location
    Brigadoon, Western Australia
    Posts
    899

    Default back to Mountain Lion advice please

    I have an iMac 27" late 2009 version 11,1. Had a late 2006 24" prior to that and NEVER had a crash in all that time. Since putting Mavericks on it has locked up completely many times. Have a 3TB Time machine so have backups before October 23rd. Which is probably when I installed Mavericks.

    I'm guessing an old iMac is struggling with Mavericks. It's an i7 with 8GB RAM fully specced up at the time. So is it just a matter of finding a Time Machine backup before October 23 and doing a full restore? And if I do do I lose all app updates I've done since and any files like photos downloads documents etc that I've put on since?

    I hoped the latest Mavericks update might fix the lockups but it just did it again. The only answer is to power down and reboot. This is like dreaded Windows days. Don't need that on a Mac.
    iMac 27" i7, 16GB RAM Late 2009 running El Capitan, iPhone 6 64GB and iPad Air 128GB WiFi + 4G, ATV2

  2. #2

    Join Date
    May 2010
    Posts
    3,410

    Default

    Your iMac should not be having trouble at all!! Mavericks is a poor OS and similar things happen on my Mid 2012 Macbook Pro.

    I think you'll need to do a clean install of Mountain Lion, then restore from update. if you've updated iMovie, iPhoto, Pages, Keynote etc the new file types have changed so anything new you've done will not be compatible.
    Plus, IIci, IIsi, LC, LCII, LC III, CC, LC475, LC630, Centris650, 6100, 8100, 5260, 7220, 7600. PB: 100, 150, 160, 165, 540, 190, 5300, 1400. Lombard, iMacG3, iBookG3, iBookG4, PBG4, eMac, iMac G4, PMG4, MiniG4, iMacG5

  3. #3

    Default

    This sounds like the perfect situation for a Bootable Carbon Copy Cloner image of your old 10.8.x system. Boot off the untouched backup and just hit restore... (not getting paid for this )

  4. #4

    Join Date
    Feb 2009
    Location
    Mill Park, Vic.
    Posts
    65

    Default

    Quote Originally Posted by Oldmacs View Post
    Your iMac should not be having trouble at all!!
    I'll second that! Have updated a 2007 iMac, 2008 iMac, 2009 Mini & 2010 MBP to Mavericks with zero problems.

    Have you run something like Onyx to repair permissions and clean out caches? Ideally that should be done before you upgrade as well as after.
    All software up to date and Mavericks compatible? Done a hardware test to make sure your RAM is OK?
    Are you running any 3rd party software to "improve" the Apple settings? If so get rid of it. - Common cause of problems, especially after Apple software updates.

  5. #5

    Join Date
    Sep 2009
    Location
    Outback Queensland
    Posts
    2,061

    Default

    My current 27-inch iMac is a 10,1 (2009) model with Core 2 Duo processor. I've upgraded to 16GB of RAM but little else. It's been relatively stable for every OS release I've had on it (everything from Snow Leopard onwards). Right now, it's got one niggle that I firmly believe is software in nature - the machine will lock up on some web pages (not totally convinced it's Flash, but don't know what it is really). I expect that a fresh re-install would fix this but I'm about a week away from a new CTO iMac arriving so I'm just living with it for now.

    There's no reason for Mavericks to give you particular stability problems in itself.

    But that doesn't mean there's not something wrong. For starters, can you rule out hardware problems? RAM and HDD working OK? What about software? Have you tried doing a fresh build (on an external if you just want to test it all) and then slowly building up your normal software installs and seeing if something goes wrong? Have you tried creating a new user profile and using that instead of your current one?

    Ultimately, downgrading to a previous OS may give you it's own set of problems for recovering all your data - especially stuff that's changed since you upgraded to Mavericks. That's mostly going to depend on the type of data you want to recover, how much meta data you're prepared to lose, and how much effort you want to go to.

    For example, if you store all your photos in iPhoto then you won't be able to just load the new iPhoto library in an older version of iPhoto (and the latest updates only install on Mavericks). That means you'll have to view the contents of the iPhoto library and manually extract newly added photos. You may not be able to recover any meta data that's been added.

    Personally, I'd by trying to figure out why the system isn't stable. It may not be Mavericks at all. It could be older software that doesn't work properly with Mavericks, it could be a newly developed hardware issue, etc, etc.

    David

  6. #6

    Join Date
    May 2010
    Posts
    3,410

    Default

    tbh I'm onto my 3rd clean install of Mavericks. For some reason (Perhaps rushed development) it runs terribly. I think Mavericks for some people has major problems :P
    Plus, IIci, IIsi, LC, LCII, LC III, CC, LC475, LC630, Centris650, 6100, 8100, 5260, 7220, 7600. PB: 100, 150, 160, 165, 540, 190, 5300, 1400. Lombard, iMacG3, iBookG3, iBookG4, PBG4, eMac, iMac G4, PMG4, MiniG4, iMacG5

  7. #7

    Join Date
    Sep 2009
    Location
    Outback Queensland
    Posts
    2,061

    Default

    I'm currently running Mavericks on my 2009 iMac, 2010 Mac mini, 2010 MacBook Air and 2011 MacBook Air.

    Aside from the one niggle mentioned above on my iMac, it's working fine on all of them.

    I've got a range of connected peripherals on them and the iMac (video and photo work) and Mac mini (almost everything else I do) work pretty hard for many hours each day.

    I don't doubt that some people have problems. It's the nature of things. But perhaps it's not Mavericks in isolation. Perhaps it's Mavericks in association with other factors. The most common of these would have to be third party software. There's some truly dreadful software out there that'll make even the best machine unstable.

    If that's the case, I'd rather figure out what's causing the stability issues - if it's a particular application then it's time to look for it's replacement.

    David

  8. #8

    Join Date
    Jan 2005
    Location
    The moon
    Posts
    91

    Default

    Sounds bad.

    Not sure if this will help, but just in case it does... Try a fresh install? Old OS artefacts could be causing random issues. My story:

    I upgraded my early 2010 MacBook Pro to Mavericks, and it made it so slow as to be unusable.

    After contacting Apple to ask them to allow me to downgrade my OS with a fresh install, they advised to do a fresh install of the operating system on my machine (original install disks and upgrade to Mavericks).
    This worked much better and was pretty much as fast and reliable as 10.8.

    It appears as though there may be problems with the upgrade process from old OSes (I'd upgraded from 10.6 onwards without a complete reinstall).
    Maybe try a fresh install?

    Best of luck.

  9. #9

    Join Date
    May 2008
    Location
    Brigadoon, Western Australia
    Posts
    899

    Default

    Quote Originally Posted by neo View Post
    Sounds bad.

    Not sure if this will help, but just in case it does... Try a fresh install? Old OS artefacts could be causing random issues. My story:

    I upgraded my early 2010 MacBook Pro to Mavericks, and it made it so slow as to be unusable.

    After contacting Apple to ask them to allow me to downgrade my OS with a fresh install, they advised to do a fresh install of the operating system on my machine (original install disks and upgrade to Mavericks).
    This worked much better and was pretty much as fast and reliable as 10.8.

    It appears as though there may be problems with the upgrade process from old OSes (I'd upgraded from 10.6 onwards without a complete reinstall).
    Maybe try a fresh install?

    Best of luck.
    So my originals were snow leopard. So do a time machine backup, then wipe the lot with a fresh install of SL then upgrade to mavericks then a restore from my latest time machine backup? Is that the way?
    iMac 27" i7, 16GB RAM Late 2009 running El Capitan, iPhone 6 64GB and iPad Air 128GB WiFi + 4G, ATV2

  10. #10

    Join Date
    May 2010
    Posts
    3,410

    Default

    It would be better if you make a usb installer of Mavericks or Mountain Lion (If you want to downgrade) and do a fresh install like that Brining SL into it will slow the computer down!
    Plus, IIci, IIsi, LC, LCII, LC III, CC, LC475, LC630, Centris650, 6100, 8100, 5260, 7220, 7600. PB: 100, 150, 160, 165, 540, 190, 5300, 1400. Lombard, iMacG3, iBookG3, iBookG4, PBG4, eMac, iMac G4, PMG4, MiniG4, iMacG5

  11. #11

    Join Date
    Jan 2005
    Location
    The moon
    Posts
    91

    Default

    I agree with Oldmacs - a USB installer of Mavericks is probably the best way to go.
    There seem to be many (differing) guides on how to do it. Here's Lifehacker's:
    How To Create An OS X Mavericks USB Installation Drive | Lifehacker Australia

    Once your system is running with Mavericks, do a time machine restore of your data and apps and you should be done.

  12. #12

    Join Date
    Sep 2009
    Location
    Outback Queensland
    Posts
    2,061

    Default

    Quote Originally Posted by neo View Post
    I agree with Oldmacs - a USB installer of Mavericks is probably the best way to go.
    There seem to be many (differing) guides on how to do it. Here's Lifehacker's:
    How To Create An OS X Mavericks USB Installation Drive | Lifehacker Australia

    Once your system is running with Mavericks, do a time machine restore of your data and apps and you should be done.
    If the problem is that things are unstable running Mavericks then doing a Time Machine restore may not be the best action. At least, do a selective restore to get back your data but not your apps (for example).

    If a clean install of Mavericks is unstable then you may well have an underlying hardware issue. If a clean Mavericks is stable and then becomes unstable after you finish setting everything up then it's something in what you've set up that's most likely causing the instability.

    David

  13. #13

    Join Date
    May 2010
    Posts
    3,410

    Default

    My clean installs of Mavericks were unstable even with no software installed. Mavericks has issues that Apple hasn't yet addressed.
    Plus, IIci, IIsi, LC, LCII, LC III, CC, LC475, LC630, Centris650, 6100, 8100, 5260, 7220, 7600. PB: 100, 150, 160, 165, 540, 190, 5300, 1400. Lombard, iMacG3, iBookG3, iBookG4, PBG4, eMac, iMac G4, PMG4, MiniG4, iMacG5

  14. #14

    Join Date
    May 2008
    Location
    Brigadoon, Western Australia
    Posts
    899

    Default

    Quote Originally Posted by Oldmacs View Post
    My clean installs of Mavericks were unstable even with no software installed. Mavericks has issues that Apple hasn't yet addressed.
    Yes after more googling I'm beginning to think it's mavericks that's the problem. Think I'll persevere till more updates come along. I'm far from alone with these issues. Seems to mainly happen in Safari
    iMac 27" i7, 16GB RAM Late 2009 running El Capitan, iPhone 6 64GB and iPad Air 128GB WiFi + 4G, ATV2

  15. #15

    Join Date
    May 2010
    Posts
    3,410

    Default

    My main problems are Safari, Mail, Finder (it freezes opening things and then logs me out), startup is slow, stuff just hangs and crashes. I've gotta say I'm not impressed for an update that Apple says 'speeds up your computer'. Also my battery life is severely reduced and again its disappointing considering this update was meant to improve battery life.
    Plus, IIci, IIsi, LC, LCII, LC III, CC, LC475, LC630, Centris650, 6100, 8100, 5260, 7220, 7600. PB: 100, 150, 160, 165, 540, 190, 5300, 1400. Lombard, iMacG3, iBookG3, iBookG4, PBG4, eMac, iMac G4, PMG4, MiniG4, iMacG5

  16. #16

    Join Date
    Aug 2008
    Location
    Sydney
    Posts
    678

    Default

    I'd love to say it's not the OS causing these issues, but in all honestly I don't know as I don't have that hardware. You definitely shouldn't be experiencing problems like this if your computer is supported and an i7 and 8 Gb RAM is definitely enough to run Mavericks well.

    If I was there in a tech-support capacity first I would look at all your system processes and resources, what kind of software and login items you have, perhaps turning unnecessary ones off to see if that improves things. Then I'd run full clearing of all caches. Many utilities exist that do cache cleaning but I just do it myself with a script in Terminal. If you'd like it let me know and I can email it.

    I'd verify disk in disk utility and repair any problems (you can do this by booting into the recovery partition) and also throw in a Parameter RAM reset for good measure! Then I'd run Apple hardware test to see if it finds any problems. Even if AHT doesn't find any problems it doesn't guarantee there aren't any but it probably means serious problems aren't likely.

    Remember that hard drives have a limited life and poor performance can be indicative of a hard drive having problems. If your machine is more than 4 years old keep an eye on SMART status in Disk Utility. Full hard drives are also going to slow down and could cause beach-balling, especially if you run out of RAM!

    If after all this problems persist I'd be inclined to blame the OS or software compatibility issues with Mavericks, but only in the absence of finding other problems.
    Last edited by simonm; 21st December 2013 at 11:39 PM.

  17. #17

    Join Date
    Aug 2008
    Location
    Sydney
    Posts
    678

    Default

    Quote Originally Posted by Oldmacs View Post
    My main problems are Safari, Mail, Finder (it freezes opening things and then logs me out), startup is slow, stuff just hangs and crashes. I've gotta say I'm not impressed for an update that Apple says 'speeds up your computer'. Also my battery life is severely reduced and again its disappointing considering this update was meant to improve battery life.
    That's really strange, especially about the battery life. When was the last time you drained it completely flat? Sometimes calibration can be out.

    I still think the OS is the least likely thing to be causing your issues, but that doesn't mean it isn't.

  18. #18

    Join Date
    May 2010
    Posts
    3,410

    Default

    I've tried calibrating my battery about 3 times now and it hasn't made a difference :/
    Plus, IIci, IIsi, LC, LCII, LC III, CC, LC475, LC630, Centris650, 6100, 8100, 5260, 7220, 7600. PB: 100, 150, 160, 165, 540, 190, 5300, 1400. Lombard, iMacG3, iBookG3, iBookG4, PBG4, eMac, iMac G4, PMG4, MiniG4, iMacG5

  19. #19

    Join Date
    May 2008
    Location
    Brigadoon, Western Australia
    Posts
    899

    Default

    Quote Originally Posted by simonm View Post
    I'd love to say it's not the OS causing these issues, but in all honestly I don't know as I don't have that hardware. You definitely shouldn't be experiencing problems like this if your computer is supported and an i7 and 8 Gb RAM is definitely enough to run Mavericks well.

    If I was there in a tech-support capacity first I would look at all your system processes and resources, what kind of software and login items you have, perhaps turning unnecessary ones off to see if that improves things. Then I'd run full clearing of all caches. Many utilities exist that do cache cleaning but I just do it myself with a script in Terminal. If you'd like it let me know and I can email it.

    I'd verify disk in disk utility and repair any problems (you can do this by booting into the recovery partition) and also throw in a Parameter RAM reset for good measure! Then I'd run Apple hardware test to see if it finds any problems. Even if AHT doesn't find any problems it doesn't guarantee there aren't any but it probably means serious problems aren't likely.

    Remember that hard drives have a limited life and poor performance can be indicative of a hard drive having problems. If your machine is more than 4 years old keep an eye on SMART status in Disk Utility. Full hard drives are also going to slow down and could cause beach-balling, especially if you run out of RAM!

    If after all this problems persist I'd be inclined to blame the OS or software compatibility issues with Mavericks, but only in the absence of finding other problems.
    Great advice there. Thank you will work with that.
    iMac 27" i7, 16GB RAM Late 2009 running El Capitan, iPhone 6 64GB and iPad Air 128GB WiFi + 4G, ATV2

  20. #20

    Join Date
    May 2008
    Location
    Brigadoon, Western Australia
    Posts
    899

    Default

    Quote Originally Posted by simonm View Post
    I'd verify disk in disk utility and repair any problems (you can do this by booting into the recovery partition) and also throw in a Parameter RAM reset for good measure! Then I'd run Apple hardware test to see if it finds any problems. Even if AHT doesn't find any problems it doesn't guarantee there aren't any but it probably means serious problems aren't likely.

    Remember that hard drives have a limited life and poor performance can be indicative of a hard drive having problems. If your machine is more than 4 years old keep an eye on SMART status in Disk Utility. Full hard drives are also going to slow down and could cause beach-balling, especially if you run out of RAM!

    If after all this problems persist I'd be inclined to blame the OS or software compatibility issues with Mavericks, but only in the absence of finding other problems.
    Repaired permissions, did a PRAM clear and checked Smart Status. All good except one only Permission that was locked. Can't do an AHT as I don't have it now that I'm on Mavericks. Found an old version for 10.8 but refuses to let me use it. Used Onyx to run all the tests and cache clearing. Really need that AHT. Why on earth don't Apple let you just have it as a download I wonder? Since mine is an iMac late 2009 11,1 you have to use AHT. But trying both D and option D to boot just don't work loads to my desktop every time.
    iMac 27" i7, 16GB RAM Late 2009 running El Capitan, iPhone 6 64GB and iPad Air 128GB WiFi + 4G, ATV2

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •