Welcome to MacTalk Australia

the largest Australian community for Apple discussions and topics

Join the discussions, Register Now!
Results 1 to 2 of 2

Thread: OS X VPN issue

  1. #1

    Join Date
    Mar 2013
    Location
    Dunedin, NZ
    Posts
    170

    Default OS X VPN issue

    I have an issue with an OS X 10.5.8 Server that lost its VPN settings, I've recreated the VPN settings but now when trying to connect to it I get an errors in the logs:

    MPPE required, but keys are not available. Possible plugin problem?
    sent [LCP TermReq id=0x2 "MPPE required but not available"]
    rcvd [CCP ConfReq id=0x1 <mppe +H -M +S +L -D -C>]
    rcvd [LCP TermAck id=0x2]


    I've Googled this (for hours!) and tried a number of things including this:



    Process followed from https://discussions.apple.com/thread...readID=1229769

    1. vpnaddkeyagentuser /LDAPv3/127.0.0.1 - this creates an entry in the system keychain called com.apple.ras - from this you can find the vpn_xxx username and password
    2. Create an OpenDirectory user using the Workgroup Manager using the vpn_xxx name and password
    3. Use the mkpassdb -dump command to get a list of the users credentials. Find the entry corresponding to the vpn_xxx user.
    4. Run mkpassdb -setkeyagent 0x..... where the 0x... bit is the big hex number to the immediate left of the username from the previous dump command (mine mostly start 0x47...)

    But unfortunately nothing seems to have worked, can anyone suggest what might be causing this error and how I might be able to fix it?

    Cheers

    Jamie
    Last edited by MadKiwi; 2nd October 2013 at 01:18 PM.

  2. #2

    Join Date
    Dec 2007
    Location
    Hobart, TAS
    Posts
    6,422

    Default

    Doubt it'll help, but have you tried with a fresh user profile to rule out some kind of preferences issue? Unlikely seeing as you've already recreated the VPN settings...

    Could also be related to how it lost its VPN settings in the first place.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •