PDA

View Full Version : Safari 2.01 crashes



step_andy
30th October 2005, 03:46 PM
Hi,
Couple days ago installed fresh copy of 10.4 + 10.4.2 combo + Safari Update + Java update

Now Safari will crash every time I close either a tab with several tabs open or a window with 2 or more open.

Repaired permissions, but Safari still crashes.

Any ideas? Is it Safari? Is it Java? Is it 10.4.2?

Andy :(

kim jong il
30th October 2005, 04:36 PM
Before I start looking at anything in regards to problem applications these days I always make sure I have performed all the usual maintenace tasks (repair permissions, update pre binding etc; if the permissions repair does not work especially). Rather than use multiple applications to perform these tasks (and I really don't like using the command line interface as I find the UNIX syntax strangely anti-intuitive) I use a handy helper application called control freak that divides tasks into daily, weekly, monthly 'maintenance' tasks and if the machines performance becomes unstable I will run all tasks and set it to restart when finished (about 20 minutes (plus) depending on which hard drives are mounted at the time)

Well it's worth considering if nothing else and quite safe.

kim

EDIT 1: PS I should have mentioned that in the past I have found applications/helpers (e.g. codecs) that will only work properly in the root directory and not when placed in the user directory (which leads into Currawongs question in the following post...)

Currawong
30th October 2005, 04:55 PM
Does it crash while logged in as a different user?

designers_hub
30th October 2005, 05:48 PM
it keeps crashing on me on realestate.com.au

its very very annoying

dmw
30th October 2005, 06:18 PM
my safari is mostly stable but also crashes on certain realestate.com.au pages. This has only been happening for a week or so. I have not done any software changes recently with the exception of iTunes 6.01.

half way thorugh rendering the page (normally pages with the search engine parameters on it) i get BSOD for about 5 mins until it auto quits.

this is happening on all 3 macs i have in my office. (2 are still running 10.3)

is anyone else experiencing this? if so let me know as i know some of the dudes at REA and i will get them to look into it further.

d.

step_andy
30th October 2005, 06:47 PM
Originally posted by Currawong@Oct 30 2005, 04:55 PM
Does it crash while logged in as a different user?
Just tested, no it does not crash.

Do I need to trash Safari preferences?
Any advice to where they are located?

Andy

mvjs
30th October 2005, 06:56 PM
Home Folder --> Library --> Prefrences

starbug
30th October 2005, 06:56 PM
It crashed for me. I went to the site and clicked on Victoria.


Bang... :ph34r:

step_andy
30th October 2005, 07:16 PM
Originally posted by michaelvjsmyth@Oct 30 2005, 06:56 PM
Home Folder --> Library --> Prefrences
Trashed.
Safari didn't crash after opening two tabs and closing one of them. Opened three more, closed one... BANG... Crash again
:(

kim jong il
30th October 2005, 09:45 PM
I checked it out on my 3 prime macs (two different G4 towers and an iMac for channel BT) and ALL realestate.com.au site/ links/pages work perfectly and consistently for me.

kim

PS: Hosted on a nice fast server

EDIT: spelling :cry:

Currawong
31st October 2005, 06:31 AM
There's also a ~/Library/Safari folder. Try renaming that to see if it isn't something like the bookmarks or the site icons cache causing trouble.

step_andy
31st October 2005, 08:14 PM
Renamed the Safari folder and still no luck.
Beats me.
To re cap. Installed fresh 10.4, imported documents, apps and network settings, updated to 10.42, updated Safari to 2.01, updated Java.

Only thing that looks a potential problem is importing the apps from 10.3.9 that was on a different HD.
Andy

step_andy
31st October 2005, 11:35 PM
I am happy to report that the problem was Speed Download v2.
I uninstalled and after some quick testing Safari isn't crashing anymore.
Yippee
:lol:

suryo
1st November 2005, 01:21 AM
realestate.com.au crashes Safari for me too.

dmw
1st November 2005, 04:16 PM
i could surf realestate.com.au QLD fine ... but VIC kills safari.

Is this consistent with other users?