PDA

View Full Version : Spellchecker language different to OS X language?



arlibie
25th August 2010, 10:15 PM
Hi all, hopefully someone can help me with a weird problem:

I've set my language to Australian English, but words like 'colour' and 'recognise' come up as incorrect spellings with 'color' and 'recognize' as the spelling suggestions! Pages says the language is set to Australian English but it's still using [American] English apparently... (also Safari and Dictionary are showing correct spellings as incorrect, so not just Pages)

I've tried changing the language to something else and then changing it back, but nudda. Any help REALLY appreciated!!

arlibie
28th August 2010, 09:12 PM
Ok so the solution was reinstall OS X, for anyone who's curious :)

Mike Sprawson
4th September 2010, 08:46 PM
Ok so the solution was reinstall OS X, for anyone who's curious :)

Yes, I'm curious, I've just done a search on 'dictionary' and found your post. I've had my 27inch iMac nearly 3 weeks, and while sorting out my word files, I came across the problem you've discovered.

So that I don't stuff everything up, how simple is it to, 'reinstall' OS X?

Thanks in advance, Mike.

feeze
4th September 2010, 08:51 PM
Before doing a reinstall, which is like going after a fly with wrecking ball, first try this.

In the bottom of this forum is a text box. Click within the text box and select "Spelling and Grammar" -> "show Spelling and Grammar"

Down the bottom is a drop down box. Select your language.

Changes won't come in until the window is closed and you may need to restart any open documents which already have words underlined.

Hopefully that should work.

Mike Sprawson
4th September 2010, 09:10 PM
Before doing a reinstall, which is like going after a fly with wrecking ball, first try this.

In the bottom of this forum is a text box. Click within the text box and select "Spelling and Grammar" -> "show Spelling and Grammar"

Down the bottom is a drop down box. Select your language.

Changes won't come in until the window is closed and you may need to restart any open documents which already have words underlined.

Hopefully that should work.

Thanks for your reply, but nope, I've already tried that, done a restart, and still no joy. I've even tried British English, again a re-start, nothing but American English.

Cheers, Mike.

Mike Sprawson
4th September 2010, 09:35 PM
This is the message in the spelling box concerning Aussie spelling; This word was not found in the spelling dictionary.

I’ve also tried the pages, Inspector > More > Language > Australian English.

And System Preferences > Language & Text > Input Sources > Australian

So, it could be a ‘reinstall’ OS X, is on the cards?

Me again, Mike.

Mike Sprawson
5th September 2010, 09:03 PM
In the bottom of this forum is a text box. Click within the text box and select "Spelling and Grammar" -> "show Spelling and Grammar"

Down the bottom is a drop down box. Select your language.


And mine shows, Australian English.

Not long after I had my new iMac set up, typing in Safari, I noticed the Australian English spelling was underlined. Later, after I'd sorted things out, I found that Pages had the same problem. I did some checking, but found nothing to tell me what the problem was, hence, my doing a 'dictionary' search in MacTalk.

So, another thing I've discovered is below: right clicking on a Pages' file, and in the pop-up menu, > Writing Tools > Look up in Dictionary and Thesaurus, I found this;

http://web.me.com/nundah/dlf/mactalk/allrefsource.jpg

American only, that's it.

Edit: I've simply put the graphic into another folder.

Mike Sprawson
6th September 2010, 05:26 PM
Before doing a reinstall, which is like going after a fly with wrecking ball, first try this...

I've tried so much, and done restart after restart, but no joy in accessing my choice of English. I mean, where's that wrecking ball when you need it.

So, following arlibie's example, out came the wrecking ball. Result? I now have Australian English; in Safari, TextEdit, and Pages, and goodbye to that pesky fly.

As a matter of interest, the graphic above looks just the same too.

Edit: after the success above, I needed to follow up with the UpDates, then, that pesky fly was back! I'll be getting in touch with Apple tomorrow. Watch this space.

Mike Sprawson
7th September 2010, 04:37 PM
"In Apple Discussions a Poster writes; British Dictionary in 10.6.4 not working."

The insert disc that I have is 10.6.3, and when I updated the software, I was no longer able to use Australian English. It seems to be something to do with the recent updating.

This is really interesting. (http://discussions.apple.com/thread.jspa?threadID=2533369&tstart=0)

This Poster has had the same experience as me. There seems to be a problem with the latest DownLoad software; which one?

So, it looks as if I'm not the only one to have this drama. I sent a feedback to Apple, 01:30 am Tuesday 07/09/10, from AppleDiscussions Forum.

I downloaded the combo update, tu070910 1:38am. 887 MB, as advised in Apple Discussions:

"When doing a system upgrade it is best to use the Combo update. Click on this link (http://support.apple.com/kb/DL1048) to download it. It resolves many issues that the smaller updates might miss."

Well, the system wouldn't allow it to be installed.

I looked at the package contents of Dictionary.App on my original install disc, 10.6.3 and also the package contents of Dictionary.App 10.6.4 in Applications, after I had downloaded the latest updates, and the English Folders appear the same.

So could the problem be in one of the recent downloads for 10.6.4?

I got in touch with Apple today, but, no concrete answer to this problem. So, I have now done another install, and yes, I now have excellent Australian English again; in Safari, TextEdit, and Pages. But, I won't be doing any UpDate stuff at the moment, well, not until this dictionary aberration is sorted out.

At Apple Discussions, one of the Posters pointed out that there's probably a break in the software in some of the downloads. Not being a programmer, it's beyond me. At the moment I'm not game to try and load the Combo Update I downloaded (I kept the package), but it's staying where it is for the moment.

In the mean time, any ideas? And keep smiling, Mike.

Mike Sprawson
10th September 2010, 01:01 PM
Well, I did carry out another download, result below:

Downloading carried out Friday, 10/09/10.

I Checked the spelling after individually downloading these below;

1) iPhone SDK Compatibility Update, 1.0 6KB.

Good.

2) AirPort Base Station Update 2010-001, 5.5.1, 12.1MB.

Good.

3) Safari, 5.0.2, 39.2 MB.

Good.

Java for Mac OS X 10.6 Update 2, 1.0, 81.7 MB.

Good.

iWeb Update, 3.0.2, 185.8 MB.

Good.

Mac OS X v10.6.4 Update for iMac Mid 2010, 1.0, 478.2 MB.

Bad!

It's back to the drama again! But, what to do about it? That's the question; clues anyone?

Mike Sprawson
15th September 2010, 11:28 AM
Last night I spent some time on this problem, again! And, it worked out good, as I ended up with Australian English again, in TextEdit, Pages, and Safari. I was happy, I couldn't believe it. I checked, and checked, and yes, all was well again.

I closed the TextEdit app, opened it again, but only American English. I closed the Pages app, and opened this again, but only American English. I checked Safari, no problem with that, I spent quite a lot of time trying to work out what the problem could be; no joy!

This morning, realising I hadn't closed Safari down last night (as I had done with both TextEdit and Pages), I closed the Safari app, and guess what? Now only American English in Safari; again!

I've checked out Software Update, just in case something has happened overnight, but, still no joy with accessing Australian English to date. This Dictionary aberration seems to have something to do with the Update to 10.6.4. As mentioned in a post above, I've reinstalled 10.6.3 twice, and in each case the spelling was in Australian English. And also in each case, when I followed up with the Updates, back to American English, independently of the Australian English settings.

In spite of the odd experience last night, I'm stuck with something other than my choice of English.

This link (http://discussions.apple.com/thread.jspa?messageID=11692078&#11692078) in Apple Discussions is interesting.

I now have a problem with Pages' Ruler Units, being in inches, instead of centimeters. Somehow, this got changed to Inches, and it wasn't by me. In fact, the settings in Pages' Rulers Preferences, is set to Centimeters, to no useful effect.

cosmichobo
15th September 2010, 04:48 PM
I've been watching this thread with interest, cos I can never seem to get AU English happening here in 10.5.8 either...

I guess Zteve just wantz to Americanize the worldz...

Mike Sprawson
16th September 2010, 12:18 PM
I guess Zteve just wantz to Americanize the worldz...

As seen above, the problem isn't limited to either Australian, or British English, but other languages are open to dictionary oops-a-daisies. One can only hope that other Steve doesn't get wind of it. It must have something to do with all the, iThis and iThats, Apple is marketing. There are only so many programmers to go around.

Now, when I face this dictionary oh-oh again, I find myself thinking of a certain O O, you know, OpenOffice. I mean, in 10.6.3, no dictionary problem, with the UpDate there is; disappointing. Apple Australia told me that 10.6.5 is in beta. Hopefully, the dictionary oh-oh, is being addressed. Therefore remember, mum's the word, don't tell that other Steve.;)

Edit; your know, into you know. And some caps too.

Mike Sprawson
19th September 2010, 09:17 PM
Early yesterday. Once more, I have access to Australian English. It was simple really, I got the wrecking ball out again, and, no more fly. This move was prompted by a bad report after doing a Repair Disk Permissions.

After this third re-install, I checked out:

1) Repair Disk Permissions
2) Spell Check

Both were good.

I then downloaded the latest UpDates, having checked all but one, ie, the Mac OS Xv10.6.4. for iMac version 1.0, 478.2 MB.

After this third download, I checked out:

1) Repair Disk Permissions
2) Spell Check

Again, both were good.

Checked UpDate again; only Mac OS Xv10.6.4;

Well, having gotten tired of swinging that wrecking ball around, I'm leaving that fly where it is. Result? All is sweet. Now for other things.

Edit: 1) Disk Repair Permissions to, 1) Repair Disk Permissions. Consistency. :D

Mike Sprawson
6th October 2010, 09:51 PM
Play it again Sam!



So, down to work with Pages, and what a joy. Having downloaded several 100 pages, of American English html files (open source), I needed to change them over to Australian English. The downloaded html files had tags etc, that needed to be removed (almost each sentence). So now was the opportunity to become familiar with Pages', "find and change" program. It was a little different from the old AppleWorks WordProcessor, but soon got use to it.



A lot of work, but becoming familiar with Pages was enjoyable, it's so good. I was more than just a little curious with the problem I'd been having with language spelling choice, and played around with it. Simply put, for change in language to take place, the app (alone) needs to be closed, then re-opened. Choice of English spelling was simple.



My default choice of English is Australian, so, that is what I have. And for interest, I placed American English within the same page. Then I opened another page with American English as the default language, and placed Australian English within this page. Check the graphic below;

http://web.me.com/nundah/dlf/mactalk/be_af_ud01.jpg

And, all is well, as can be seen by the appropriate red underlining.



When each page or inserted section, is clicked on, the choice of English is shown in the Inspector. The one in this example correctly shows Australian English. I played around with this for ages, just to make sure it wasn't a flook.



Unfortunately, there was a downside to this fiddling around. The successful exercises led to me becoming confident that all was well, so, to the echo of "Play it again, Sam," I downloaded 10.6.4.



After the downloading, I first checked system settings Language and Text, all was well. Then I opened Pages at the same place as above; that fly is back! See below;

http://web.me.com/nundah/dlf/mactalk/be_af_ud02.jpg

I clicked on the different sections, and the inspector showed the appropriate language settings chosen earlier. No problem there, but only American English formatting shows in the actual page.



I then opened a word file that was saved as a Template before the latest download, it's the same. When clicked upon, the Inspector shows Australian spelling, but it is American English formatting that puts in an appearance in the actual page. Not only that, but something else is odd.



More fiddling around led to this below being discovered;

http://web.me.com/nundah/dlf/mactalk/be_af_ud03.jpg

Also, correct Au spellings are underlined red, when ending with: colon, semi-colon, exclamation and question marks.



Should the above red line free words become red lined, placing the blinking insertion point at the end of a word (say with the full stop), then hitting the back button and re-inserting the full stop, the red line disappeared. So the red line free words aren't wholly free of these "oops-a-daises." Maybe this little exercise will shed light on the possible problem with the dictionary woes.



Here's hoping that 10.6.5, which is in beta, is betta. So, c'mon "Sam" and "play it again!"

Edit; I had some dramas with the graphics. Phew! :)

arlibie
13th November 2010, 08:54 AM
... 

Here's hoping that 10.6.5, which is in beta, is betta. So, c'mon "Sam" and "play it again!"


Sorry for bringing this back but.. The problem is back with me as well! OS X 10.6.5 hasn't changed/fixed anything either. :(

Any fresh ideas??

Mike Sprawson
15th November 2010, 10:38 AM
Well, here we go again. :D

Before UpDates, I close all Apps and run Repair Disk Permissions. The result was the same as earlier with OS 10.6.4, ie, seven warnings that couldn't be repaired. I then did a restart, and proceeded with the 10.6.5 UpDate, upon completion, again ran Repair Disk Permissions. This time, two warnings that couldn't be repaired. So, five previous problems have been solved, with two(?) to go. The two "before and after download" screen shots are below;

http://web.me.com/nundah/dlf/mactalk/2diskreports_th111110.jpg

Checked Language and Text settings, normal. Tested spelling in TextEdit, Pages, and Safari, same as before, still work to do.

I've discovered that in both Spelling Folders (Macintosh HD/Home Folder, Libraries), three English Language dictionary folders have turned up;

http://web.me.com/nundah/dlf/mactalk/lib_spel.jpg

The contents look like they're from OpenOffice, but, nothing doing.

The en_AU-1 folder was last modified: Tuesday, 28 September 2010 5:56 PM. Both en_GB and en_US folders were modified: Sunday, 3 October 2010 5:03 PM.

However, progress is being made, so again, here's hoping that 10.6.6 which is in beta, is much betta. So, c'mon "Sam," and "Tickle those Ivories again." :)

Mike Sprawson
30th November 2010, 07:27 AM
Sorry for bringing this back but.. The problem is back with me as well! OS X 10.6.5 hasn't changed/fixed anything either. :(

Any fresh ideas??

Yes indeed arlibie, I've tried the Dictionaries from OpenOffice, they didn't work. However, "Sam" has tickled those Ivories; in tune! I got onto Apple Discussions, and again came across the idea of the combo download. I'd tried this with OS X 10.6.4, but it wouldn't install. Now, having found out where THE Dictionaries (http://discussions.apple.com/thread.jspa?threadID=2533369&tstart=0) are supposed to be (they were missing), I decided to give the latest combo a try, and downloaded OS X 10.6.5.

After the download, checked the relevant Dictionary folder, and at last, they are there! Tried out the spelling in TextEdit, Pages, and Safari, all is well again. Thank you, "Sam!" In the graphic below, you'll see where my formerly missing Dictionaries are now happily nested. The AppleSpell.service icon needs to be right clicked upon, and then follow through by left clicking, Show Package Contents, etc;

http://web.me.com/nundah/dlf/mactalk/sdg.jpg

Below are the results after testing;

http://web.me.com/nundah/dlf/mactalk/scg1a2.jpg

You'll see the "blinking insertion point" agrees with the relevant choice of English in the Inspector. Apparently, 'English', without any Adjective before it, is American English by default.

So there you go, instead of spellcheck woes, we have Checkmate. Here's hoping this is the correct move for you as well arlibie. :)

P.S. Repair Disk Permissions results are good too. Phew! This also helped. (http://discussions.apple.com/thread.jspa?messageID=12378718#12378718)

arlibie
6th February 2011, 08:09 AM
Ok I had been waiting for an opportunity to download the 1GB+ combo update, because on my internet connection that would take a weekend or more, but then I realised that was never going to happen while my internet is like this, so! I went into Time Machine and following your directions to get to the dictionaries, restored the missing en_AU etc files, restarted and viola! I now have colour not color :)
I hope it says this way after the next update... So for anyone who doesn't want to d/l the combo update and has time machine, this is a pretty good alternative I think.

Thank you Mike for all your help!

nibbles
6th February 2011, 09:04 AM
I'm running 10.6.5 and using Pages '09, is there a way to set that default language to Aust' English because every time I create a document I have to manually change it to Aust' English.

Alex Morrow
6th February 2011, 11:25 AM
Looking at this thread with some interest, as I never have to change spelling or reset anything. (10.6.6, Pages '09 (4.0.5))

The settings I have are listed below, just in case they form a combination that does what people want.
System Preferences>Language and Text>Language has "Australian English" at the top of the list on the left (and "English" as the order for sorted lists, though I don't know if that's important)
System Preferences>Language and Text>Text>Spelling "Automatic by Language"
System Preferences>Language and Text>Formats>Measurement units "Metric" (I've included this for the person whose ruler kept reverting to inches)
System Preferences>Language and Text>Input Sources "Australian" is ticked (I also have another one ticked, but it shouldn't be relevant)
System Preferences>Language and Text>Input Sources>Input Source options - Use the same one in all documents
In my menu bar the Australian flag shows a tick against "Australian"

In case it's relevant, you might also try making a new Pages document, blank, with Australian English in the Inspector>Text>More section, and saving that as a template (File>Save as Template). You might then set General Preferences for New Documents to Use the template you made.

I would also point out that in the Auto-Correction Preferences of Pages, I have ticked only the smart quotes and the email and web addresses. I never ask a machine to check my spelling as I go, let alone alter it.

Sorry for long post, and perhaps none of this will be what is wanted, but here's hoping . . .

Mike Sprawson
28th February 2011, 09:30 AM
Ok I had been waiting for an opportunity to download the 1GB+ combo update, because on my internet connection that would take a weekend or more, but then I realised that was never going to happen while my internet is like this, so! I went into Time Machine and following your directions to get to the dictionaries, restored the missing en_AU etc files, restarted and viola! I now have colour not color :)
I hope it says this way after the next update... So for anyone who doesn't want to d/l the combo update and has time machine, this is a pretty good alternative I think.

Thank you Mike for all your help!

Thank you arlibie, and congratulations; what a journey! It is "The starting out" to find a solution, that a "Quest" gains power. One only needs to go over this Thread to realise I'm not a computer geek. :) But, making the effort, exposed me to those whose skill led to the discovery of the dictionary problem; missing spellcheck Files.

It was at Apple Discussions where I came across the problem solving skills of Eftsoon (UK), and fruhulda (Sweden). Unfortunately, in spite of the evidence, some (Very few), seem to think OPs are the Problem (Ignorant), instead of having a problem (In this case, missing spellcheck Files).

Finally (Not over night), I grabbed hold of the "baton" held out by our friends at Apple Discussions, and ran with it. Then you arlibie, also grabbed the "baton" and ran with it (Replacing the missing spellcheck Files), leading to the desired choice of English.

This is what I consider to be the healthy interaction of Forums, share what has been discovered by others, for the common good.


I'm running 10.6.5 and using Pages '09, is there a way to set that default language to Aust' English because every time I create a document I have to manually change it to Aust' English.

Hi moto51

See below what Alex has to say, and the comments that follow.


Looking at this thread with some interest, as I never have to change spelling or reset anything. (10.6.6, Pages '09 (4.0.5))

Alex, this comment may lead one to understand, you don't have any missing spellcheck Files that have plagued some of us.


The settings I have are listed below, just in case they form a combination that does what people want.
System Preferences>Language and Text>Language has "Australian English" at the top of the list on the left (and "English" as the order for sorted lists, though I don't know if that's important)
System Preferences>Language and Text>Text>Spelling "Automatic by Language"
System Preferences>Language and Text>Formats>Measurement units "Metric" (I've included this for the person whose ruler kept reverting to inches)
System Preferences>Language and Text>Input Sources "Australian" is ticked (I also have another one ticked, but it shouldn't be relevant)
System Preferences>Language and Text>Input Sources>Input Source options - Use the same one in all documents
In my menu bar the Australian flag shows a tick against "Australian"

Excellent, however, this will only work if the relevant spellcheck Files actually exist on your OS, which for some, are/were missing.


In case it's relevant, you might also try making a new Pages document, blank, with Australian English in the Inspector>Text>More section, and saving that as a template (File>Save as Template). You might then set General Preferences for New Documents to Use the template you made.

So correct, and, as I've pointed out in an earlier post, I do this, but after updating the OS, the relevant spellcheck Files were missing, resulting in the failure of template settings.


I would also point out that in the Auto-Correction Preferences of Pages, I have ticked only the smart quotes and the email and web addresses. I never ask a machine to check my spelling as I go, let alone alter it.

And this is the beauty of personal choice, however, if spellcheck Files are missing, guess what.


Sorry for long post, and perhaps none of this will be what is wanted, but here's hoping . . .

No apology needed, and thanks for your valuable input Alex. The chance is that others will find your post is articulating a personally felt query, leading to insight. An old Chinese saying has it, "A picture is equal to a thousand words." This is why I've used a number of graphics in this thread, it's a sort of, "Waffle avoidance Technique." But of course, not always successful; check? ;)

Cheers one and all, thanking you for your encouragement (http://www.google.com.au/search?q=mac+pages+tutorial&tbo=p&tbm=vid&source=vgc&hl=en&aq=1&oq=mac+pages); Mike.

BeePee
28th February 2011, 05:05 PM
Well all I did was use Cocktail to remove all unwanted languages (everything except English) in Language/Text select Australian English. Works for me.

Mike Sprawson
1st March 2011, 11:10 AM
Well all I did was use Cocktail to remove all unwanted languages (everything except English) in Language/Text select Australian English. Works for me.

I'll take that as a comment; check? :D