PDA

View Full Version : The ole Pismo keeps rearing it's ugly head



captain fantasy
20th August 2010, 12:28 PM
I have a new charger but nothing happens.
Can't turn on - nothing.
Pram battery measures approx 1.8v.
Did all the stuff you are required to do to make it work.
My question is: Can the machine turn on if the pram battery is removed and if the battery is approx 1.8v should that be enough to turn on etc.
This is a mint condition machine that doesn't go.
Do I cut my losses and give up or is there anything else I can try.
I know there are Pismo/Wallstreet/Bronze keyboarders out there and any assistance would be greatly appreciated.
CF

Byrd
20th August 2010, 01:57 PM
Yes the Pismo will still turn on with the PRAM battery removed (and unplugging it, as you are probably aware, is how to resurrect seemingly "dead" Pismos that haven't been used for some time).

Next up, I'd reseat the RAM (just have one known good working module installed), and reseat the CPU card. Also check the DC board.

JB

captain fantasy
21st August 2010, 02:56 PM
Thank you Byrd.

I'll work on the ram and the cpu, but how hard is it to check the DC board and what should I look out for.
And if it is the DC board is that the end of the Pismo?
Once again, thanks for your help.

Byrd
21st August 2010, 04:51 PM
You need to remove the top case, but it would be a last resort (assuming CPU, RAM all good) - checking for any charring/loose DC connector

cosmichobo
21st August 2010, 05:07 PM
DC card being the power/sound in card?

I've seen them on eBay common enough... though I guess you're buying an unknown... Is it really for sale cos it's busted...