PDA

View Full Version : IPhone4 MMS issue?



louiscypher
6th August 2010, 12:50 PM
Got it, love it, minor bar drop in low signal areas - not an issue

I fled Optus and took shelter with Telstra, and they've been great. And the signal strength is MARKEDLY improved

But......

Can't send MMS pics to anyone who is not with Telstra.
Phone says sent , no red flag, MMS and any attached text doesn't arrive

No problem Telstra to Telstra
No problem receiving MMS and or text from any carrier
No problem sending straight text to anyone

But, pics? Telstra only.

Is this Optus' revenge?????:crying:

nbetts
6th August 2010, 01:24 PM
been reports of this happening with all carriers over at Whirlpool.

Its been happening with me too and i am on Vodafone. I suspect there is a problem with the carrier files on the iOS 4 software. I have spoken to vodafone but unfortunately not gotten anywhere.

Complain to your carrier

Fitshaced
6th August 2010, 01:29 PM
Actually, just noticed that I cant figure out how to send an mms. And cant remember how I did it on the 3G. Can anyone show me?

nbetts
6th August 2010, 01:53 PM
tap the little camera icon inthe text field when writing an mms

sleek881
6th August 2010, 01:56 PM
I am on Telstra and i successfully sent an MMS to an Optus phone.

Fitshaced
6th August 2010, 02:02 PM
tap the little camera icon inthe text field when writing an mms
Yeah thats what I thought. I dont see to have that now. Just able to text. Is there a switch to turn it on?

nbetts
6th August 2010, 02:04 PM
its always on. do you have a jailbroken phone?

what OS are you using?

Fitshaced
6th August 2010, 02:07 PM
its always on. do you have a jailbroken phone?

what OS are you using?
Not jailbroken. Using 4.0.1. I noticed this problem the day I got it but thought I needed to search a bit more. I had to get the phone swapped on wednesday night for another issue but this one has the same problem. Must be an issue with my restore from my 3g. I really dont want to have to start again as I got it just right (apart from mms).

sleek881
6th August 2010, 02:34 PM
http://img.skitch.com/20100806-rnj7n46aamr4ucbag9tfhgf6f1.jpg

Can you see this button?

Fitshaced
6th August 2010, 02:48 PM
http://img.skitch.com/20100806-rnj7n46aamr4ucbag9tfhgf6f1.jpg

Can you see this button?
Nope

nbetts
6th August 2010, 02:57 PM
Ok then you do have a software issue. possibly something to do with your restore. i would set up as a new phone and start from scratch

grfxninja
6th August 2010, 03:00 PM
I am on Telstra and i successfully sent an MMS to an Optus phone.

Same (though it was actually a Virgin phone)

bassmanbliss
6th August 2010, 03:07 PM
Make sure MMS is turned on in your messages setting.

Fitshaced
6th August 2010, 03:15 PM
Make sure MMS is turned on in your messages setting.
I dont have an option to enable mms under settings/messages

mallo
6th August 2010, 03:19 PM
I dont have an option to enable mms under settings/messages


Yeah thats what I thought. I dont see to have that now. Just able to text. Is there a switch to turn it on?


its always on. do you have a jailbroken phone?

what OS are you using?

As mentioned, there is a switch to turn it on in message settings. If this is missing, call telstra, it may be disabled on your account. i've had a similar issue with vodafone before.

It's a carrier setting issue I believe.

i remember when 3.0 first came out in beta, people where installing the 3.0 betas, but not getting any MMS options, until they applied a hacked carrier setting.

Now that 3.0 is public, all the carriers carrier settings support MMS and so it should appear.

Maybe, did you restore from a jailbroken backup? even though are not jailbroken anymore?

As I believe sometimes the carrier file from the old jailbreak hangs around in this circumstance?

Fitshaced
6th August 2010, 03:23 PM
As mentioned, there is a switch to turn it on in message settings. If this is missing, call telstra, it may be disabled on your account. i've had a similar issue with vodafone before.

It's a carrier setting issue I believe.

i remember when 3.0 first came out in beta, people where installing the 3.0 betas, but not getting any MMS options, until they applied a hacked carrier setting.

Now that 3.0 is public, all the carriers carrier settings support MMS and so it should appear.

Maybe, did you restore from a jailbroken backup? even though are not jailbroken anymore?

As I believe sometimes the carrier file from the old jailbreak hangs around in this circumstance?
Well firstly, I'm with Optus. Going to check my old 3g but I remember it being there.

I'm going to do a factory restore and, should it reappear, just load all my stuff back on again. Shame I'll lose all my texts. Dont think I removed a text in over a year.

strange
6th August 2010, 03:32 PM
Sent an mms today from Telstra to Optus and although it sent fine from my iphone 4 my wife did not receive it on her optus 3GS.

Personally I blame Optus, but that's my default position for everything these days...

morebroadband
6th August 2010, 03:57 PM
I had the same problem today. I recommend the following:

1. Turn on MMS in Settings/Messages/MMS Messaging
2. Send a pic to yourself (make sure less than 300kb)
3. If you do not receive the mms then you have to restore iPhone
4. Back up iPhone first, then restore to original settings.
5. Turn phone off the reboot.
6. Try again - should work.

Unlike other handsets you cannot access the APN or other mms settings on iPhone.

louiscypher
6th August 2010, 05:28 PM
MMS now being received by Optus burdened friends and relatives.

Suspect that morebroadband's advice might have been the clincher - but I don't know how!

Essentially, my MMS and included text, is being received by Optus phones after I sent myself a picture (my Telstra sent to my Telstra)

Time for Bex and a good lie down.:frustrating:

Thanks again