PDA

View Full Version : iTunes 9.1 + ASL.dll error (iPad)



Pankeezy
8th June 2010, 03:45 PM
hey guys, just got a 16gb ipad 3g. problem is that i cant get itunes working whatsoever. heres what i went through:

i keep getting "The procedure entry point asl_add_log_file could not be located in the dynamic link library ASL.dll" when i try to run itunes, then when i connect the ipad i get an itunes error saying:

This ipad cannot be used because the required software is not installed. run the itunes installer to remove itunes then install the 64-bit version of itunes. the thing is that the itunes version IS 64-bit. now, ive tried uninstalling everything to do with apple, then doing a fresh install of itunes/quicktime etc. i still get both the asl.dll error and the 64-bit version error from itunes.

ive googled the ASL.dll error but all i find is something about jailbreaking and blackrain.. i have no clue of anything to do with jailbreaking, so i dont know why this error is associated with jb..

EDIT: i've also tried repairing itunes as well as everything to do with apple software on the pc. if it helps i am running windows 7 64-bit enterprise.

EDIT2: system restore did not help at all as the restore process also failed itself, i ended up deleting all restore points.

Pankeezy
8th June 2010, 09:17 PM
help anyonee??

Byrd
9th June 2010, 08:59 AM
I'd try downloading asl.dll from somewhere online (there are sites that specialise in having random .dll files, and placing it in your C:\Program Files\iTunes (or whatever) folder, and C:\Windows\System32 folder.

If missing - putting it on might fix up the issue.

JB

Pankeezy
9th June 2010, 10:08 AM
edit!! stupid me.. there was an older asl.dll file hanging around, i didnt delete it, all good now :D

thanks heaps for the suggestion.

Byrd
9th June 2010, 12:52 PM
Whoo! Good news. Sadly some of us still have to regularly use Windows here ;)

Pankeezy
10th June 2010, 06:52 PM
back again actually.. i was wrong, it didnt fix the error :(

i assumed it did because upon restarting after the fresh install, i would usually get the asl.dll errors, and that time i didnt, but when i tried connecting to itunes with the ipad, the errors came back.