View Full Version : Fink Update Error

25th January 2004, 01:54 PM
I want to update my binaries via FinkCommander, and I get this output.

Err file: local/main Packages
File not found
Ign file: local/main Release
Err file: stable/main Packages
File not found
Ign file: stable/main Release
Err file: stable/crypto Packages
File not found
Ign file: stable/crypto Release
Hit http://us.dl.sourceforge.net 10.3/release/main Packages
Hit http://us.dl.sourceforge.net 10.3/release/main Release
Hit http://us.dl.sourceforge.net 10.3/release/crypto Packages
Hit http://us.dl.sourceforge.net 10.3/release/crypto Release
Hit http://us.dl.sourceforge.net 10.3/current/main Packages
Hit http://us.dl.sourceforge.net 10.3/current/main Release
Hit http://us.dl.sourceforge.net 10.3/current/crypto Packages
Hit http://us.dl.sourceforge.net 10.3/current/crypto Release
Failed to fetch file:/sw/fink/dists/local/main/binary-darwin-powerpc/Packages File not found
Failed to fetch file:/sw/fink/dists/stable/main/binary-darwin-powerpc/Packages File not found
Failed to fetch file:/sw/fink/dists/stable/crypto/binary-darwin-powerpc/Packages File not found
Reading Package Lists...
Building Dependency Tree...
E: Some index files failed to download, they have been ignored, or old ones used instead.

Same thing happens when doing it via the terminal....
Anyone know what's the problem?
Elvis? :P

29th January 2004, 08:39 PM
can you post your sources.lst file?

I'll have a poke at my Fink setup when I get back to work tomorrow.

Asher Tuzza
30th January 2004, 01:18 AM
i dont suppose you noticed that, in finks current rendition it suggests not updating if your on panther but only updating on jaguar - jaguar is stable and ucntional - there are fink issues with the current build on panther...

30th January 2004, 11:05 AM
yeah, i'm getting the same errors. looks like a problem with the repositories. I'm guessing it will fix itself in time. :)

I'm a Debian-Unstable user, so I'm kind of used to seeing these sorts of things. :)

30th January 2004, 01:27 PM
ok, under fink preferences i enabled unstable packages for both normal and crypto. I then did an apt-get update and and apt-get dist-uprade, and was informed that the download locations have now changed.

however doing another update after that hasn't fixed much. for now i'm sticking with Asher Tuzza's explanation that panther-fink is a bit broken. I might go do some RTFMing for a moment.

2nd February 2004, 12:36 PM
I am a moron.

The /sw/etc/apt/sources.list file has entries in it pointing to local stores for fink binaries. Obviously if you don't store your own fink binaries, apt/fink will give you an error as it points to nothing.

Simple solution: ignore the error, or hand-edit your source.list file to comment out the local paths, and only point to the us.dl.sourceforge.net repositories.

See, now that was the obvious answer, and I should have thought about that first. :)