PDA

View Full Version : Hard Dive Icon Missing



wokka59
20th April 2010, 08:13 PM
My Hard Drive Icon has disappeared!


1. Finder prefs has Hard Drive ticked
2. Spotlight cannot locate my Disc
3. External discs are visible
4. 10.6.3 Running
5. Disc does show at the bottom of the window in the pathway bar
6. Disc still remains as the startup disc in prefs

Any ideas?

Cheers

Wokka

soulman
20th April 2010, 08:34 PM
Have you tried logging out &/or restarting?

wokka59
20th April 2010, 08:51 PM
Restarted, logged out. No change.

soulman
20th April 2010, 10:36 PM
Finder prefs has Hard Drive tickedThere are two places to show the hard disk in Finder prefs. One is to show it on the desktop, the other is to show it in the sidebar. If you tick Hard disks under Devices in the Sidebar section, does it then show up in the sidebar?

It sounds like it could be some sort of Finder prefs issue, so perhaps drag the file com.apple.finder.plist from your Preferences folder to the desktop then log out and see if that fixes it. If not, just put the file back.

Also, I would check the disk - verify/repair - in Disk Utility if you haven't already done so. If you have any other disk repair utilities, like Disk Warrior or TechTool Pro - then I suggest you run them too.

Have you done anything recently, like used Onyx or Cocktail or a similar utility, to mess around with the system?

wokka59
21st April 2010, 08:38 AM
Thanks for replying. Devices is ticked. Booted from Install disc, ran disc utility, disc repaired, green text to say disc is repaired. Still doesn't mount. I'll try to treash the plist file next. If that doesn't work I might erase the HD and restore from time machine.

Wokka

soulman
21st April 2010, 10:50 AM
I don't think this is serious enough to warrant an erase & restore, but it's your time. :) It's worth remembering that your disk is definitely mounting, otherwise the machine wouldn't boot and you wouldn't have access to any of your files. It's a Finder issue I would say - the disk is there & probably fine, just that the Finder has lost track of it.

Remember, there is no need to trash the finder prefs - just pull the file out of the Prefs folder first and let the Finder create a new one. If that fixes the problem then trash the old one.

gehenna
21st April 2010, 10:54 AM
Are you using Path Finder at all? There is a preference in there to hide the actual Finder's desktop icons...

stewiesno1
21st April 2010, 12:20 PM
There are also terminal commands to mount disks that don't want to play even though as Soulman says
It's a Finder issue I would say - the disk is there & probably fine, just that the Finder has lost track of it.
That's if none of the above trashing , moving pref files etc works that is.
The terminal command just might force the finder to accept the mount command to the desktop.

Stewie

Byrd
21st April 2010, 12:58 PM
I'd try making another user account and see if it surfaces then :)

wokka59
21st April 2010, 07:55 PM
Interesting - no com.apple.finder.plist in my prefs folder. Am going to try an archive and install, but can't do this on snow leopard I believe?

wokka59
21st April 2010, 08:38 PM
The finder is definitely screwed up. In the Finder prefs the ext drives do not go off the desktop when their boxes are unticked. I've done a new archive and install equivalent and still no icon. I wonder why there is no pref file for the finder? Did someone say you can delete it via the terminal.

What happens if I put my entire prefs folder on the desktop? Shouldn't a whole new set of prefs be created in their place?

Darwiniandude
21st April 2010, 08:41 PM
You know there are two prefs folders? one in /Library and one in ~/Library (Library in your home folder)

Create a new user account, log into it, and see if it works there.

Snow Leopard always does an archive and install, you have no choice. They did this presumably because newbies thought that Erase and Install would keep all their files...

scarbrow
23rd April 2010, 07:55 AM
just a simple question, have you cleaned up the desktop/re-arranged the icons? its possible the icon is there but has been moved to be just off screen.