PDA

View Full Version : total noob question



onrails
30th March 2010, 03:12 AM
hey sorry extremely new here and I am wanting to upgrade to the latest ox. I have an Imac 2007 I think running 10.4.11 2ghz intel duo 2GB 667 DDR2 SDRAM L2 cache 2MB.
What system software with this run??

Cheers Onrails

u98925
30th March 2010, 06:56 AM
You'll need to purchase Snow Leopard 10.6 and then run software update to install the recently release 10.6.3 update :)

Balthazar
30th March 2010, 10:33 AM
Sounds like your iMac CAN run leopard (10.5) or Snow Leopard (10.6) just fine, but my question is, do you really need it? What extra's features are you looking for or problems that you have that need a solution?

(p.s. Leopard is an excellent upgrade from Tiger)

gehenna
30th March 2010, 10:37 AM
Snow Leopard will run very well on your machine, and I'd highly recommend skipping Leopard altogether and just upgrading Tiger to Snow Leopard directly. You'll gain performance improvements along with the extra features

~Coxy
30th March 2010, 10:46 AM
Yep I agree, go straight to 10.6. It's a lot cheaper than 10.5 is, even now!

jaysee
1st April 2010, 02:10 PM
There's no reason for anyone to run Leopard on that kind of hardware anymore. Snow Leopard is faster, more refined and more compatible. For $39 it's a no-brainer!

:)

John

Balthazar
1st April 2010, 02:31 PM
Unless of course it breaks some of the software you need to run that snow leopard dosent support

nibbles
2nd April 2010, 06:55 AM
Next time mate use a better title like which os x version should I be using or something, to answer your question snow leopard is the latest and will run the best on your hardware, don't bother with leopard and before you upgrade is there any 'classic' app you run, it is one that would take a while to open and look quite old, if you do have one then it won't be supported on either leopard or snow leopard.