PDA

View Full Version : Slow internet on new Mac?



maybelle
11th February 2010, 10:52 PM
We bought our daughter a 13" Macbook for Christmas and connected it to the Netgear router. Its running very slow and takes forever to get any webpage up. We have had other notebooks connected to the router before without any problems. Any suggestions?

ClockWork
12th February 2010, 12:00 AM
Is it connected by Ethernet or is it connected Wirelessly?

maybelle
12th February 2010, 12:09 AM
The router is connected by ethernet to our PC. I've connected the Mac wirelessly.

ClockWork
12th February 2010, 12:31 AM
Try connecting the MacBook directly to the Netgear Router, via an Ethernet cable.

Then click on the Apple menu and scroll down to System Preferences...
In the System Preferences window, click once on Network and in the left column, click on Ethernet to make sure it's activated.
Then close off the Network window and try browsing on the MacBook.

Does it surf at full speed in this way?

maybelle
12th February 2010, 09:25 PM
The Ethernet is not activated.
Status: Ethernet is not plugged in or the device at the other end is not responding.

How do I activate it?

Aladdin
12th February 2010, 09:42 PM
http://img.skitch.com/20100212-ejppreg5fy6kwuagmrqkthda42.preview.jpg (http://skitch.com/aladdin/niy2d/network-prefpane)
Click for full size (http://skitch.com/aladdin/niy2d/network-prefpane) - Uploaded with plasq (http://plasq.com)'s Skitch (http://skitch.com)

It should look like this.

There should be a green dot next to Ethernet.

Have you tried connecting the PC end of the ethernet cable into the MacBook? At least this way, you're only changing one thing at a time.