PDA

View Full Version : Fire Extinguished After Tiger



AusMac
14th August 2005, 06:18 PM
don't know where to put this but I'll start here maybe the mods will fix it.
My machine moved to Tiger this weekend but Firefox would not run nor Firebird, which both had run all the way through all the system upgrades to this point.
Other things I have managed to repair or nut out what needs to be done. However the Firefox/firebird issue has me stumped at present.

Date/Time: 2005-08-14 17:01:53.278 +1000
OS Version: 10.4.2 (Build 8C46)
Report Version: 3

Command: firefox-bin
Path: /Applications/Firefox.app/Contents/MacOS/firefox-bin
Parent: WindowServer [95]

Version: 1.0.6 (1.0.6)

PID: 410
Thread: 0

Exception: EXC_BAD_ACCESS (0x0001)
Codes: KERN_INVALID_ADDRESS (0x0001) at 0x16000000

Disko
14th August 2005, 06:24 PM
Which version of Firefox is it? If it isn't the latest - try downloading that one. I use the G5 build of firefox... when i actually use firefox instead of Safari ;)

AusMac
14th August 2005, 08:08 PM
Build 1.0.6 ..As it is stated above in the crash report.
Of course I am using Safari now and it is quite useable but somehow cumbersome if you are used to using Firefox.
Also most of my commonly used bookmarks are in Firefox.
Maybe I should look for daily builds?

AusMac
15th August 2005, 02:12 PM
The problem is definitely in my user account as I can open firefox and run it in my wife's user account.

purana
15th August 2005, 02:24 PM
Have you tried removing the prefs file in your profile associated with firefox, and see if it makes a difference.

AusMac
15th August 2005, 02:44 PM
Hmm. renamed the files to firefox.old and still had the crashes .. Last night my son was allowed access from afar and he said he had firefox loading, after many crashes but it still would not load for me . I am currently testing whether it is an user account or firefox profile issue. Point is that it is a problem both with using firebird and firefox and the only difference between these two is at computer library level .. not at user level

purana
15th August 2005, 03:04 PM
Originally posted by AusMac@Aug 15 2005, 02:44 PM
I am currently testing whether it is an user account or firefox profile issue. Point is that it is a problem both with using firebird and firefox and the only difference between these two is at computer library level .. not at user level
If either firebird or firefox from a different user account, then its something to do with your home dir. It might just be a file in one of the dir tree's. Which one I dont know. Not without having a machine in front of me to explore and see how it crashes when I move files relating to each product.

Maybe you might have some luck by doing some stuff and seeing how it behaves. Will be interesting to see with a different user if either program works ok.

AusMac
15th August 2005, 04:51 PM
correct.
Sorry I took so long to reply (other threads occupying my attention as well as getting the washing dry between showers).
Intuition led me to believe that since disabling user profiles failed.. that it was something that enhanced the app at login level.
This could be application enhancers or internet plugins say..
So I checked user profiles and found that due to my usual sensibility, I had not installed anything unusual on any other than the admin account.
The internet plugins folder held a file named "JavaEmbeddingPlugin.bundle"
but my wife's internet plugins folder .. did not. so I deleted the file and .. hey presto she works!

The fire has been reignited
Problem solved.
just add that:
If you are using firefox and require this plugin, have upgraded to tiger and have not upgraded the plugin.. here it is (http://prdownloads.sourceforge.net/javaplugin/JavaEmbeddingPlugin0.9.3.zip?download)