PDA

View Full Version : Viewing wmv e-mail attachment



hampo
10th November 2009, 01:51 PM
If I receive an e-mail with a WMV file attached I can't run the movie file, I get an alert saying "Quicktime must be installed to run the file" or similar. However if I save the file to my d/l folder, open Quicktime and then select the file from the menu, open file, the file runs OK.

Any ideas?

iMac 10.6.2, Mail

ClockWork
10th November 2009, 02:11 PM
Download Flip4Mac (http://dynamic.telestream.net/downloads/download-flip4macwmv.htm) and Perian (http://www.perian.org/).

hampo
10th November 2009, 02:15 PM
I have Flip4Mac and Perian installed (I think)

gehenna
10th November 2009, 02:23 PM
You need to associate WMV with Quicktime. Go to one of the videos in your Downloads folder, Get Info on the file, change Opens With to Quicktime and then click the button to Change All. This means all WMV files from now on will open with Quicktime, previously they had no default application to open with which is why you were able to play them by opening them manually.

ClockWork
10th November 2009, 02:25 PM
Drag a wmv file onto your Desktop.
Click on it once to highlight it and then hit the: :cmd: + I keys on your keyboard.
This opens its Info Window.

Under the sub-heading half way down the Info Window under Name & Extension, called: Open with:

- click on whatever is there and scroll down to: QuickTime Player.app, and then after you've done this, click the button beneath that, called: Change All...

Then click the Continue button, and close off the Info window.

See how you go.

hampo
10th November 2009, 02:25 PM
Thanks, much appreciated. I'll try that when I'm next in front of the Mac. Am currently at work on XP machine.

hampo
10th November 2009, 05:21 PM
Thanks, worked a charm

StuartMac
10th November 2009, 08:51 PM
Got the same problem but that fix didn't work.
Tried installing Perian and flip4mac but they won't work on my old Mac OS X 10.3.9
Is my G4 just too old or can I upgrade to 10.4.7 or whatever I need to run Quicktime 7?
I got all excited about upgrading to Snow, but the lack of an Intel has buggered that idea.

ClockWork
11th November 2009, 03:34 AM
yeah - Mac OS 10.3.9 is really no longer supported - time to consider upgrading.

StuartMac
11th November 2009, 08:26 AM
Thanks Clockwork. I might start a new thread seeing as my next q is even further OT

stewiesno1
11th November 2009, 08:55 PM
Well not completely true.
I have a DA ( dual 533MHz ) and OS10.2.6 which plays a .wmv file just fine so your G4 ( whatever it is ) should play it fine.
I can't remember if I downloaded anything in the past to make it open but it does it easily.
I just clicked on a small .wmv file and it opens in Windows Media Player.

Stewie