PDA

View Full Version : Help With Etherape



sidd
2nd August 2005, 05:04 PM
$ fink install ethereal
Information about 1793 packages read in 1 seconds.
Failed: Can't resolve dependency "x11" for package "gtk+2-2.4.9-9" (no matching packages/versions found)
venu-gopal-metlas-powerbook-g4-15:~ sidd$ fink install gtk+2-2.4.9-9
Information about 1793 packages read in 1 seconds.
Failed: Can't resolve dependency "x11" for package "gtk+2-2.4.9-9" (no matching packages/versions found)


any help. i tried installing x11 and that didnt work.


any help as to why this happens on macosx. i thought it should install all dependencies automatically.

tx
sidd

MacDave
2nd August 2005, 06:25 PM
Did you do the fink install as root ?



c-67-161-2-136:~ root# fink install ethereal
Information about 1811 packages read in 2 seconds.
The following package will be installed or updated:
ethereal
The following 13 additional packages will be installed:
atk1 atk1-shlibs gtk+2 gtk+2-dev gtk+2-shlibs gtk-doc pango1-xft2
pango1-xft2-dev pango1-xft2-shlibs pcre pcre-bin pcre-shlibs xfree86
Do you want to continue? [Y/n] y


If fink continues to fail, try DarwinPorts:

c-67-161-2-136:~ root# port install ethereal
---> Fetching libiconv
---> Attempting to fetch libiconv-1.9.2.tar.gz from ftp://ftp.gnu.org/gnu/libiconv
---> Verifying checksum(s) for libiconv
---> Extracting libiconv
---> Configuring libiconv
---> Building libiconv with target all
---> Staging libiconv into destroot
---> Packaging tgz archive for libiconv 1.9.2_1
---> Installing libiconv 1.9.2_1
---> Activating libiconv 1.9.2_1
---> Cleaning libiconv

Danamania
2nd August 2005, 06:27 PM
Originally posted by sidd@Aug 2 2005, 05:04 PM
$ fink install ethereal
Information about 1793 packages read in 1 seconds.
Failed: Can't resolve dependency "x11" for package "gtk+2-2.4.9-9" (no matching packages/versions found)
venu-gopal-metlas-powerbook-g4-15:~ sidd$ fink install gtk+2-2.4.9-9
Information about 1793 packages read in 1 seconds.
Failed: Can't resolve dependency "x11" for package "gtk+2-2.4.9-9" (no matching packages/versions found)


any help. i tried installing x11 and that didnt work.


any help as to why this happens on macosx. i thought it should install all dependencies automatically.

tx
sidd
It's possible you don't have the x11 meta-package installed. It's a package that doesn't technically exist as code, but just defines that you already have Apple's own X11 installed, letting fink know it's present.

As fink doesn't control the installation or not of the Apple X11, it can't automatically resolve its dependencies, so you have to manually install this 'fake' X11 package in fink. it's called "system-xfree86" so:

fink install system-xfree86

should get you up & running. It'll only take half a moment as it's not really installing anything but an entry in fink's database.

dana

sidd
2nd August 2005, 07:47 PM
fink install system-xfree86
Password:
Information about 1793 packages read in 1 seconds.
Failed: no package found for specification 'system-xfree86'!


doesnt work :(

and yes i installed fink in root

Nevets_Anderson
14th August 2005, 06:01 PM
Have you got the latest version of the develper tools installed?

There was a patch a while ago that sorted a number of fink problems..

atkins
22nd August 2005, 08:28 PM
so Sidd

After all the replies, did you actually get this working? I ask as I too have the same problem!!!

Jason

sidd
24th August 2005, 03:42 PM
Jason,

yes i did get to install ethereal and it is working.
etherape on the other hand didnt work. i did a install from fink via command line and it was a clean install. all looked good but i cant find a binary to run. nothing under /sw/bin and a locate comesup with no binaries.

the best way to go about it

1. Install x11 and xcodetools and x11sdk from the cds
2. install fink after step1 is installed perfectly.
3. update fink as necessary
4. fink install ethereal --> should do a clean install
5. once done ethereal should work like magic.

follow the steps and you should be fine. if you have fink and darwinports installed already i would recommend to clean them up and follow the steps.

investigating about etherape still.

tx
sidd--

macintoshrules
24th August 2005, 04:18 PM
Etheral works fine. Etherape doesn't, theres no binary anywhere...

sidd
25th August 2005, 09:23 AM
did u try darwin ports.

well i spent 6 hours yesterday and it still keeps saying the cheksum is invalid for etherape.


pissing me off.....


i wanttttttttttttt etherapeeeeeeeeeeeeeeee