PDA

View Full Version : Spotlight returning strange results in Snow Leopard



gumby08
29th August 2009, 03:21 PM
Since upgrading my Unibody MacBook (2008 model) to Snow Leopard searches in Spotlight for certain files is displaying Japanese (?) text.

Spotlight search for Airport Utility:
http://img.skitch.com/20090829-j3b27uuubqumwjyq3f3wc6n888.jpg

Spotlight search for Activity Monitor:
http://img.skitch.com/20090829-t9x4a7t5dmcyyej96fe3wxb1gd.jpg

Displaying the Utilities folder without using Spotlight shows the names correctly:
http://img.skitch.com/20090829-g6myfhk49qsm4fn4egk8f4ta4y.jpg

Any suggestions on how to fix this?

incanspyder
29th August 2009, 03:45 PM
No idea, but why only black out 2/3 pictures?

Beau
29th August 2009, 03:46 PM
No such issues here:
http://img.skitch.com/20090829-kst1xcjr1qxp17dmirsgqk6dkt.jpg

What have you got set up in the 'Language & Text' preference pane?
http://img.skitch.com/20090829-mbn8jxkjj2hw15ququ6nb25gap.jpg

gumby08
29th August 2009, 03:54 PM
No idea, but why only black out 2/3 pictures?

Because I don't have much of an eye for detail I guess :D

Languages and Text preferences:

http://img.skitch.com/20090829-en5dj8r4k8sedbmgum3fq6k74r.jpg

http://img.skitch.com/20090829-9xftpu1gj1pb1pm5bernbf9rd.jpg

http://img.skitch.com/20090829-r6auw51j1gndkwtxa9inb19958.jpg

babypoppop
29th August 2009, 04:05 PM
anyway, i've tried spotlight-ing something similar to what you've spotlight-ed, but i didn't get such results. sorry. i'm of no help.

matthew858
29th August 2009, 04:13 PM
Funny you should mention this, I had the exact same issue! I changed the languages so it would only ever use Australian English in System Preferences (unticked all but the one box), then rebooted the computer.

gumby08
29th August 2009, 04:27 PM
Funny you should mention this, I had the exact same issue! I changed the languages so it would only ever use Australian English in System Preferences (unticked all but the one box), then rebooted the computer.

How strange! Reboot didn't help, but when I changed my Language Preferences to the same as Beau's (ie adding British English and English), it fixed the problem.

Thanks everyone for your assistance :)

MissionMan
29th August 2009, 04:35 PM
Had the same problem. Odd little glitch as I also set mine up with only aus english and had issues.

Remy
29th August 2009, 05:10 PM
Hmm... no such oddness on my MBP.

dt
29th August 2009, 06:18 PM
I've got exactly the same problem as you. I tried to put the languages back in the prefpane but it didn't work.

Eventually, the md* processes (mds, mdworker etc) kept crashing and spotlight kept trying to perpetually index my drive.

I tried an archive/install, but that didn't fix it. So I had to do a clean install.

I noticed it first when I searched for "address book" in spotlight, it came back with the asian characters.

asphotos
2nd September 2009, 09:55 PM
Glad its not just me.. ive tried changing the language and its still japanese :)

about to reinstall and see what happens, mbp 3,1 (mid 2007)

rjch
3rd September 2009, 05:39 PM
Asphotos. I have the same problem. Did the reinstall fix it? Apple discussions suggest that you have to add "English" as well as "Australian English" in language preferences. That worked here.

asphotos
3rd September 2009, 08:48 PM
reinstall fixed some items (airport is now english) but disk utility isnt, it seems to only be my /utilities folder as well.

will add normal english to the options,

i was always going to fresh install once I was hapy with SL, but the above will be a stop gap

its only spotlight thats displaying incorrectly, and i know some japanese!

matthew858
3rd September 2009, 09:22 PM
Just make sure that you have the 3 options Beau posted above in your Language settings and all will be fine. It happened to me as well.

Edit - Here are the languages you will need:

http://img.skitch.com/20090829-mbn8jxkjj2hw15ququ6nb25gap.jpg

Add them, then restart the computer and all will be fine. No need for a re-install :)

Beau
3rd September 2009, 09:28 PM
Just make sure that you have the 3 options Beau posted above in your Language settings and all will be fine. It happened to me as well.

Edit - Here are the languages you will need:

http://img.skitch.com/20090829-mbn8jxkjj2hw15ququ6nb25gap.jpg

Add them, then restart the computer and all will be fine. No need for a re-install :)

Thankyou for nicking my setup. :P
I've had this since I got my Mac - Australian English comes first as well, that's where I'm from. If I type in an english word that's not found in the AU dictionary, then it looks it up in the British dictionary as that's closer to our spellings than the US. And then of course, British is followed by the US. It's a fluke that it fixes up the spotlight funkiness as well!

asphotos
3rd September 2009, 09:57 PM
language and text adjustments (as above) and a kick in the battery fixed it..

bundle
13th October 2009, 02:49 PM
What fixed it for me was putting the generic language at the top of the list e.g. English