PDA

View Full Version : [Mega-Merge] Snow Leopard Compatibility Thread



rhb
5th August 2009, 01:06 PM
I have just installed a freebee copy of EazyDraw (from Macworld UK disc). It is version 2 and of course they want to then sell you the newer version 3.
In the readme file it says that ".. versions prior to 3.1.0 will not work on Snow Leopard."
Is this going to be a problem with many existing programs? In this case the program was free, but if I go to 10.6 will I find lots of programs not working?

Lutze
5th August 2009, 01:24 PM
There are a few applications that don't work in Snow Leopard currently. The ones that I've seen are:

Bento
&
iStat Menu

I'm sure others will have noted a few others. Developers have had over a year to work on their applications so that when the 10.6 release comes they *should* all be up to date and work fine after an update by the vendor.

marc
5th August 2009, 01:49 PM
iStat Menus
We should be ready for 10.6 when it's officially released, if not before.


Is this going to be a problem with many existing programs? In this case the program was free, but if I go to 10.6 will I find lots of programs not working?
Generally speaking, no. Most apps should work just fine if they were ok on Leopard. However, each new OS release brings changes to frameworks. A drastic change to an OS X framework can mean all apps that use it will need updating. iStat Menus is the same... there's lots of menu bar apps that will require updating for Snow Leopard.

Lutze
5th August 2009, 02:59 PM
We should be ready for 10.6 when it's officially released, if not before.

Sorry Marc, I should have noted that you'd said you were working on this and had an internal beta that was being tested (as you've posted about before) - very sloppy of me to have not mentioned that.

I'd love to get a list of known apps that don't currently work though.

tcn33
14th August 2009, 10:50 AM
With 10.6 right around the corner, you may be wondering whether Snow Leopard supports that one app you can't live without. I've compiled a few and figured I'd crowdsource the rest :)

If you find SL-compatible apps, post them here!

Note: please post a link to the announcement or the app's system requirements.

1Password: Yes (http://news.softpedia.com/news/1Password-2-9-24-Fixes-Snow-Leopard-Bug-119056.shtml)
NetNewsWire: Unsure (https://twitter.com/nnw_Mac/status/2155634141). 4.0 definitely, 3.2 maybe.
Parallels: Yes (http://macmegasite.com/node/5746)
Skitch: In development (http://twitter.com/skitch/status/2271648701).
Tweetie: Yes (http://www.macnn.com/articles/09/05/05/tweetie.111.released/)

dotnet
14th August 2009, 10:59 AM
A few that are important to me:

VMWare Fusion 2.0.5: Yes
Office 2008 for Mac: Yes
Aperture 2.1.3: Yes
Xrite EZcolor 2.6.6: Yes
iStat Menus: No, but coming soon :)
iStat Server: Yes

Cheers
Steffen.

dotnet
14th August 2009, 11:02 AM
Preference Panes:

Flip4Mac 2.2.3.7: Yes (32bit)
Perian 1.1.4: Yes
Targus 2.0.0b2: Yes (32bit)

Cheers
Steffen.


Cheers
Steffen.

tcn33
15th August 2009, 08:14 AM
Confirmed in testing:

Firefox 3.5: Yes
Coda: Yes
NNW 3.2b14: Yes

samuelowens
15th August 2009, 11:56 PM
Flip4Mac (2.3.0.7 beta with SL compatibility): yes
1Password (3.0 beta with SL compatibility): yes

incanspyder
16th August 2009, 12:16 AM
VERY IMPORTANT

Medialink: NO
Cisco VPN Client: NO YES - version 4.9 0180 (not 0100) works in SL 10.6 (THANK HEAVEN!)

I'm screwed now that these 2 important programs aren't working for me. Can't live life without the VPN!

What's this bullshit with Cisco not letting you download their VPN clients directly? I mean you use it to access a paid server, so why not? I had to torrent my way through it for something I had a legitimate licence to use, just so I could get the updated version!

pengu
16th August 2009, 05:10 AM
VERY IMPORTANT

Medialink: NO
Cisco VPN Client: NO YES - version 4.9 0180 (not 0100) works in SL 10.6 (THANK HEAVEN!)

I'm screwed now that these 2 important programs aren't working for me. Can't live life without the VPN!

What's this bullshit with Cisco not letting you download their VPN clients directly? I mean you use it to access a paid server, so why not? I had to torrent my way through it for something I had a legitimate licence to use, just so I could get the updated version!

I thought someone said that 10.6 has built in support for the Cisco VPN stuff?

DeanCorp
16th August 2009, 07:16 AM
VERY IMPORTANT

Medialink: NO


I am using Medialink in Snow Leopard. Works fine :)

tcn33
16th August 2009, 09:05 AM
Forklift: No
Transmit: Yes :)
Transmission 1.73: Yes
Bento 2: Yes, although a bit flaky when restoring from backup.

incanspyder
16th August 2009, 11:40 AM
I thought someone said that 10.6 has built in support for the Cisco VPN stuff?

Tried it, works just as shit as it did in Leopard. (i.e. not at all)


I am using Medialink in Snow Leopard. Works fine :)

HOW?!?! I see my server except it just says "there are no titles". My firewall is off as well and all settings are same as they worked in 10.5.8

mustgroove
16th August 2009, 10:20 PM
Vuze (4.2.0.4): No - the app will run but opening new torrent files produces errors, plus seems not to want to seed existing torrents

XLD: No - the app will run but files won't encode properly

Max 0.8.1: No - app will run but won't encode files properly, also the "Formats" section in Preferences does not load properly (therefore cannot select other codecs)

pengu
16th August 2009, 11:24 PM
Tried it, works just as shit as it did in Leopard. (i.e. not at all)



apparently it does work? i dream of code, How to connect to FIU's Cisco VPN natively in Snow Leopard (http://tumblr.idreamofcode.com/post/136307207/how-to-connect-to-fius-cisco-vpn-natively-in-snow)

DeanCorp
16th August 2009, 11:33 PM
Tried it, works just as shit as it did in Leopard. (i.e. not at all)



HOW?!?! I see my server except it just says "there are no titles". My firewall is off as well and all settings are same as they worked in 10.5.8

Sorry mate, your right. I didn't bother to check it until this evening. It is detected, but will not list the folders/files.

El Guardo
17th August 2009, 12:22 AM
Can this thread have the original post updated to reflect the contents of all subsequent comments - that way we have one source to read instead of pages to scan through. Pretty please...

pengu
17th August 2009, 12:25 AM
Can this thread have the original post updated to reflect the contents of all subsequent comments - that way we have one source to read instead of pages to scan through. Pretty please...

this sort of thing would be best served with a wiki.

bed
17th August 2009, 01:02 PM
This is my list so far, tested with build 10A432:

Evernote - yes
1Password - yes - safari must run in 32bit mode for plugin to work
Path Finder - yes
Growl - yes
Parallels - yes with 32bit kernel only
Fluid - yes
iStatMenus - not yet - update coming. Could use iStat non widget instead
NetNewsWire - yes
Things - yes
ExpanDrive - update coming - 2.02 beta is buggy
MacFuse - yes with 32bit kernel only
VLC - yes
KeyWurl - no. REPLACE WITH GLIMMERBLOCKER
AdBlock - safari must run in 32bit mode - with SIMBL. Working on fix REPLACE WITH GLIMMERBLOCKER
GlimmerBlocker - yes
SIMBL - yes - BUT apps must run in 32bit mode for plugin to work enabling SIMBL on Snow Leopard | hackd (http://hackd.net/2009/06/18/enabling-simbl-on-snow-leopard/)
smcFanControl - yes
Mozy - yes from 1.4
Perian - workaround see First impressions: 10.6 10A380 Mac OS X Snow Leopard Developer Preview – ProjectDaenney.org (http://projectdaenney.org/2009/first-impressions-mac-os-x-snow-leopard-developer-preview)
Visor - yes - BUT Terminal must run in 32bit mode (for SIMBL to work) - and visor set to Fullscreen

still to test:
Adium -
iiUsage -
Clypan -
Mail Unread Menu -
ScrobblePod -
EyeTV -

tcn33
17th August 2009, 01:12 PM
iiUsage: Yes

dotnet
17th August 2009, 03:06 PM
Perian - workaround see First impressions: 10.6 10A380 Mac OS X Snow Leopard Developer Preview ProjectDaenney.org (http://projectdaenney.org/2009/first-impressions-mac-os-x-snow-leopard-developer-preview)

The current version of Perian (1.14) is 64-bit and doesn't require any workarounds:


Perian: Mach-O universal binary with 3 architectures
Perian (for architecture x86_64): Mach-O 64-bit bundle x86_64
Perian (for architecture ppc): Mach-O bundle ppc
Perian (for architecture i386): Mach-O bundle i386

Cheers
Steffen.

incanspyder
17th August 2009, 05:23 PM
The current version of Perian (1.14) is 64-bit and doesn't require any workarounds:


Perian: Mach-O universal binary with 3 architectures
Perian (for architecture x86_64): Mach-O 64-bit bundle x86_64
Perian (for architecture ppc): Mach-O bundle ppc
Perian (for architecture i386): Mach-O bundle i386

Cheers
Steffen.

Perian doesn't work for me (1.1.4). Oh and pengu - I've read that already, the method doesn't work for the USYD VPN.

rmac
17th August 2009, 05:44 PM
AppCleaner: Yes. made my own uninstall service with Automator 2.1, pretty cool.
Colloquy: Yes
Coversutra: Yes
Cyberduck: No. doesnt open at all.
Dropbox: Yes
Firefox 3.5.1: Yes
Frostwire: Yes
Google Earth: Yes
Handbrake: Yes
jGRASP: Yes, need to download & install Rosetta.
Miro: Yes
MPEGStreamclip: Yes
NodeToad: No, menu bar app opens, but then crashes.
Nokia Multimedia Transfer: Yes
Pacifist: Yes
Paintbrush: Yes
Schoolhouse: Yes
Skype: Yes
TextWrangler: Yes
The Unarchiver: Yes
VLC 1.0.1: Yes

nightelves
17th August 2009, 08:23 PM
Can anyone confirm whether Appzapper work and Little Snitch work?

gikku
17th August 2009, 08:43 PM
EyeTV 3.1.2(5237) : Yes mostly,
EyeTV 3.1.3b1 here Elgato Product Compatibility with Mac OS X 10.6 Snow Leopard (http://support.elgato.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=3611&nav=0,1&languageid=1&group=englishdefault)

samuelowens
17th August 2009, 09:40 PM
Vuze (4.2.0.4): No - the app will run but opening new torrent files produces errors, plus seems not to want to seed existing torrents


Reproduced here. Apparently, you can drag the torrent file in. I've switched to Transmission, which works fine.

Beau
17th August 2009, 09:44 PM
LittleSnitch 2.1.4 works fine.

Most screensavers that worked on Leopard will not work by the way, until they're updated. :(

tcn33
17th August 2009, 09:47 PM
AppZapper 1.8 works just fine.

gehenna
17th August 2009, 10:16 PM
Anyone had a go with Xslimmer under SL out of curiosity?

samuelowens
17th August 2009, 10:40 PM
VLC 1.0.1 has an issue with the Apple Remote when iTunes is open for me. Pausing the video starts the current tune and vice versa.

DeanCorp
18th August 2009, 12:29 AM
Monolingual works fine too

gikku
18th August 2009, 08:11 PM
woops!

http://i781.photobucket.com/albums/yy93/gikku33/Screenshot2009-08-18at80915PM.jpg

http://i781.photobucket.com/albums/yy93/gikku33/Screenshot2009-08-18at80927PM.jpg

dotnet
18th August 2009, 10:02 PM
Well, Rosetta is an optional install with SL. Good to see it's still supported :)

Cheers
Steffen.

Currawong
19th August 2009, 12:17 AM
Anything at all that uses the "Menu Extra Enabler" wont work, so no iStat menus, no Soundsource.

USBOverdrive: Works, after Mac OS X brought up a warning about a bad kernel extension install, but the thumb buttons on my G9 don't register any more with it.

The Silicon Image 3132 driver for their Expresscard SATA card works fine, without a reboot after installing the driver, despite the 10.6 installer removing it citing incompatibility.

Mailtags: Doesn't work.
Adium: Works
Skype: Works, but haven't tried a voice call yet.
Default folder: There's an update that works.
Little Snitch: The current version works, but there's a nightly with "preliminary 10.6 support".

Fink: I don't expect support for some time.

Will try Adobe and Apple apps soonish.

Devil rolla
19th August 2009, 08:13 AM
MetaX ?
Stattoo ?
CheetahWatch ? ( I know )

also, you can command + option + I on any apps in ur application folder and it will tell you if it is PowerPC, universal or Intel.

Huy
19th August 2009, 08:16 AM
you can command + option + I on any apps in ur application folder and it will tell you if it is PowerPC, universal or Intel.

Why do you need the 'option'?

Devil rolla
19th August 2009, 08:21 AM
If you hit option the screen doesn't disappear / you don't need to open the details for every app.

Helpful ?

the_doctor
20th August 2009, 02:16 PM
Anyone know if VisualHub and AudialHub work?

Lutze
20th August 2009, 02:33 PM
Anyone know if VisualHub and AudialHub work?

Visualhub certainly does.

http://img190.imageshack.us/img190/4327/vhsl.jpg

Beau
20th August 2009, 03:39 PM
AudialHub also works fine.


I installed QuickTime Pro 7 though, if that's any help.

W9cae
20th August 2009, 03:49 PM
I have just noticed in Mac OS X 10.6 (10A432) MobileMe will not synch. Goes through the motions but never synchs. It will connect to MobileMe & you can read from your account etc. But synching information it just will not.

spuds_imac
20th August 2009, 03:53 PM
Mobile Me works fine for me including synch with 10A432.

W9cae
20th August 2009, 03:55 PM
Hmm thats interesting I cant seem to get it to work. Not doing anything different....

tcn33
20th August 2009, 03:55 PM
I have just noticed in Mac OS X 10.6 (10A432) MobileMe will not synch. Goes through the motions but never synchs. It will connect to MobileMe & you can read from your account etc. But synching information it just will not.

Works just fine for me. What specifically isn't syncing for you?

W9cae
20th August 2009, 03:59 PM
Got it working logged out then re-enterd my details & it works.

gehenna
21st August 2009, 03:39 PM
The Logitech VX Nano laptop mouse is not compatible with Snow Leopard yet - the driver/app hasn't been released so none of the special buttons work.

tcn33
21st August 2009, 03:48 PM
The Logitech VX Nano laptop mouse is not compatible with Snow Leopard yet - the driver/app hasn't been released so none of the special buttons work.

But SteerMouse works just fine (and has the added bonus of not sucking).

gehenna
21st August 2009, 03:49 PM
Ooh that's good news

alPotatoe
21st August 2009, 04:24 PM
this sort of thing would be best served with a wiki.

Great idea!

I set up a wiki with all of the compatibility information from this thread.

Please visit it at:

Mac OS X 10.6 Snow Leopard Compatibility List (http://snowleopard.wikidot.com/)

Currawong
21st August 2009, 11:12 PM
Interesting to note, my iPhone wouldn't show in iTunes until I re-installed iTunes, upgrading from 10.5. I have nuked my ~/Library to start from scratch though, removing a crapload of plug-ins.

Adobe PDF: So far, doesn't work from the upgrade.

W9cae
22nd August 2009, 12:45 AM
I am finding MobileMe synch is still a bit wonky. I do wonder if this is the GM everyone says it is. But lucky for me I installed on a USB drive for testing. Just a format & gone.

alPotatoe
22nd August 2009, 05:09 PM
I'd love to get a list of known apps that don't currently work though.

Lutze,

A wiki has been established to keep track of the compatibility status of Mac applications with Snow Leopard:

Mac OS X 10.6 Snow Leopard Application Compatibility List (http://snowleopard.wikidot.com/)

Cheers!

tcimac
25th August 2009, 12:28 PM
After reading this (http://www.macfixit.com/article.php?story=20090813160052571)- I have noted that MactheRipper is a PowerPC type application. so I am guessing it wont work with Snow Leopard??

Huy
25th August 2009, 12:31 PM
You can use Rosetta.

The_Hawk
25th August 2009, 05:28 PM
Anyone happen to know if Adobe Photoshop CS2 will still work? One of the applciations I use but don't really want to update just to get a new OS...

Carve
25th August 2009, 06:59 PM
does anyone know if an iMac 2.4ghz will work with snow leopard? (in specs its listed as: iMac8,1)

thanks

leon
25th August 2009, 07:01 PM
does anyone know if an iMac 2.4ghz will work with snow leopard? (in specs its listed as: iMac8,1)

thanks

Yes it will.

W9cae
26th August 2009, 10:34 PM
I have tried iiUsage and the iinetusage widget in Snow Leopard and they work like in Tiger & Leopard.

gikku
26th August 2009, 10:38 PM
#Cyberduck 3.3b1 (Build 5154) now compatible with Mac OS X 10.6 Snow Leopard - Download: http://bit.ly/lahAG

W9cae
27th August 2009, 12:12 PM
Just tested out all the Nikon software. Nikon Transfer, ViewNX & Capture NX2 all the latest versions are working.

Lutze
27th August 2009, 12:29 PM
Anyone happen to know if Adobe Photoshop CS2 will still work? One of the applciations I use but don't really want to update just to get a new OS...

As per the headlines on a few Mac related sites - CS3 is not supported in Snow Leopard - so I doubt that CS2 will be.

gehenna
27th August 2009, 02:07 PM
Another Wiki is online here (http://wiki.macworld.com/index.php/Snow_Leopard_Compatibility) from Macworld

mechcon
27th August 2009, 02:12 PM
current version of RapidWeaver works, but any projects you've worked on don't work.

leon
27th August 2009, 02:23 PM
Is there someone who is running SL who can confirm whether or not CS3 works correctly?

All I have read are people who are making assumptions that it won't function correctly. I would like to know for sure.

Thanks,
Leon.

W9cae
27th August 2009, 02:34 PM
Some place I read Aperture was not working. I have just installed & its working for me.

Cameras app preference pane is also working.

tcn33
27th August 2009, 02:51 PM
Is there someone who is running SL who can confirm whether or not CS3 works correctly?

Dreamweaver and Photoshop CS3 seem to run just fine, although I haven't tested them extensively.

Dust For Eyes
27th August 2009, 11:03 PM
Quicksilver? Anyone heard if that'll work?

Back2Bedlam
27th August 2009, 11:06 PM
Try this link (http://snowleopard.wikidot.com/)

gikku
27th August 2009, 11:16 PM
Quicksilver? Anyone heard if that'll work?

quicksilver - working. Though this new spotlight is so damn fast.

basseyy
28th August 2009, 10:23 AM
I havent bought Snow Leopard yet, but will soon.

In the mean time, this link I found might be useful to people in working out what programs they have are compatible with 10.5.6.

acknowledgment to macnn

Snow Leopard Compatibility: Mac OS X 10.6 Snow Leopard Compatibility List (http://snowleopard.wikidot.com/)

NORMANDY
28th August 2009, 10:54 AM
there are a fair few things that dont work under snow leopard, see the below link Snow Leopard Compatibility: Mac OS X 10.6 Snow Leopard Compatibility List (http://snowleopard.wikidot.com/)

If something is critical to your day to day ops, and it wont work under snow, then do not upgrade, it wont hurt you by not having the latest and greatest.

If you are unsure, then dont upgrade! Of course you should backup everything to a bootable backup drive (NOT TIME MACHINE) with super duper or something else first, then upgrade, see if all you stuff works.. if you find something doesn't that you cant live without.. then clone your drive back from your backup.. and wait till there are updates to will make it work with snow leopard.

I know my install wont be simple, as I must have all the export features of flip for mac working, so I will have to install Quicktime 7 pro after the install... as quicktime x makes all the export features crap.... and I will also have to remove menu meters.. as they dont work.. and neither does growl... and I have to make sure I install Rosetta as well, as a few apps I use are ONLY PPC.... and Rosetta is not part of the install.. and connect 360 may or may not work after asking the developers, who do not know either... that I cant live without... so if it doesnt work.. back to Leopard till they fix it..... HOW DO I know this when I have not even got Snow Leopard yet? Researching... I suggested EVERYONE else do the same.

So make sure you know what will or wont work, do your research before you install... and if you are still unsure.. wait.. and ask on forums... before committing to an install that could waste you hours of time.. and possibly lead to Frustrating posts on the internet, as you were too eager to install and do no research before hand....be informed not alarmed

bartron
28th August 2009, 10:57 AM
ooh...cyberduck no worky

Back2Bedlam
28th August 2009, 11:01 AM
Go to system profiler, and click on applications, and see what app's you have that are PPC? Check if there useful, if not all's good.

One I have found is MacTheRipper, but then it's been superceded by better app's anyways.

Mullarkey
28th August 2009, 11:05 AM
Remember to delete any large files you don't need backed up also from your system.....

or wait for those movie files backup...

NORMANDY
28th August 2009, 11:09 AM
Go to system profiler, and click on applications, and see what app's you have that are PPC? Check if there useful, if not all's good.

One I have found is MacTheRipper, but then it's been superceded by better app's anyways.

its not like Mac the ripper needs speed to operate.. so no biggie running that as a PPC app

Back2Bedlam
28th August 2009, 11:17 AM
its not like Mac the ripper needs speed to operate.. so no biggie running that as a PPC app

You're right, but it would need to include Rosetta into the install, and i'd rather not bother. I use HandBrake and Visual Hub so no real need for an App that's no longer updated.

NORMANDY
28th August 2009, 11:19 AM
its only a 1.8MB download for Rosetta.... plus I have mame emulation that is PPC only.... :) so its needed for me...

Mutters
28th August 2009, 11:32 AM
Yes Normandy, I quite agree.

I've noticed Vuze (Azureus) is not working properly - they're working on it.

Crossover is command line only atm - they're working on it.

EyeTV needs an update for "Sharing" to work - done that.

PS CS3 has minor bugs - my main app.

The list goes on!

So yeah, it looks like I might wait a week or two before installing it on my main machine.

Will put it on my second machine first(?) - 2GHz MB and see how it pans out.

mutters

gikku
28th August 2009, 11:45 AM
ooh...cyberduck no worky

update to v3.3b1 nightly build
http://update.cyberduck.ch/nightly/Cyberduck-5167.tar.gz

Cyberduck | FTP, SFTP, WebDAV, Cloud Files & Amazon S3 Browser for Mac OS X | (http://cyberduck.ch)

The_Hawk
28th August 2009, 12:07 PM
Photoshop CS2 asked to install Rosetta before it would run (even though I didn't need this in the past). I started it up after it went through that process and it seems to be working, although to be fair I haven't done any work in it yet.

Dux
28th August 2009, 12:23 PM
PS CS3 has minor bugs - my main app.

Urgh, what kind of bugs?

I only just bought a second-hand copy of CS3 :(

HumanMedia
28th August 2009, 01:00 PM
"Vuze", "Things" and "Max" updates are now available for SL compatibility.

Zurg
28th August 2009, 01:10 PM
Growl works fine, sure it isn't 64 bit and asks you to restart the system preferences into 32bit mode, but it definitely does work.

Mutters
28th August 2009, 01:25 PM
Urgh, what kind of bugs?

I only just bought a second-hand copy of CS3 :(

I believe they're menu related, like wacky type and off-colour menus.

Don't quote me though, I have a head full of mis-information from all the reading about Snow Leopard.

They do exist though - basically it's a suck it and see situation!

My copy of PS CS3 is factory-full of bugs anyhow!!!:eek:

mutters

Mutters
28th August 2009, 01:26 PM
"Vuze", "Things" and "Max" updates are now available for SL compatibility.

Wow - Vuze already!?

Edit: Pulled this quote from one of the devs

"The downloading/networking bug will be fixed for 4208 release via the BSD-select work around, and we're trying to fix as many UI glitches as possible, but full Snow Leopard support won't come until 4210 release:"

Is this out now?

mutters

HumanMedia
28th August 2009, 01:32 PM
Wow - Vuze already!?

Edit: Pulled this quote from one of the devs

"The downloading/networking bug will be fixed for 4208 release via the BSD-select work around, and we're trying to fix as many UI glitches as possible, but full Snow Leopard support won't come until 4210 release:"

Is this out now?

mutters

Only 4208
Vuze 4.2.0.8 software download - Mac OS X - VersionTracker (http://www.versiontracker.com/dyn/moreinfo/macosx/22820)

Mutters
28th August 2009, 01:36 PM
Only 4208
Vuze 4.2.0.8 software download - Mac OS X - VersionTracker (http://www.versiontracker.com/dyn/moreinfo/macosx/22820)

Ah yes - worth a go though.

mutters

tcn33
28th August 2009, 01:42 PM
Growl works fine, sure it isn't 64 bit and asks you to restart the system preferences into 32bit mode, but it definitely does work.

Except for GrowlMail.

spuds_imac
28th August 2009, 01:48 PM
Except for GrowlMail.

Works fine for me.

The_Hawk
28th August 2009, 02:12 PM
Confirmed: $29 Snow Leopard Installs Whether or Not You've Got Leopard - Saving Money - Lifehacker (http://lifehacker.com/5347086/confirmed-29-snow-leopard-installs-whether-or-not-youve-got-leopard?skyline=true&s=x)

An interesting read. While it seems you can upgrade from a non compliant version, you wouldn't be legally licensed. Nice to know though.

Back2Bedlam
28th August 2009, 02:17 PM
If you'd had a quick sticky beak, you'd have seen that info has been posted a number of times.

I feel for the mod's around this time, all the cleaning up of posts, must be annoying!

tcn33
28th August 2009, 02:19 PM
Works fine for me.

I get a disable message every time I launch Mail.app, and Growl's site says it's not SL-compatible.

Growl - Frequently Asked Questions (http://growl.info/documentation/faq.php#snow-leopard)

tcn33
28th August 2009, 02:24 PM
Cleaning up? Fuck that. In a week once things settle we're just going to merge every single SL thread into one mega-thread from hell and back away slowly.

kidding.

(probably)

The_Hawk
28th August 2009, 02:33 PM
Applogies for the post, I did a search but somehow managed to miss that. I have been reading most of the posts too :shocked:

Boofhead
28th August 2009, 02:49 PM
If any of you use Peer Guardian i noticed theres a specific SL beta PeerGuardian 1.6 - Phoenix Labs (http://forums.phoenixlabs.org/showthread.php?t=18902)

andytlr
28th August 2009, 02:57 PM
Quicksilver? Anyone heard if that'll work?

A couple of others have said Quicksilver is working but it isn't for me. I downloaded the latest version just to make sure and it just does that QS over the desktop then nothing happens.

Also, I have NO idea why. But I just got a website working perfectly in Safari, firefox and IE. Now when I load it on the computer with Snow Leopard it looks all off. The strange thing is when I load the version stored on my computer it looks fine, load the version that is on the server and it looks wrong. This happens in both Firefox and Safari which is the strangest thing.

Could anyone go to Snow Media The specialist in Australian ski resort advertising (http://www.tlr.name/snowmedia) and let me know if it looks bung for you as well?

I think I'm going to do a clean install tonight and see if that helps.

Zem
28th August 2009, 03:59 PM
Any suggestions for notification plug-ins for Apple Mail? I was using Mail.appetizer but it appears not to be compatible with Snow Leopard. Just installed Growl and same problem.

jimdrum
28th August 2009, 04:32 PM
Anyone tried MYOB First Edge Version 1 under Snow Leopard? System profiler tells me it's a PPC app, not universal, so I have my doubts.
MYOB don't know. They didn't even know about Snow Leopard.
Sometimes I wish I didn't use Windows apps that have been ported for Mac.
Often, they're poorly supported.
If anyone can help, I would be very glad!

banjo
28th August 2009, 04:56 PM
Not a program as such, however I just discovered that Applescripts saved as droplets in Leopard are not compatible with SL without Rosetta. Am about to try resaving from script editor and see if it works then ...

zigzagler
28th August 2009, 05:54 PM
my day to day app would be


mail
firefox
evernote
dreamweaver CS4
Photoshop CS4 / Photoshop Element 4.0
1password
VMWare 2
Office 2008


Should it be risky to upgrade now? I know for sure that it's best to make a bootable backup using Super Duper but I just don't want to spend another $277 just to get an ext HDD with FW800(Tho it's very much tempted) just to make a full backup before I upgrade...

Really tempted to install SL after getting it....

My current TimeMachine HDD(Ext) is full ....sigh....

Rjat
28th August 2009, 06:37 PM
Growl is working fine for me.

tcn33
28th August 2009, 06:41 PM
Growl isn't the issue. GrowlMail is.

Tassiecelt
28th August 2009, 06:50 PM
What about MYOB Accountedge? any info on whether that works? Waste of time asking MYOB.

Tragedies
28th August 2009, 06:55 PM
Logitech Control Center's mouse fuction seems to be having trouble with Expose, I can't assign any button to work on my logitech mosue with Expose. Nothing happens when I click the selected button. Gets really annoying as Expose is damn useful >_>

dickg
28th August 2009, 07:41 PM
Any probs with sending emails thru Mail?

Back2Bedlam
28th August 2009, 07:41 PM
Be careful with Eye TV, if you are doing a fresh install, and don't have the latest update, it won't run. There is no way around it, you have to install leopard, then sl, to get it to work.
I have contacted the company, and asked for a link to download the new software. I let you know how I go

Devil rolla
28th August 2009, 08:00 PM
stattoo works,
cheetahwatch doesnt.

lama323
28th August 2009, 08:15 PM
Hey Guys,
Had a look around and I thought it might be a good idea for everyone to post what they have found not be working as a result of installing Snow Leopard?
(save you trawling through other threads - as a quick reference)

I'll start it off;
1. iStat
2. Limewire (refuses to connect)
that's all I have found at the moment.

spuds_imac
28th August 2009, 08:16 PM
LOL thread all ready done.

Redman
28th August 2009, 08:17 PM
Snow Leopard Compatibility: Mac OS X 10.6 Snow Leopard Compatibility List (http://snowleopard.wikidot.com/)

Tom125
28th August 2009, 08:18 PM
None of my non-Apple screensavers are working. I hope they release a new version of FliqLo.

MrJesseRoss
28th August 2009, 08:22 PM
There's already a thread on this. Multiples will only confuse. Thankyou!

http://forums.mactalk.com.au/46/70782-snow-leopard-compatibility.html

lama323
28th August 2009, 08:25 PM
Limewire 4.18 is not working (refuses to connect to network)

Devil rolla
28th August 2009, 08:39 PM
ETV COMMSKIPPER DOESNT WORK !!

http://i5.photobucket.com/albums/y169/devilrolla12345/Screenshot2009-08-28at83315PM.png

and growlmail plugin

appletoast
28th August 2009, 08:43 PM
Limewire 4.18 is not working (refuses to connect to network)

GOOD!
:D

Devil rolla
28th August 2009, 08:48 PM
sweet mary and joseph, metaX started working again..

http://forums.mactalk.com.au/11/70437-metax-wont-load-crashes-everytime-included-crashlog.html

Mongrel
28th August 2009, 09:56 PM
What about MYOB Accountedge? any info on whether that works? Waste of time asking MYOB.

I am hearing you!!

I recently had discussions with MYOB re their Mac software. I asked them why their "Trial Downloads" form Mac are packaged in Stuffit. The guy on the phone replied... "That is the Compression software used on a Mac"

I then asked why it is Stuffed when the DMG is only 2mb larger than than the compressed file itself. He replied "I'm not sure - I am not that experienced with Macs" AND THIS WAS THE MAC SUPPORT GUY!!! :crazy1:

Anyways... I am thinking it will fall over.

Cheers
-J

NeoRicen
28th August 2009, 10:03 PM
Perian works, you can even trim clips with it.

Flip4Mac doesn't work, but there is a Beta that does work, although it's not perfect yet.

That's all I've tried so far.

vella
28th August 2009, 10:16 PM
hey there,

i use automator all the time and i use 2 main scripts every day and when i did the update to snow leopard it lost this finder plug in and now in automator there's no save as plug in option

here is the scrip i'm talking about

scrip here for resizing files (http://mymacbuzz.com/2006/10/15/right-click-image-resizing-with-automator)

yinyang
28th August 2009, 10:22 PM
That Classic Apple replacement thingy that makes the Apple logo in the top left old skool - not a good idea to enable that with Snowie :)

Puts the system into a horrible "all apps unexpectedly quit" loop and you're stuck.

Unless of course you boot from your backup, restore & then upgrade again....!

Candybar also doesn't seem to be able to work on icons like Safari, Mail or Sys Prefs, even after change permissions on the apps. Others seem to be okay, but it's not consistent.

Okay back to restore....!

Sticky Windows also doesn't work

NeoRicen
28th August 2009, 10:24 PM
hey there,

i use automator all the time and i use 2 main scripts every day and when i did the update to snow leopard it lost this finder plug in and now in automator there's no save as plug in option

here is the scrip i'm talking about

scrip here for resizing files (http://mymacbuzz.com/2006/10/15/right-click-image-resizing-with-automator)
Try making it again as a Service. Services appear to have taken the place of Finder plugins. They work the same though, but can be used in other apps too if you want to enable it.

vella
28th August 2009, 10:40 PM
Try making it again as a Service. Services appear to have taken the place of Finder plugins. They work the same though, but can be used in other apps too if you want to enable it.

Thanks so much for that now i can cut files now

for some reason when i do a normal cut it wont paste the items it just goes straight to the trash bin, hence this script to cut the file and not to trash bin

guitarman
29th August 2009, 01:06 AM
Like the title says....my Presonus Firestudio 2626 works with the SL I have just installed on my external FW drive. Just tried it with Logic Studio 8 (which also seems to be behaving so far) and everything is normal.
Presonus have stated several times on their forums that NONE of their audio interfaces will work with SL, and that we'll have to wait for compatible drivers to be tested. Well mine works..... :D:D:D

andytlr
29th August 2009, 08:12 AM
I said earlier that I couldn't get Quiksilver to work. I've done a clean install (after an upgrade and a full migration) and it now works.

dreemtrax
29th August 2009, 08:30 AM
I have just run my VMWare Fusion Windows program under Snow Leopard for the first time and it has come up with an unrecoverable error:

(vcpu-0)
'NOT_IMPLEMENTED bora/devices/mainmem/mainMemHosted.c:1967'

All attempts have failed to connect me to Windows (Macbook Pro).
Is anybody else having this problem?
Is there a solution?

Given the laptop came preloaded with Leopard, how am I able to revert back to the old OS for the sake of getting all my files on the Windows OS I was utilising earlier. Even under Snow Leopard, is there a way I can access old Window files?

Huy
29th August 2009, 08:32 AM
What version of Fusion? Mine works fine under SL (Fusion 2.0.5 and XP SP3).

gumby08
29th August 2009, 08:33 AM
Has anyone got Handbrake working? It crashes on launch for me. I've deleted the app and reinstalled with no luck.

aafuss
29th August 2009, 08:36 AM
Anyone tried running Adobe Photoshop Elements on SL yet?

banjo
29th August 2009, 08:50 AM
Has anyone got Handbrake working? It crashes on launch for me. I've deleted the app and reinstalled with no luck.

I have it working with no issues.

xerodude
29th August 2009, 09:09 AM
Xmarks for Safari is a no go.

Leopard Cache Cleaner too

jimdrum
29th August 2009, 09:16 AM
I am hearing you!!

I recently had discussions with MYOB re their Mac software. I asked them why their "Trial Downloads" form Mac are packaged in Stuffit. The guy on the phone replied... "That is the Compression software used on a Mac"

I then asked why it is Stuffed when the DMG is only 2mb larger than than the compressed file itself. He replied "I'm not sure - I am not that experienced with Macs" AND THIS WAS THE MAC SUPPORT GUY!!! :crazy1:

Anyways... I am thinking it will fall over.

Cheers
-J
It's mind boggling, isn't it. I installed Snow Leopard and when I launched
MYOB First Edge, SL told me that I needed to install Rosetta from the extras on the disc to run First Edge. I did so, and so far all seems to be working OK.
I got very mixed information from two different phone support staff at MYOB. It makes me want to move everything over to something else.
The software does what I want it to do, but has some really annoying
aspects. I wonder who road tests this stuff before it is released??

dreemtrax
29th August 2009, 09:22 AM
Fusion 2 is the Beta version I presume? I looked at mine & it was installed in June 2008, so it's probably a very early version, but was working like a rocket. If I downloaded the new version, is it going to over-ride the one I have & give me access to my files in Windows? If not, any idea how to access the Windows files? I've looked everywhere I can think of.

HumanMedia
29th August 2009, 09:31 AM
Apples QMaster Control Panel for Pro apps is not 64 bit compliant and needs to be upgraded to the new version hat shipped with Final Cut Pro (and Logic?) a couple of weeks ago.

incanspyder
29th August 2009, 09:32 AM
UnrarX occasionally doesn't work - screen goes black even though I see a cursor. The wiki says it does work but I guess that's BS then. Or it must be UnrarX + FF 3.5.2 (DivX web player doesn't work on the new safari)

mvjs
29th August 2009, 09:46 AM
X-Lite VoIP/SIP client unfortunately does not work. No audio. Judging by how long it took for the Leopard update to come out, I'm not holding my breath.

mattDC5R
29th August 2009, 10:02 AM
Fusion 2 is the Beta version I presume? I looked at mine & it was installed in June 2008, so it's probably a very early version, but was working like a rocket. If I downloaded the new version, is it going to over-ride the one I have & give me access to my files in Windows? If not, any idea how to access the Windows files? I've looked everywhere I can think of.

Fusion 2 isnt a beta, its the full release now, and its up to 2.0.5.
Im using it to read my bootcamp partition and it works fine.

Arkhum_Eramak
29th August 2009, 10:41 AM
Not sure if this has been mentioned, but my Blackmagic Decklink HD Extreme III drivers won't install correctly with SL. Just tried it this morning and no dice.

Back2Bedlam
29th August 2009, 11:33 AM
Be careful with Eye TV, if you are doing a fresh install, and don't have the latest update, it won't run. There is no way around it, you have to install leopard, then sl, to get it to work.
I have contacted the company, and asked for a link to download the new software. I let you know how I go

OK Update on Eye TV, Elgato have updated there software, and if you (like me) have done a clean install, there is a linky to the SL Full Update version of Eye TV (http://support.elgato.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=3628)which you can download direct to your hardrive.

dotnet
29th August 2009, 04:09 PM
You wonder what Apple has the developer seed program for, if so many (even major) software vendors don't bother to have their fekkin' apps ready when a new OS version comes out...

Cheers
Steffen.

Curlyone
29th August 2009, 04:17 PM
Anyone tried running Adobe Photoshop Elements on SL yet?

Seems to work OK for me.

goatcatcher
29th August 2009, 04:19 PM
Anyone tried running Adobe Photoshop Elements on SL yet?

Started up fine for me when I tested it. Haven't tried any image manipulation yet.

gumby08
29th August 2009, 06:45 PM
Has anyone got Handbrake working? It crashes on launch for me. I've deleted the app and reinstalled with no luck.

I disabled Growl and now it's working.

The_Hawk
29th August 2009, 11:06 PM
Looks like I'm restore the wifes machine to Leopard...

Collectorz products do not work at all (although they are working on a fix/update) and Rapid Weaver doesn't have a working final build yet. Since she uses both of these all the time she's stuck... probably should have checked before... but oh well.

BoxDog
30th August 2009, 12:29 AM
Visualhub certainly does.

http://img190.imageshack.us/img190/4327/vhsl.jpg

Crazy. I had all sorts of stack overflows and madness when I tried it. :(

angusg
30th August 2009, 01:50 AM
Growl isn't the issue. GrowlMail is.

I'm glad someone else has pointed it out. Waiting for an update. Otherwise switched to Glimmer Blocker for Safari ad blocking and haven't had any other problems.

bullrout
30th August 2009, 07:58 AM
Finderpop (http://www.finderpop.com/) has been causing me lots of problems.

Could not quit applications from menubar and other menubar problems, originally thought it was something iStat menus had done.

Preventing CCC and Superduper from selecting drives.

Could not edit recordings in EyeTV.

iJohn
30th August 2009, 09:35 AM
anyone have issues connecting to FW?

angusg
30th August 2009, 11:36 AM
Another one... Western Digital Turbo drivers won't install.

lama323
30th August 2009, 02:21 PM
GOOD!
:D

nah this is not good

Mutters
30th August 2009, 04:12 PM
Even though Elgato says anything above EyeTV 3.1.* is compatible with 10.6, they admit there are problems with Sharing.

So they put out a Beta ( 3.1.3b ) to address this.

Unfortunately for me, it doesn't address anything.

There could be many reasons for this, as I have only installed 10.6 on one computer, as a test machine, so to speak - a 2Ghz MB C2D, 950m graphics, which btw is fine with the new OS.

The main machine is a MBP still running 10.5.8, but with the EyeTV 3.1.3 beta also.

So far sharing is all fucked up with the 10.6 machine saying there is a library to share, but it's empty. In fact, it's not.

At the other end the MBP can't even find the huge shared MB library.

But there you go, I can't argue with a machine.

It's hardly Sunday in Europe, so I've still got some waiting to do, but thought I'd let you know of my experiences so far.

Maybe someone else is co-experiencing this or has come up with an early fix?

That would be nice.

Thanks

mutters

aafuss
30th August 2009, 06:06 PM
Does the Finereader OCR software that comes with some Epson all-in-one printers work on Snow Leopard?

mestevie
30th August 2009, 08:52 PM
HP Printer Problems?

See this support page

Mac OS: Setting Up and Using the Product in Mac OS X 10.6 HP Officejet J6480 All-in-One Printer - HP Customer Care (United States - English) (http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01846935&lc=en&dlc=en&cc=us&product=3635378&os=219&lang=en)

NOTE: HP Scan Pro software (from Mac OS X 10.4, 10.5) is not supported in Snow Leopard. The HP icon for HP Device Manager still in the dock after upgrade is not functional and should be removed.

NOTE: Scan support from pushing the Scan button on the printer is not supported with this version of the scan interface built into Snow Leopard. Scan functionality is supported by scanning directly from the computer.

Steve

tcn33
30th August 2009, 09:05 PM
Yeah, Scan Pro is not working with my PSC 2410 either and SL doesn't support scanning with it. I'm using VueScan (http://www.hamrick.com/) in the meantime.

fotografer
30th August 2009, 09:21 PM
My findings :-

a) NTFS-3G does not work in 64-bit kernel mode
b) Cisco VPN does not work in 64-bit kernel mode (although somewhat alleviated by the fact that Cisco IPSEC VPN is now built-in but also hampered that the built-in support does not offer all the functionality that the VPN client has).

Errr ... just for information cos I am now rebooting back to 32-bit kernel mode.

Dust For Eyes
30th August 2009, 11:22 PM
Even though Elgato says anything above EyeTV 3.1.* is compatible with 10.6, they admit there are problems with Sharing.

So they put out a Beta ( 3.1.3b ) to address this.

Unfortunately for me, it doesn't address anything.


Same problem right here and the 3.1.3b didn't help either.

aafuss
31st August 2009, 08:49 AM
Does any of the software provided with Epson Stylus AIO printers work fine in SL?

I have a Stylus TX100 by the way.

TBPlayer
31st August 2009, 09:07 AM
anyone have issues connecting to FW?

When I installed Snow Leopard everything appeared to be fine until I tried my External DVD burner which is Combo FW and USB 2.0. Nothing would mount via FW so I tried USB via a hub. Nothing. Tried via USB directly into the Mac and it worked. Yet I have another FW device, Lacie Ext HDD and that seemed to work fine. Also, the HP printer did not respond except when you used the HP Device manager to check the setup or print a test page. It would not work with any programs. Eventually I restored the system back to OSX 10.5.8 and everything went back to working as expected. Maybe I'll reinstall OS X 10.6 Snow Leopard when they have had a couple of updates to correct all these issues :slant:
Cheers
TB

grfxninja
31st August 2009, 09:11 AM
anyone have issues connecting to FW?

No problems connecting to a Lacie Rugged portable HDD via FW800
Haven't tried it via FW400 though

bubble
31st August 2009, 10:46 AM
iStat menus crashed my UIServer in a never ending loop until I deleted it. All my other menu item software seems to work fine.

Back2Bedlam
31st August 2009, 09:39 PM
Flip 4 Mac (http://dynamic.telestream.net/downloads/download-flip4macwmv-beta.asp) have released a SL Beta for there software, been running for an hour or so, they have made all of it 64 bit, including the prefpane.

opilot87
31st August 2009, 10:17 PM
Also got an update for ad-blocker in safari today, with the new version having SL compatibility.

Ollie

angusg
31st August 2009, 10:19 PM
Also got an update for ad-blocker in safari today, with the new version having SL compatibility.

Ollie
I ended up grabbing Glimmer Blocker instead.. I just want an update for GrowlMail and I'll be sweet..

asylum119
31st August 2009, 11:09 PM
Can any one confirm "WBFS for macOS x v1" working on SL ?
I have not finished backing up my wii games just yet


Any other confirmed working or non working apps would be appreciated.

aafuss
1st September 2009, 03:08 PM
Roxio's Toast 8 works well in Snow Leopard-despite not being the latest version.

aafuss
1st September 2009, 08:24 PM
Canon CameraWindow will run, but then gives a "failed to initialise program" error.

aafuss
1st September 2009, 08:59 PM
Has anyone been able to use the Canon CameraWindow software on Snow Leopard?

chrisjg
2nd September 2009, 05:28 PM
I've just bought Final Cut Studio 2 and I'm about to upgrade to snow leopard. I was just wondering if anyone has had any issues with editing on the new osx?

For that matter I assume all other software works as well on Snow Leopard as it did on previous OSX?

aafuss
2nd September 2009, 06:13 PM
Canon's CameraWindow that is included with ImageBrowser-v 6.31a does not function properly.

They have not stated when a SL compatible version will be ready.

ImageBrowser, meanwhiles works OK.

pengu
2nd September 2009, 07:20 PM
Is there a reason people use the Camera maker's software rather than Image Capture/iPhoto/Aperture/Lightroom/etc to import photos? I've always found Camera/Printer/Scanner manufacturer's software to be generally shite.

aafuss
2nd September 2009, 08:25 PM
I use my Canon software because I like to trim and create email ready photos from ImageBrowser-by the way that works fine in SL, but not Camerawindow.

NORMANDY
2nd September 2009, 09:03 PM
Its just got updated to work with snow :) yea!

AnthoMac
2nd September 2009, 10:30 PM
Anyone who uses Windows Live Sync to sync data between two or more computers will be disappointed to learn that this is not compatible with SL. The software installs but refuses to log in despite being connected. I hope MS fixes this although it seems they have abandoned the software for their 'live mesh' app instead.

Also, Synergy (mouse/keyboard sharing) works but does not show the icon in the system menu bar.

aafuss
3rd September 2009, 08:45 AM
You Software's You Control works well in Snow Leopard-haven't noticed any serious issues with it.

Mutters
3rd September 2009, 11:31 AM
Roxio's Toast 8 works well in Snow Leopard-despite not being the latest version.

Toast 7 seems to work okay as well - amazing!

mutters

aafuss
5th September 2009, 01:17 PM
My Canon CanoScan 5000F scanner's drivers and CanoScan toolbox both seem to be working OK in SL (had to use the 8.0x drivers from the Canon website and not the ones that were supplied on a CD).

tcn33
5th September 2009, 02:53 PM
My new Canon MX330 multifunction printer works straight out of the box, no need to download or install drivers or software. Scanning in Image Capture is implemented nicely.

mantaray
5th September 2009, 03:18 PM
Even though Elgato says anything above EyeTV 3.1.* is compatible with 10.6, they admit there are problems with Sharing.

So they put out a Beta ( 3.1.3b ) to address this.

Unfortunately for me, it doesn't address anything. yeah, Have tried everything, but sharing will not work between my Mac Mini and iMac both running SL and the latest Beta Eye TV. Tried reinstalling it on both machines , rebooting one first then the other but it seems it will need an update to get it going- just hope they don't bring out Version 4 and makes us pay for the upgrade- nah- they wouldn't do that .....:slant:

Boofhead
5th September 2009, 05:57 PM
Nullriver Software : Products : MediaLink (http://www.nullriver.com/products/medialink) has released an alpha version for SL.

aafuss
5th September 2009, 09:20 PM
CoverScout 2 works nicely in 10.6.

tcn33
15th September 2009, 10:21 PM
Aaron Harnly has released a beta of Letterbox that works on 64-bit Mail.app. No problems here, but if you use MailTags I'd hold off.

aaron.harnly.net Blog Archive Letterbox beta 4 for Snow Leopard (http://harnly.net/2009/software/letterbox/letterbox-beta-4-for-snow-leopard/#more-227)

uncyherb
17th September 2009, 11:06 AM
Aaron Harnly has released a beta of Letterbox that works on 64-bit Mail.app. No problems here, but if you use MailTags I'd hold off.

aaron.harnly.net Blog Archive Letterbox beta 4 for Snow Leopard (http://harnly.net/2009/software/letterbox/letterbox-beta-4-for-snow-leopard/#more-227)

Sweet. Now if only the mail.appetizer plug in was re-written I could get back to being as productive as I used to be. (Even growl would at least get me by)

aafuss
23rd September 2009, 12:37 PM
Bought a Tungsten E2 PDA-and was relieved to find that Palm Desktop seems to work fine in OS X 10.6.