PDA

View Full Version : memory allocation problem



lunchbill
27th June 2004, 12:14 PM
I have been trying to change the allocation of memory to Appletalk on my G3, but there is no "memory" option in the Show menu of the Appletalk Info window. No additional options appear when I click the General Information button.

Does anyone have any clues what is wrong here and how to fix it?

thanks :)

Byrd
27th June 2004, 12:23 PM
Hi lunchbill, welcome to the forums :)

You can only assign memory to applications, not control panels (or extensions). While control panels are 'applications' as such, memory allocation isn't nescessary. Can I ask why you're wanting to do this to Appletalk (is it coming up with an out of memory error or something).

JB

lunchbill
27th June 2004, 12:31 PM
Thanks for the welcome and the info.

I bought a Lexmark X1150 printer and it wont run on my system. Their tech line said that Appletalk has too much memory allocated. (???) Apple's help line is down for the weekend.

Byrd
27th June 2004, 12:53 PM
That's weird. Delete the Appletalk preferences file (and turn off Appletalk), and see if Lexmark have updated drivers for the printer from their web site.

Or, if still rooted, reinstall OS 9.2.2 to a clean system folder (retaining your old one - it can be reselected under the Startup control panel). If the printer decides to work when the System is 'clean', you can then drag your favourite control panels/extensions/fonts to the new System folder, and try to ascertain if there is any software that is incompatible with your Lexmark printer drivers from there.

JB

lunchbill
27th June 2004, 01:17 PM
Yow. Thanks for the info.

Easier to just return the printer to the store and replace with a more reliable model, don't ya think?

Currawong
27th June 2004, 03:46 PM
I'm not sure how anyone could come to the conclusion that the memory allocation for Appletalk has anything to do with printing...

Anyway, file sharing if anything would end up using the disk cache (set in the memory control panel). That's only really relevant if your machine is sharing files over a fast network and you want to set a larger cache for better performance. Essentially the same trick is now used in OSX whereby memory is reserved as "inactive" in large quantities when you copy files over a network.

The Appletalk control panel isn't actually the Appletalk part of the system, it only tells the Appletalk extension to change settings. It's probably possible to hack the settings in the extension to change the amount of memory it gets allocated but I wouldn't attempt this.

Anyway, it sounds like the Lexmark drivers or something conflicting is at fault, as Byrd has suggested.

lunchbill
27th June 2004, 04:06 PM
Thanks! Yeah, looks like this baby is going back to the store.