PDA

View Full Version : Airport Express & Printing Through Appletalk



BigAD
1st July 2005, 11:13 AM
Here's the deal

I can connect my iMac to my work network via a network cable, and i can see the printers through appletalk fine.

But I use aiport express to get access to the network in my office, and for some reason, it doesn't want to see the printers through appletalk anymore.

Before anyone asks, I have had it working a week ago, I can only see the printer through appletalk because IP printing won't work, and Appletalk is only enabled in Airport settings under systems preferences.

If anyone can help me, you will make my day.

also, I think someone might have played around with the airport express settings

BigAD
4th July 2005, 02:05 PM
bumpty bump

If anyone can help me I would appreciate it

Devski
4th July 2005, 03:27 PM
Ensure the following:

1. AppleTalk is only enabled on 1 interface
2. Prioritise the interfaces so that the Airport is at the top of the list (System Preferences-->Network-->Show-->Network Port Configurations)

Is there any reason you cannot connect to the printers using TCP/IP instead?

BigAD
5th July 2005, 10:14 AM
I've tried everything, doesn't want to work

I'm gonna have to get someone to have a look at it

Thanks anyway

Mac Aid
6th July 2005, 07:56 AM
Most Likely, you have your airport set to distribute IP addresses, and therefore it's acting as a router, and so you are on a different subnet when on the Airport Express. Since Appletalk doesn't route, it won't work (nor will filesharing, normally)

go into the Airport Configuration Utility, and untick ditribute IP addressed, and you should be right

BigAD
6th July 2005, 09:38 AM
Thanks mate.

That solved part of the problem.

I have a inkjet and a colour laser connected through AppleTalk but for some unkown reason, only the inkjet can be seen.

But thanks heaps for the info

Devski
6th July 2005, 09:39 AM
Another thing you might consider is the Switch that the printer is connected to.

If it's a newer switch or has been changed recently it might be the cause of your problem. If it's a good switch with a web interface and you can get access to it, you can try switching off 'spanning tree' as this setting will kill AppleTalk.

Mac Aid
8th July 2005, 08:45 AM
I presume the colour laser is connected to the airpot via ethernet, rather than USB?

If so, make sure you restart the printer it if it's using DHCP (to reset the IP address that may have been changed with the change in airport config), or check it's in the correct range if it's manually configured. At risk of stating the obvious, make sure it has appletalk available, and switched on.

If you print a status page from the printer, the first three sections of the IP address should match those on your mac. ie, 192.168.0.x for example, or 10.0.1.x.

You may also find now you have made that change on the airport, printing over IP will work again.

BigAD
8th July 2005, 03:42 PM
Got it working after a week of hell!

Thanks heaps guys for the help

BTW, I finally got it working via IP printing, LPD/LPR setting rather than internet printing protocol.
Which is very strange because a couple of months ago when I set it up, the canon people could only get it working through Appletalk, and now I can't. But hey, it's working.

Thanks again
A.D