PDA

View Full Version : SOS! Mail can't see older messages



Paul_G
2nd July 2009, 01:17 PM
Hi folks. My wife just changed ISPs. She had three email addresses through her own domain.

Now she can send and receive emails from all three, but in two of the three mail accounts all the emails that were in her account are 'gone'.

Not actually gone though - when I go to Users/xyz/library/mail the accounts are still there, and I can work down through the various inboxes etc and see the messages - when I doubleclick to open them they open in Mail.

It's not that they're in the wrong spot or anything - I can see that new emails are also going into those very same folders. It's just that Mail isn't 'seeing' any messages that were there before today.

I'm guessing there must be some file that indexes the messages in the folder so that Mail knows they need to be displayed. Could anyone tell me what it is, and how I'd force it to rebuild itself?

BTW, I've tried restarting already.

Weird that one account went fine, all messages still showing, and the others have the problem.

Paul_G
2nd July 2009, 08:30 PM
Anyone? I know it's an early bump, but we're kind of desperate here.:(

Aladdin
2nd July 2009, 10:55 PM
Was changing the ISP the only thing that occurred between having and losing the messages? Which ISP (not that it should matter)? IMAP or POP3 Mail?

Tried Time Machine - either to see the time all the messages 'disappeared', or to retrieve them?

BTW, have you tried rebuilding the mailboxes? Prob worth a try first. Select relevant mailbox then Mail > Mailbox > Rebuild.

Paul_G
3rd July 2009, 12:42 PM
BTW, have you tried rebuilding the mailboxes? Prob worth a try first. Select relevant mailbox then Mail > Mailbox > Rebuild.

Bingo! Worked like a charm. Just what the doctor ordered.

Thanks - you're a lifesaver!

Aladdin
3rd July 2009, 10:54 PM
You're welcome. Glad I was able to help.