PDA

View Full Version : AirPort/Internet problems



johns91
7th May 2009, 12:33 PM
Gday all,

i recently purchased the white 13" macbook a few weeks ago, been using it at home, connecting wirelessly to our internet router. first time i turned the laptop on the airport popped up, i entered the password and its worked fine ever since, not needing to ever enter anything again, just turn on the macbook, click on safari and the internet is up n running.

this week however, i took it to uni, had to fiddle around with some settings to get it to connect to the wireless network there and eventually i cud access the internet at uni. when i got home, turned it on, clicked back onto my home wireless and it just wont let me connect.

i've run the diagnosis thing a hundred times, done the "assist me" thing, but just won't connect. it says that airport is on, and occasionally it will turn green in the network preferences window, but no matter what i do the internet just wont bring up any pages. it says "no IP address". so basically the airport is saying it's on, its finding the home wireless, i enter the password (which i thought you only had to do once for setup, then you're supposed to be able to simply select a previously accessed network and away you go?), the window pops up and says its connected, everything is as expected. only thing that isn't is that "no IP address", and the fact that safari returns "page cannot be found, run diagnosis". if i have to complete the diagnosis sequence one more time i will throw my computer out the window...

my bro and sis both have their macbooks connected wirelessly and it works fine, and so was mine, up until the day i went to uni and added another network.

any suggestions would be greatly appreciated

craigc
7th May 2009, 02:08 PM
Have you checked your DNS settings on the MacBook? Perhaps these were changed at the Uni.

Make sure the DNS settings are identical to your brother and sister's MacBooks.

Lutze
7th May 2009, 02:31 PM
Sorry Craig,

DNS settings will not prevent the Macbook connecting to the Airport base station.

This is going to be something that has been done to the configuration on the wifi for the Macbook.

A couple of things will help figure out what that could be.

1. Where in the world are you?

2. What Uni is it that you are going to? Someone here may know their settings and we can probably sort them from that.

ajbeardy
7th May 2009, 02:38 PM
Have you got a "proxy" setting" in the network settings that was used at the last location.

This maybe preventing the connection...

Aladdin
7th May 2009, 02:50 PM
Did you create a new 'location' in network preferences?

This would be easiest solution. Configure the settings separately for each location, then just switch locations as appropriate.

Don't fiddle with your uni settings if they work OK. Create a new 'home' location and configure your settings for your home wifi network again.

craigc
7th May 2009, 03:01 PM
Sorry Craig,

DNS settings will not prevent the Macbook connecting to the Airport base station.



That is correct, but are we certain that he isn't connecting to the Airport base station, as per his comment below:

"occasionally it will turn green in the network preferences window, but no matter what i do the internet just wont bring up any pages"

If he is connecting, but the issue is only accessing web pages, than I thought it may be worth at least checking his DNS settings.

johns91
7th May 2009, 07:43 PM
thanks for all your advice, its great to see people willing to help us noobs.
when i got home i clicked around randomly inside network preferences and now the net is working perfectly. won't complain, but i do hope this means that from now on i can simply select 'home' or 'uni' under airport and it will simply switch without the tedious passwords and setup and creating locations (there is now about 15 locations of random times throughout the night when i was prompted to create yet another failed location).

its set to automatic atm, which im happy about, in the hope now it'l take care of itself whether at home/uni.
so thanks again for all your help, all of you.
cheers