PDA

View Full Version : Please help - iLeopard messed up ui elements.



jack112006
25th April 2009, 10:45 PM
Thanks to my never-ending desire to customize the ui of OS X, I have seriosly borked the ui elements in Leopard. This has resulted in me being able to run no applications at all. I can't even run the uninstaller of iLeopard to remove it. All that I can run is a Finder window which itself is pretty badly
borked. If anyone knows some way I can fix this without having to reinstall OS X, I would be extremly grateful. I have backups of all my important stuff, so worse come to worse, I can reinstall OS X if I have too. Right now I am posting from my iPhone. Thank you and please help Jack.

Trabb
26th April 2009, 06:32 AM
To be honest, if you've been messing with the UI stuff... and now can't do anything, or even open those programs you've been using to mess with the UI stuff... I don't think you're gonna be able to undo the damage pretty easily... apart from an archive and install. You don't need to do a full reinstall... just pop in your install disc, and make sure it says 'archive and install' before you hit go. This will keep all your data and setting intact, but will clean out the operating system. Still takes just as long but yeah, should clean it up. If that doesn't work, then a complete reinstall.

You also get a nice lesson here: Don't mess with system files, even if you are using a program to do it.

Oh, and still do make sure everything is backed up still... I've never seen an archive and install fail to keep all the data, but you never know!

jack112006
26th April 2009, 07:02 AM
Thanks for the help. That's what I've decide to do, an archive & install. At least I have learnt a valuable lesson from all this.

jack112006
26th April 2009, 11:14 AM
The Archive & Install went perfectly. The only thing that didn't work was iLife '09 and i'm fixing that now. Even CS4 was still activated. The only annoying thing is that there was a ton of updates to install.