PDA

View Full Version : Logic editing gone a bit mental - help please!



RustySpanner
17th February 2009, 11:59 PM
Hi all,
Logic (8 pro) likes doing weird things to me sometimes, and at the moment it's thrown me one out of left field - if I delete a region in a track (MIDI), the region before it will fill out to the end of the song, as loops. It's never done this to me before, and I can't see any practical reason as to why it might. I have to go and remove a few minutes worth of loops each time I delete something. I don't recall having changed any settings to this effect, but perhaps with Logics single key shortcuts, I've enabled some esoteric 'please annoy the living shit out of me' mode by mistake?

Why you got to be all up in my kool-aid, Logic?

Anyone have ideas?

Darwiniandude
27th February 2009, 01:09 PM
Hope you've worked it out by now... if not, I believe this is the solution:

Ensure the inspector is visible (i) in the toolbar.
You'll have two settings areas with disclosure triangles: the bottom one will say Audo 1 or Midi 1 unless you've renamed it, but the top one is what we want, ensure it's visible. There is a tickbox in there called 'Loop' which causes all regions on that track to loop till the end of song marker unless another loop is placed in the way.

Hopefully this solves it?

RustySpanner
4th March 2009, 11:13 PM
Hey,
Thanks for the reply. The problem seems to have fixed itself, but I'll save your reply so I know where to look next time it happens.

Ta
Liam

marc
5th March 2009, 01:20 AM
Select the region.
Press "l" (lowercase L).

That'll toggle loop on and off. It's very handy.

Another Logic tip: "s" solos the selected regions. Option-s solos the selected regions and locks them as soloed so you can keep editing.