PDA

View Full Version : Cannot make/receive calls - "Call Failed"



chrsha01
22nd December 2008, 08:22 PM
Hi guys,

Just recently, I have discovered that my iPhone 3G cannot make or receive any calls.

When I call someone the signal will drop and I get a 'call failed' message. This also happens when I receive a call.

I've tried the usual things like doing a reset and complete restore to factory settings, but nothing seems to be helping.

Despite this, I can amazingly send/receive text messages, use Mail, Safari and every other feature without fault.

I'm running firmware 2.2 and using Optus. :rolleyes:

Any suggestions would be great.

Thanks,

Chris. :)

mvjs
22nd December 2008, 08:25 PM
This is almost certainly something on the carrier's end. It would definitely be worth calling them and explaining the problem.

Exocet
22nd December 2008, 08:50 PM
Does your SIM in another handset do the same thing? Have you paid your bills recently? Has there been recent storm activity in your neighborhood and have you recently made a rate-plan or other service-affecting change to your phone plan?

Beau
22nd December 2008, 08:59 PM
Have you thought about switching carriers? :D

chrsha01
22nd December 2008, 09:00 PM
Does your SIM in another handset do the same thing? Have you paid your bills recently? Has there been recent storm activity in your neighborhood and have you recently made a rate-plan or other service-affecting change to your phone plan?

1) The SIM works fine in another handset

2) I have paid my bills

3) No recent storm activity

mvjs
22nd December 2008, 09:04 PM
1) The SIM works fine in another handset

2) I have paid my bills

3) No recent storm activity

If the SIM works fine in another handset and you've done a full restore, you've eliminated two of the three culprits really; software and network. The only option you've got is to take it into Chadstone and get it swapped over, as far as I can see.

Exocet
22nd December 2008, 09:15 PM
mvjs is on the money. Isolation people, its the REAL troubleshooting.

mallo
22nd December 2008, 11:30 PM
Try Disabling 3g, I had the Same symptoms, soon as I disabled 3g worked fine, I took it into chadstone and had it changed within 1.5min

chrsha01
23rd December 2008, 01:44 PM
I also tried putting another SIM into the iPhone but still no success. Off to Chadstone it seems. Thanks for your help guys, much appreciated. :)

Joey1983
24th December 2008, 09:58 PM
Try Disabling 3g, I had the Same symptoms, soon as I disabled 3g worked fine

+1

Almost impossible for me to make or take a call with 3G turned on...
I'm on Voda though.

Lumus
24th December 2008, 10:32 PM
Try getting your sim card replaced and see if it make a difference. SIM cards can be fickle things if they've been even slighly damaged.

chrsha01
25th December 2008, 06:01 PM
Try getting your sim card replaced and see if it make a difference. SIM cards can be fickle things if they've been even slighly damaged.

But as I've said in my above post, I tried another SIM card in the iPhone and still it came up with 'Call Failed'. :(

chrsha01
27th December 2008, 10:59 PM
I went down to the Chadstone store today and within 10 minutes or so I was with a 'new' iPhone.

I was just wondering whether the ones they give you are usually new or are in fact refurbished.

I say this because I have noticed that the one I have now has a few imperfections like an un-even sleep/wake button and a chipped plastic edge near the dock connector.

Should I go and return it again or am I just being fussy? :D

forno
28th December 2008, 09:36 AM
Go back IMO, they are refurbed, but I would be pissed if my pristine iPhone developed an issue that required replacement and that replacement wasnt pristine either

landog
28th December 2008, 12:24 PM
Ive had 3 iphones, 1 2g and 2 x 3g,

The 2g was magic, never missed a beat, wish I had kept it

The 3 G - I had this problem constantly, as well as incoming calls going straight to voicemail. I replaced my 3g iphone thinking it was the networks, no luck same issues and this was before I even updated the new one in itunes. My brother has a 3g one, he very rarely receives incoming calls, mostly they go to voicemail and many calls drop frequently.

So i recently sold the 3g one and bought a blackberry. Honestly I havent dropped a call, missed an incoming call, or had problems dialing once. Its been 2-3 months now.

Ill tell you what the problem is with the Iphone 3G. Because its an immature chipset / wireless stack, its inherently unstable in maintaining its connectivity with the networks...coupled with the fact that....optus and vodafone have rather shit, over subscribed, poorly "meshed" networks which means that a combination of a shit phone with a shit network = complete shit.

I miss my iphone, but imho you need to wait for Version 3 before making it your main business phone in Australia (unless your on Telstra).

Just my 5 cents.

Cheers

Supblek
29th December 2008, 02:36 PM
It could be somthing with your sim card. THis happen to my mother's iphone.. the sim card was faulty. Best to check if the sim card works in another phone.

arkenstone
29th December 2008, 02:37 PM
Go back IMO, they are refurbed, but I would be pissed if my pristine iPhone developed an issue that required replacement and that replacement wasnt pristine either

x2

The one we got replaced from the Apple store in Chadstone was flawless.

iTy
28th November 2009, 08:07 PM
Thought I'd revive this thread. Need help BIG time.

I've 2 iPhone 3GS and they both do the same thing.

Call failed
Tries to call out but just sits there with msg "calling..."
Incoming calls come through but the caller cannot here me and vice versa
Lots of dropped calls

I'm on 3.1.2 (7D11) and new iPhones. Got the last one replaced on Thursday from Chermside, the other one was replaced from Robina 2 months ago. This is really pissing me off. Is this a Vodafone issue or Apple?

Btw, there are no issues, when I turn 3G off. The sims work fine in other phones.
Also, I got my mum an iPhone through 3 and hers does the same thing, though not as frequent. My 2 Vodafone iPhones have this issue several times a day.

I'm about to throw these bloody things out the window :mad:

Would appreciate any ideas guys.

TIA

ipwn
28th November 2009, 10:15 PM
Thought I'd revive this thread. Need help BIG time.

I've 2 iPhone 3GS and they both do the same thing.

Call failed
Tries to call out but just sits there with msg "calling..."
Incoming calls come through but the caller cannot here me and vice versa
Lots of dropped calls

I'm on 3.1.2 (7D11) and new iPhones. Got the last one replaced on Thursday from Chermside, the other one was replaced from Robina 2 months ago. This is really pissing me off. Is this a Vodafone issue or Apple?

Btw, there are no issues, when I turn 3G off. The sims work fine in other phones.
Also, I got my mum an iPhone through 3 and hers does the same thing, though not as frequent. My 2 Vodafone iPhones have this issue several times a day.

I'm about to throw these bloody things out the window :mad:

Would appreciate any ideas guys.

TIA





I feel your pain, Voda was pretty good up untill august, and then bam!

Call failed several times a day, going to my voice mail although i have full service, and i live 20meters from their tower.......

I switched from optus for the same reason.


NOW VODA IS SHIT BALLS...

Im going to telstra next, My friends on telstra have no problems at all and hardly reset their phones, why the hell should i have to reset network setting 3 to 4 times a week to use my f-ing phone, customer support seems to think this is acceptable I DO NOT

RANT OVER AND OUT

iTy
28th November 2009, 11:28 PM
I feel your pain, Voda was pretty good up untill august, and then bam!

Call failed several times a day, going to my voice mail although i have full service, and i live 20meters from their tower.......

I switched from optus for the same reason.


NOW VODA IS SHIT BALLS...

Im going to telstra next, My friends on telstra have no problems at all and hardly reset their phones, why the hell should i have to reset network setting 3 to 4 times a week to use my f-ing phone, customer support seems to think this is acceptable I DO NOT

RANT OVER AND OUT

I know what you mean, every time I call Voda, their technical support just points the finger at Apple and vice versa. Us poor saps are caught in the middle.

I was with Telstra previously and though their customer touch points are utter crap/incompetent, their network is amazing. After all the trouble they put me through, I find myself saying, "maybe I'll get a prepaid with Telstra".

Fricking Voda has locked the handset too. :mad:

Now that I think about it, this has been happening since August. That was why I changed the first handset in the first place. I wonder what happened around then...

dche5390
1st December 2009, 03:29 PM
Im going to telstra next

Smartest thing you've said all day. But prepaid is the way to go.

DazR6
2nd December 2009, 09:31 AM
It is happening to me too, plus 3 other people at work with iPhones the same. Also my boss has the same problem but he has a Blackberry. We are all on different carriers.

mitty
2nd December 2009, 09:49 AM
Guys, I had a similar problem where my phone constantly had call failed, but whilst at home. But doing isolation and my own testing determined it had to be the NextG Cell local to where I lived that had the problem, no problems elsewhere. 2G was also fine, only 3G had the problem, and only when I was in about half a k of my place. My partner had the same problem. Rang T and reported it as an issue, it was fixed within a day (maybe the cell needed a reboot or something).

iTy
3rd December 2009, 06:20 AM
My issue occured all over Brisbane regardless of 3G signal strength.

However, I got so sick of it that I wiped everything and started it as a new phone the other day. Lost a my SMS and Things data. Didn't care about the rest but so far so good. Not sure if this is a fix though.

I'm not sure what info is saved and restored when you restore from backup but here's hoping what ever bug it was is gone.

Touch wood that it keeps running smoothly.

Mychael
19th December 2009, 04:31 PM
I have had a similar problem on occasion with my Motorola, re-booting the phone seems to fix it however I have noticed it is a more frequent occurrence in the Ringwood area.

strat
20th December 2009, 04:39 PM
It a network issue i been getting this since i been with 3 and it annoys the hell out me.