PDA

View Full Version : Spaces - doing my head in! [Solved]



Joe91
18th November 2008, 07:59 PM
I began scratching my head over this and now I'm really frustrated. :mad:

I have set up 4 Spaces (Pages, Safari, MSN and iTunes) pretty easily but once I got to the actual multitasking I hit a brick wall. I've had a look at a few YouTube videos but they failed me, as did a quick Google.

So, when I'm in a Space using Pages for example, how do I instantly jump to another space without opening "the birds eye view"? In the Spaces preferences, it says "To switch between spaces" and I have set the arrow keys to do this. But the arrow keys won't let me switch at all. :confused:

Thanks :)

Huy
18th November 2008, 08:03 PM
Control + arrow keys left/right/up/down.

Or to jump straight to say your 3rd space, Control + 3.

http://img512.imageshack.us/img512/7817/90145784ga7.jpg

azenis
18th November 2008, 08:29 PM
or just click the dock icon for the program whose space you want. There is a menu bar icon for spaces too that let's you switch spaces.

banjo
18th November 2008, 08:49 PM
I usually use Ctrl+1,2,3 or 4 to immediately jump to the space I want.


or just click the dock icon for the program whose space you want

This might not work depending on your settings as you can set it to switch apps without switching spaces. So you can, for example, open a new Safari window in your current space.

tcn33
18th November 2008, 08:52 PM
I usually use Ctrl+1,2,3 or 4 to immediately jump to the space I want.
Same here, except I have 1 through 8. With specific apps assigned to specific spaces, you very quickly get used to selecting a particular space to go straight to an app.

azenis
18th November 2008, 09:18 PM
I usually use Ctrl+1,2,3 or 4 to immediately jump to the space I want.



This might not work depending on your settings as you can set it to switch apps without switching spaces. So you can, for example, open a new Safari window in your current space.

Oh ok, have not had that happen. Though I have noticed Lightroom 2 and Twitterrific and a few others dont play nice with spaces, when you click their dock icon they dont switch to their space, nor will they display on all spaces if set to.

Joe91
18th November 2008, 09:21 PM
I must have my keystrokes screwed up, because nothing you guys have posted is working. Either that or another setting in Spaces. Hopefully the screenshot will help. Cheers for your help so far guys!

http://img505.imageshack.us/img505/439/picture1ys5.png

Huy
18th November 2008, 09:25 PM
Try all combinations:

Shift + Arrows
Control + Arrows
Option + Arrows
Command + Arrows


It should work with Control though... my settings are the same as yours. Except the last one.

Try the right Control.

banjo
18th November 2008, 09:26 PM
Never mind ...

Huy
18th November 2008, 09:27 PM
Never mind ...

Shift is the 'up' arrow.
^ is Control.

EDIT
Nevermind. :D

banjo
18th November 2008, 09:41 PM
Oh ok, have not had that happen

Looks like you have the checkbox set to switch spaces so that's not the issue.

Anyway, are your other shortcuts working, such as Cmd-Tab or Cmd-Shift-3/4 (screen grab) or Cmd-Space (Spotlight), and Expose shortcut if you have it set up?

Are you using a default screensaver? It seems 3rd party ones can screw up your shortcuts (http://forums.macrumors.com/showthread.php?t=427224). Or other programs you are using that override them but not release them once closed.

And at the risk of sounding patronising: have you tried restarting?

[edit] I've also found that Universal Access can screw with your use of modifier keys at times.

Joe91
18th November 2008, 09:48 PM
Thanks guys.

Huy, tried all the combinations you suggested - none worked.

banjo, yep, all my other shortcuts work. I use Cmd+click for tabs constantly, all the other ones I just use the function keys on the MacBook - but yeah, all of them are working. No third-party screensavers are installed.

No need to worry about sounding patronising either :) I'll give the restart a go in a minute.

And FWIW, I can see the little Spaces graphic show up whenever I switch to another task (if I'm changing apps through the dock) so Spaces itself is working, and like I said, I can change using the birds eye view.

EDIT: Universal Access is all default, never touched it.

banjo
18th November 2008, 10:05 PM
Universal Access is all default, never touched it.

Not necessarily related but you may want to turn it all off both under Keyboard Shortcuts and Universal Access in your preferences, just to be safe. I hate it when I accidentally turn on speech-to-text, sticky keys (the most likely culprit if this is the issue), or alter the contrast of my screen.

[edit]

Before restarting, perhaps try restarting spaces by restarting the dock. Type into terminal:


killall dock

If this does not work, you could try ditching the com.apple.dock.plist file under ~/Library/Preferences/ which will reset both your spaces and dock preferences ... which you will then have to set up all over again.

And finally, the second last post on this thread (http://www.insanelymac.com/lofiversion/index.php/t101463.html) might provide a temporary solution.

If none of the above work alone or in combination, I'm stumped. This problem seems to be out there on various forums with no particular solution, and more often than not unresolved.

Joe91
18th November 2008, 10:39 PM
Appreciate all your help fellas!

The restart did the trick - have it working perfectly now. I just assumed it was my Mac-newbism shining at full strength that I didn't even consider a restart.

Thanks banjo :)