PDA

View Full Version : iPhone won't let me restore original firmware from DFU mode



benzoenator
16th November 2008, 08:08 PM
Hey guys,

My iPhone's been annoying me lately (weird bugs and such) so I decided to restore it completely (note, it's jailbroken - I used QuickPwn about two months ago). Trouble is, it doesn't want to restore. I downloaded the latest firmware, threw iPhone into DFU mode and manually selected the firmware. It extracted it, but as soon as it had finished I got the following error:

Grabup Image (http://www.grabup.com/uploads/9130c7ce1c690fcbfe8de39aa7fd30e9.png)

No matter what I did, I just got that error. Decryption suggested going back to 2.0.2, which I did, to no avail - I still got the same error.

I'm kind of freaking out now. The phone's working, but I want to be able to restore the original firmware back on it. What could possibly be causing this error?

Thanks in advance!

Ecto1
16th November 2008, 08:18 PM
I had a similar problem where I wanted to do a restore but got the same error msg as you are getting. turned out to be one of those funky vista updates conflicted with itunes.

I would recommend un-installing itunes and try reinstall it. BTW I am going with the idea the issue is using a mac and not windows.

benzoenator
16th November 2008, 08:40 PM
Thanks for the suggestion Ecto.

Just deleted iTunes.app and installed it again... To no avail. Same issue is still happening :(

Ecto1
16th November 2008, 09:06 PM
Try uninstalling Apple mobile devices, once done plug the iphone into itunes then see what happens.

benzoenator
16th November 2008, 09:29 PM
I tried restoring it on another computer. Same error. I hate to say it, but I think it's my iPhone...

decryption
16th November 2008, 09:43 PM
Go back to 2.0.1 if 2.0.2 doesn't work.

benzoenator
16th November 2008, 10:17 PM
Fixed.

Just did a stock standard DFU - ie. click Restore, and let iTunes download a copy of the firmware. No idea why downloading a copy of the firmware from Apple's website didn't work, but my god I'm glad that this is fixed.

Thanks for your help everyone :)

the_doctor
16th November 2008, 10:28 PM
hey benzonator, only saw this thread now but my brother in law came over today with an issue with his jailbroken 2.1 1G iPhone. All of his standard icons (phonebook, settings, mail etc) had disappeared. He has a jailbroken phone but has never installed apps from Cydia or installer so no idea how the issue arose.

Any we had the same problem as you trying to restore today. I had a copy of 2.1 on my HD that I was trying to restore from but was having no luck. As a last resort I decided to download and restore that latert firmware through iTunes and what do you know that bloody worked.

I wish I had tried that first as it would have saved me a lot of time.