PDA

View Full Version : VMWare Fusion and printer problems



hermeneutics
28th October 2008, 09:45 PM
Hi!

I am a new Mac User (well I used to use them quite a bit in the early 1990s but I'm new to Mac OSX)

I have networked my Mac Book Pro onto my wireless LAN. It talks quite nicely with my 3 other PCs running Win XP, and has no problem printing to my Brother HL-1430 laser printer which is connected to one of these other PCs.

However, I also have VMWare Fusion running Windows XP. In the XP VM, my printer appears to be visible and connected, but when I print to it--although it appears to queue the file--nothing actually happens! No printed file! No error messages!

The printer is listed in the "Printers and Faxes" dialog as:
Brother HL-1430#:1,
Status=Ready,
Comments=Printer created by TPAutoConnect,
Location=0;
Model=TP PS Driver <very long hex no.>

It was automatically created and setup when I created my XP VM.

What is going on?

I have noticed that several other people have had similar (but not identical problems) with VMWare Fusion and networked printers, but I can't find an appropriate fix for my problem.

Any ideas, anyone?

cheers,
Andrew

hermeneutics
31st October 2008, 01:32 AM
Thanks for all the replies! NOT!

I solved the problem myself.

1. Goto Virtual Machine->Network Adaptor and select Bridged.
2. Configure network in XP VM as if it were a stand-alone PC ie. give it manual IP address etc. or use DHCP.
3. In XP VM, browse to shared printer using Explorer (Entire Network....etc), and drag it into Control Panel Printers and Faxes folder.
4. Printer driver installs, and you're ready to go!

cheers,
Andrew

craigc
31st October 2008, 07:12 AM
Thanks for all the replies! NOT!

I solved the problem myself.

1. Goto Virtual Machine->Network Adaptor and select Bridged.
2. Configure network in XP VM as if it were a stand-alone PC ie. give it manual IP address etc. or use DHCP.
3. In XP VM, browse to shared printer using Explorer (Entire Network....etc), and drag it into Control Panel Printers and Faxes folder.
4. Printer driver installs, and you're ready to go!

cheers,
Andrew

Thanks for the information. I am going to be setting up VM myself in the near future, and I am sure this will help me.

bobotron
21st November 2008, 12:24 AM
This worked for me. The "bridged mode" was the key. Not only did it allow me to find network printers, but it also did a bunch of maintenance stuff that it must have not have been able to do in NAT mode. I got pop-up balloons for various updates, etc.

Note: For some reason it took a few minutes to work itself out once I changed to bridged mode. I switched it over, and then about gave up and did other things. And then all the sudden things started popping up in the network browser, etc.

abstractsins
10th October 2013, 04:02 AM
FIX. So, I just fixed this problem for myself. I have to share.

The printers were already installed and working properly, but whenever i would start up VM it would for some reason add a few printers. As hermeutics mentioned, they would end in :#2 or some such thing and the models were TP PS some long number. These printers don't work and what's worse is that it was setting one of them as the default.

I did what he first suggested and switched to BRIDGED. My printers still worked after this, but I wasn't sure about the rest of the instructions. I deleted the weird printers and restarted. They kept coming back.

At some point I stumbled across something online that made me realize this is related to a local service: TP Autoconnect Service. I stopped the service, deleted the printers and restarted. For some reason, even though the service is manual, it would start up again and add the printers. I flat out disabled the service, deleted the printers, and restarted. The printers still work and now there's no weird printers being automatically added! My only concern is whether or not I should change the Network Adapter back to NAT or leave it BRIDGED. Things seem to be working, so, why bother...?

What I did:
+Go to control panel (In windows/VM)
+Go to Administrative Tools, View Local Services (or just search for 'services' in the control panel if you're in windows 7 or later).
+Click on 'view local services.'
+Scroll down to "TP Autoconnect Service"
+Right click on it, go to properties.
+Under the 'start up type' drop down menu, select 'disabled.'
+Click 'ok.' Get rid of the funky printers and restart.

Did the trick for me!