PDA

View Full Version : None of the App Store apps work on my iPhone



Kai
11th September 2008, 10:01 AM
Hi has any one else got the problem that when they first turn on their Iphone 3g that all the apple apps work but that is it nun of the apps from the app store work (not even remote)????

and how to fix this problem?????

thanks

decryption
11th September 2008, 10:03 AM
Do a full restore (put the iPhone into DFU mode) and that should give you a fresh start.

the_doctor
11th September 2008, 10:48 AM
I agree with decryption. A full restore is the way to go.

How many apps (App Store) do you have? If you have alot (20+) it may take a while to sync back onto your iPhone so make sure you have some time to sit around and wait.

The restore to factory settings should only take 10 minutes or so but the re-syncing of apps, music, photos and vids will be what takes a long time.

SpecialHell
11th September 2008, 02:18 PM
happened to me today, all the app store apps i installed stopped working. they would just shutdown as soon as you tried to open them.

i just deleted them and reinstalled them, it remembers that you purchased them and you can reinstall free.

i think i'll keep my app programs to an essential minimum till all bugs are ironed out.

WindowsVista
11th September 2008, 05:07 PM
Uninstall one app, re-install it (just one). Fixed it for me.

Kai
11th September 2008, 07:24 PM
Ok I tryed the reinstall did not work and I have just relised the all my music and podcasts (mactalk as well) and the apps studs do not work and I had had this prob befor and did a full restore an this is the secned time it has happined.

Kai
11th September 2008, 08:04 PM
And I just got rid of half of my apps and then when into settings and it frozze on me so I rrlestarted my iPhone and found that all the apps I had got rid of had come back???WTF

decryption
11th September 2008, 08:06 PM
You aren't doing it properly - restore using DFU mode: iClarified - iPhone - How to Put an iPhone Into DFU Mode (http://www.iclarified.com/entry/index.php?enid=1034)

hoony
11th September 2008, 08:50 PM
This happened with my husbands iPhone & we fixed it.

The problem ended up being his version of iTunes. He is on Vista (shame shame I know) after syncing with iTunes 7.7.1 all the app store apps crashed, we downgraded to 7.7.0 and re-synced his phone, and everything has been fine since then.

More Solutions to Fix iPhone Apps Crashing Issue - iPhone Hacks (http://www.iphonehacks.com/2008/08/app-crashes-fix.html)

Kai
12th September 2008, 12:44 AM
Ok i got it working for now thanks for all the help, with the DFU mode becuase syncing with an old itunes did not help and I hope that this problem will be fix in 2.1.

klif
12th September 2008, 01:18 AM
Ok I tryed the reinstall did not work and I have just relised the all my music and podcasts (mactalk as well) and the apps studs do not work and I had had this prob befor and did a full restore an this is the secned time it has happined.

God damn I thought this was just me.

I jumped on a 14.5 hour flight to Los Angeles last week with a working iPhone 3G in my pocket with 5 extra pages of apps and around 6gb of music.

When I turned the iPhone on with Flight Mode enabled and tried to load an apps it just crashed back to the launcher, tried another one, same thing. WTF!!

Tried half a dozen different apps and the situation was the same, figured it might be something to do with lack of any network connectivity, which didn't make any sense but thought I'd try it when I landed.

Then I went to play some music and the iPhone promptly told me I had no music, no tracks, no songs, no playlists, no podcasts, WTF!!!!

I went into Settings->General->About and it confirmed 0 audio and video objects, but it did confirm 6gb of my 16gb iPhone 3G was in use!!

I was sooooooooooooooo pissed off!!!!

I landed and retested and the same issue continued.

I plugged the iPhone into the MacBook Pro and iTunes 7.7.x and it showed all the apps and music installed with no problems reported. Completed a sync and nothing changed, still unable to play/see any music on the iPhone.

Since then I have done a restore of the iPhone 3G so I could make it useable and it appeared to work.

In addition I put in a T-mobile SIM for my trip and my iPhone kept restarting every 3-4 minutes, no idea what this was about. It was stable again with my Optus SIM.

I let it settle and then swapped the T-mobile back in and it seems to work now.

So my first few days of the iPhone 3G after leaving Australia for a little while have been pure shit. I did book a genius appointment at the 5th Avenue Store in New York City but after 45 minutes of waiting for my appointment I left.

I will do a full restore on Friday when 2.1 comes out.

Getting pretty sick of these system issues/bugs/defects whatever you want to do call it.

dev_enter
12th September 2008, 01:23 AM
I had this problem when I first got my iPhone because I tried using the App Store from the iPhone before I'd grabbed any apps from the iTunes store on my Mac. Once I did that, it all worked as expected.

Mafesto
12th September 2008, 08:11 AM
As WindowsVista says, download another app and run it, it fixed everything for me.