PDA

View Full Version : Desktop not refreshing



banjo
3rd September 2008, 06:52 AM
My desktop is being a pain and refusing to refresh whenever something happens on it. I can drag files to it, or save files there, but they're not appearing on the Desktop afterwards. They are there, I can see them when navigating to it in Finder, but they're not appearing.

P.S. I think it has something to do with the fact that I have the text appearing to the right of the icons instead of underneath. When I set it back to the default, it appears to work as normal. I'd prefer not to change it back though, but will if there's no other solution.

Huy
3rd September 2008, 08:53 AM
Kill Finder/Reload Finder.
Restart Mac.

:)

thorevenge
3rd September 2008, 09:05 AM
My desktop is being a pain and refusing to refresh whenever something happens on it. I can drag files to it, or save files there, but they're not appearing on the Desktop afterwards. They are there, I can see them when navigating to it in Finder, but they're not appearing.

P.S. I think it has something to do with the fact that I have the text appearing to the right of the icons instead of underneath. When I set it back to the default, it appears to work as normal. I'd prefer not to change it back though, but will if there's no other solution.

Look for a CMplugin called Nudge.

Basically you right click - choose 'Nudge' and it refreshes the open Finder window for you.

Currawong
3rd September 2008, 09:33 AM
banjo: That's indeed weird. You could try deleting the Finder's preferences and restarting it. To do this, in your home folder, go into Library -> Preferences and drag the file named com.apple.finder.plist to the trash. Then in the Apple menu, select Force Quit and select the Finder. You should end up with default settings. With any luck, it'll fix the problem.

If not, there another bit of voodoo that sometimes fixes random weirdness such as this.

banjo
3rd September 2008, 03:56 PM
Well, it must have been something to do with preferences. Changing the label position from right to bottom then back again seems to have fixed the problem ... for now. Still, strange that it was doing it in the first place.