PDA

View Full Version : Apps from the Apps Store don't work on iPod touch



jimdrum
11th July 2008, 02:15 PM
Having updated iTunes to 7.7, I downloaded some Apps from the App store to try on my iPod Touch.
Don't bother! The iPod Touch software doesn't allow you to load these apps from your computer.
(Perhaps they will work if you download directly to your iPod Touch, rather than doing it via your computer.)
Apple tells me that for them to work, I'll need the iPhone 2.0 update (!!) and it will cost US $9.99.
Nowhere in Apple support or in the FAQ's at the store does it mention this lack of compatibility.
What a poorly executed 'feature' this is.
And to graft US $9.95 from users just so we can install apps. is outrageous, in my opinion.

STK
11th July 2008, 02:17 PM
I guess it's kinda updating from tiger to leopard...

Muzza_77
11th July 2008, 02:19 PM
Yeah it's like a whole new OS for your touch, so a fee is expected. $10 i think is very good for this update.

themessup
11th July 2008, 02:19 PM
iPhone owners get free updates :)

ethania05
11th July 2008, 02:20 PM
Got a little too excited and didn't bother reading the instruction eh? :p

Muzza_77
11th July 2008, 02:21 PM
iPhones cost twice the price lol id rather just pay $10 instead of $400

jimdrum
11th July 2008, 02:22 PM
Yeah it's like a whole new OS for your touch, so a fee is expected. $10 i think is very good for this update.

Really? A whole new OS? That allows you to install apps?? It doesn't sound like a whole new OS to me!

mvjs
11th July 2008, 02:22 PM
And to graft US $9.95 from users just so we can install apps. is outrageous, in my opinion.

You purchased your iPod touch with the 1.x.x firmware on the knowledge of the features Apple advertised. They delivered on every single feature that was advertised.

Apple have worked hard and will be releasing a software update that includes new features, one of which, third party applications. Albeit a legal requirement (under Sarbanes Oxley), they are offering previous iPod touch owners and option of taking advantage of this new firmware for a nominal fee. No one is forcing you.

Would you prefer Apple to say, "OK, all new iPod touch owners will get Firmware 2.0 free, sorry old iPod touch owners - go buy a new one" or "Hey, all previous iPod touch owners, it's a nominal $9.95 fee for the new software and it's free for all you newcomers"

jimdrum
11th July 2008, 02:25 PM
Got a little too excited and didn't bother reading the instruction eh? :p

No. Not so.
Please show me the link to where it tells you that these apps will not work on an iPod touch.
In fact, nothing I read indicates this.

Apoptosis
11th July 2008, 02:25 PM
Having updated iTunes to 7.7, I downloaded some Apps from the App store to try on my iPod Touch.
Don't bother! The iPod Touch software doesn't allow you to load these apps from your computer.
(Perhaps they will work if you download directly to your iPod Touch, rather than doing it via your computer.)
Apple tells me that for them to work, I'll need the iPhone 2.0 update (!!) and it will cost US $9.99.
Nowhere in Apple support or in the FAQ's at the store does it mention this lack of compatibility.
What a poorly executed 'feature' this is.
And to graft US $9.95 from users just so we can install apps. is outrageous, in my opinion.

This was always the case. Right from the Keynote El Jobso stated this. Was also the case with the software update last year!

jimdrum
11th July 2008, 02:28 PM
You purchased your iPod touch with the 1.x.x firmware on the knowledge of the features Apple advertised. They delivered on every single feature that was advertised.

Apple have worked hard and will be releasing a software update that includes new features, one of which, third party applications. Albeit a legal requirement (under Sarbanes Oxley), they are offering previous iPod touch owners and option of taking advantage of this new firmware for a nominal fee. No one is forcing you.

Would you prefer Apple to say, "OK, all new iPod touch owners will get Firmware 2.0 free, sorry old iPod touch owners - go buy a new one" or "Hey, all previous iPod touch owners, it's a nominal $9.95 fee for the new software and it's free for all you newcomers"

Yes, I see your point. What bothers me is that nowhere at the Store or in the support literature does it say 'you'll need to update your firmware before any of this works'.

Quamen
11th July 2008, 02:28 PM
No. Not so.
Please show me the link to where it tells you that these apps will not work on an iPod touch.
In fact, nothing I read indicates this.

They will work on an iPod touch. But they require firmware 2.0.

gaehl
11th July 2008, 02:30 PM
No. Not so.
Please show me the link to where it tells you that these apps will not work on an iPod touch.
In fact, nothing I read indicates this.

I'm sure its also elsewhere but this is the first place i found.

http://www.grabup.com/uploads/5c50751c541670c87b67a72bd5f0e390.png

Aaron
11th July 2008, 02:32 PM
http://img.skitch.com/20080711-jf4mu81ksrq5nif4yerpxsk9gs.preview.jpg (http://skitch.com/aaronwaters/xwe9/itunes)
Click for full size (http://skitch.com/aaronwaters/xwe9/itunes) - Uploaded with plasq (http://plasq.com)'s Skitch (http://skitch.com)

Apple use iPhone 2.0 to describe the OS that runs on the iPod Touch, iPhone and iPhone 3G :)

Muzza_77
11th July 2008, 02:32 PM
Apple - iTunes - iTunes Store - App Store (http://www.apple.com/itunes/store/appstore.html)

If you click on this link, then scroll down, just below the screen of "super monkey ball" there's an * which says "Access to the App Store requires the iPhone 2.0 Software Update for iPod touch, sold separately. Some applications are not available in all areas. Application availability and pricing are subject to change."

EDIT: Dang!! I was beaten haha

something2sea
11th July 2008, 02:37 PM
Well… where is this iPhone 2.0 for iPod Touch as I want to install it! I've been looking for it for a while and can't find it anywhere.

People get the new firmware with the iPhone 3G, but it's not available for us to download yet. What's the story Apple?

Muzza_77
11th July 2008, 02:39 PM
Yeah yeah!! it's soo annoying lol im sitting here waiting!! come on apple!

something2sea
11th July 2008, 02:41 PM
There's been "unofficial" links to iPhone 2.0 for iPhone, I haven't tried to install those on the iPod, but people say it doesn't work.

I should have expected it when I got the iPod, should have known that the iPhone will be the "big thing" and the iPod will get trampled in dust and forgotten about.

I want to play my Cro-mag rally!

jimdrum
11th July 2008, 02:48 PM
I'm sure its also elsewhere but this is the first place i found.

http://www.grabup.com/uploads/5c50751c541670c87b67a72bd5f0e390.png

Yes, quite right. I did not see the last sentence. In fact, I think it may have been added since last night, when I read the original FAQ's.

The iPhone 2.0 software (perhaps it should be named iPod/iPhone 2.0 software) isn't yet available.
The Apps are there. The iTunes update is there. Shame they missed releasing the 2.0 software at the same time.

jimdrum
11th July 2008, 02:53 PM
I should have expected it when I got the iPod, should have known that the iPhone will be the "big thing" and the iPod will get trampled in dust and forgotten about.

I agree. The iPod touch has been left behind here.

Apoptosis
11th July 2008, 02:57 PM
I should have expected it when I got the iPod, should have known that the iPhone will be the "big thing" and the iPod will get trampled in dust and forgotten about.

I agree. The iPod touch has been left behind here.

Yeah, and it's fucking pissing me off! As soon as the iTunes update was out last night I installed it. Got into the App store before it was official and downloaded my first app. But nearly a day later there's still no firmware for me to buy to let me run the free app :rolleyes:

something2sea
11th July 2008, 03:16 PM
I think apple have made a booboo here.

MobileMe is still not up, and there's no firmware updates avaliable for the iTouch to provide features that iPhone people get for free (Apple should be interested in getting our money!!)

dshan
11th July 2008, 06:23 PM
Yes, the lack of iPhone 2.0 s/w updates for existing iPhone/touch users is very frustrating. i've been plugging my touch into iTunes 7.7 all day and clicking the check for updates button (Apple, I want to give you money!) but no sign of it so far.

Apoptosis
11th July 2008, 06:27 PM
I have hit check for updates like 100 times today!

I WANT THAT UPDATE!