PDA

View Full Version : iTunes - tracks not mergeing into single album



FineWine
5th April 2008, 04:40 PM
I just iTunes purchased the sound track to "Across the Universe" which contains 17 tracks by different artists. In the past when I have done this all the tracks appear in the one album listing under the one album artwork. Not this time. They are appearing as 11 separate entries in iTunes.

I have tried all sorts of different sort criteria, I have ticked and unticked "Part of a Compilation" box. I even made a back up copy of the album in Finder and deleted the tracks from iTunes and reimported the album, all to no effect.

Any suggestions - this has never happened before, why this time.

Cheers

bullrout
5th April 2008, 04:47 PM
Make Album Artist all the same?

camel
5th April 2008, 04:47 PM
are the album names for each song the same?

m_242
5th April 2008, 05:00 PM
I have had this problem before; I solved it by putting the same name in the field "Album Artist" for each song on the album.

FineWine
5th April 2008, 05:04 PM
When I select multiple tracks and "Get Info" there is the following:

Artist = Blank
Album Artist = blank
Album = Across the Universe (Music from the Motion Picture)
Grouping = blank
Composer = John Lennon & Paul McCartney
Genre = Soundtrack
Compilation = No
Track Number = blank of 17

When I select single tracks and "Get Info" there is the following:

Name = song name
Artist = blank
Album Artist = artist name
Album = Across the Universe (Music from the Motion Picture)
Grouping = blank
Composer = John Lennon & Paul McCartney
Genre = Soundtrack
Compilation = No
Track Number = has the correct entry

Hope this helps

Mac Ram
5th April 2008, 06:18 PM
How about selecting all the tracks and then in the info ticking "compilation" (bottom left hand corner)

camel
5th April 2008, 06:23 PM
make sure there are no typos in the album name..i have had this happen a few times

this might be a space after a ) or something like that..

other than this, im short of ideas

FineWine
6th April 2008, 12:21 PM
Ok, I have solved the problem.

I went through each track individually and cut & pasted the Album Artist detail to the Artist and leaving the Album Artist entry blank. I then ticked the "Part of a Compilation" box.

All are now merged into the one album entry with the one piece of album artwork.

Thanks guys for your helpful tips.

camel
6th April 2008, 12:26 PM
no issues, glad you solved it mate

FineWine
6th April 2008, 12:38 PM
By the way, the movie "Across the Universe" is a fabulous movie, even if you are not a Beatles fan and who is not. If you can remember the 60's and early 70's and some of us can't, :) then they have done a great job of weaving a story of this era using the Beatles songs as a basis for the script. When it becomes available for sale I for one will be adding it to my DVD library. :thumbup::thumbup::thumbup::thumbup::thumbup:

camel
6th April 2008, 12:38 PM
10-4 on that and +1 for the beatles

Hoodster
14th March 2010, 02:07 AM
I just tried this solution for the same problem, and it didn't work.

I had inadvertently deleted a song from a compilation cd (and btw, how the heck do you restore a file from the trash back to its original location? Seems like this should be a simple move--"restore file"--but I could not find how to do it). So, since it would not let me drag the song file from the trash to the itunes album--or itunes at all--I had to drag it first to the desktop and then into itunes, but of course it filed it as its own song instead of back with the compilation. I used get info and made sure EVERYTHING is the same as the other songs in the compilation, but it won't move, regardless of checking the compilation box, trying the fix above, etc.

I love my Mac, but sometime it makes me insane that it makes such simple things so difficult.

FineWine
14th March 2010, 03:27 AM
Try this:

Quit iTunes.

Go to your iTunes library here: /Users/username/Music/iTunes/iTunes Library now drill down till you find both your original album folder containing the tracks and the album folder containing the individual track (Note they could be in the "Compilations" folder). Drag the individual track to the whole album listing.

Fire up iTunes again.

If you have Time Machine just restore your iTunes library prior to the deletion.

Cheers

Hoodster
14th March 2010, 04:33 AM
Good idea, but when I opened it that way it showed the song listed with all the others in the compilation! Opened itunes again and it's still separate. Weird!

BTW, do you know the answer to the delete/restore question?

FineWine
14th March 2010, 05:58 AM
OK. Quit iTunes and goto /Users/username/Music/iTunes/iTunes Library and drag the entire albumn out to the desktop. Fire up iTunes again. Then File - Add to Library and point to the albumn on the desktop and re-import again. Ensure you are connected to the internet during the re-importation so iTunes can grab artwork and track info again. Now select them all, then edit their Info so that they're all "out of" that number off tracks on the album. Then go one at a time, and number them 1 through or whatever. That way, they'll be numbered on the album right. Does that make sense?

As for the delete & restore question - I am at work on a PC not in front of my Mac at home so I do not know if there is a right click option on the Trash Can or not or some other such way. But I would presume just dragging out of the trash back to that albumn should of worked.

Cheers