PDA

View Full Version : iTunes 7.6.2 crashes when accessing store



leon
3rd April 2008, 12:26 PM
iTunes installed the 7.6.2 update this morning and now I can't access the online store. It just crashes iTunes once it loads up. Anyone else having this issue? Looks like I will have to try and downgrade to 7.6.1 again.

spuds_imac
3rd April 2008, 12:29 PM
No problems here all working fine.

leon
3rd April 2008, 01:38 PM
I have been observing how and when it crashes and I have noticed that when I first select the iTunes store, the progress bar moves along and then the store loads. Then the progress bar comes up again and begins to load something. It is during this time, that iTunes hangs and quits out of itself. If I am quick, I can able to press the (x) button next to the second progress bar when it pops up and cancel the process. If I do this, then itunes doesn't crash and I can still navigate the store. Very weird. I have never had a second progress bar pop up when accessing the iTunes Music Store.

leon
4th April 2008, 11:49 AM
For those interested it seems to be an issue with being behind a proxy server. Someone else has reported it on MacFixIt. Shame, means no more super speedy downloads from work.

MrJesseRoss
4th April 2008, 12:05 PM
I actually got that error as well. I'm not behind any proxies or anything. But thr error was exactly the same. I launched iTunes and went to download a track from the store, but there wasn't any response. So I stopped it (I guess I didn't get it to crash), then tried again. It worked after a while.

chrsha01
6th April 2008, 01:46 PM
No problems with mine.

rob05
6th April 2008, 01:56 PM
One thing I noticed is that itunes 7.6.2 screws quite a few permissions after it is installed.

Quicktime 7.4.5 does even worse

Once they are repaired I had few if any problems

TheWatchman
6th April 2008, 03:31 PM
I saw the update for it popup (windows) but nothing is wrong with the version I'm using so i just cancelled.

basseyy
7th April 2008, 10:09 PM
i updated to 7.6.2 on my spare windows machine, imported my libray and itunes worked only once. When i tried to load it again, the screen was blank, all i could make out was some drop down boxes at the top of my screen and nothing else...the only other thngs i could see were my icons on my desktop, but no itunes...what gives?

encryptionmatrix
13th April 2008, 01:43 PM
Im having the same problem but, instead of quitting, it just sits there and says its loading. The progress bar gets to about 1/8th of the way and then i get no response.

jbarrett
23rd June 2008, 01:33 AM
Mine is doing the same thing. I can open iTunes, but when I click on the store nothing happens and then iTunes crashes. It seems though that some of you can at least access the store's homepage. Hmm...

leon
23rd June 2008, 10:50 AM
Mine is doing the same thing. I can open iTunes, but when I click on the store nothing happens and then iTunes crashes. It seems though that some of you can at least access the store's homepage. Hmm...

Have you tried repairing permissions to see if that fixes things?

itunescrash
29th June 2008, 05:11 AM
Removing my proxy config (PAC file) fixed the problem for me. (iTunes 7.6.2, Intel Mac mini)