PDA

View Full Version : iMac in trouble!



applecollector
20th March 2005, 12:16 PM
My imac turn on then does nothing at all you can move the mouse,
and thats it!
nothing starts up and you can't click on anything!
What should i do?
Thanks!

grorr76
20th March 2005, 12:18 PM
personally that sounds serious id take it and have someone look at it for u..

applecollector
20th March 2005, 12:24 PM
Ok this is getting werid currently this very second it turned on, and now ot's working fine!
I believe this a ram thing thier is nothing wrong with the computer it's self,
After a while it works!
Werid :-)

grorr76
20th March 2005, 12:34 PM
yeah very strange
its funny cause im having some freezing issues with my mac , no where as bad as that. only thing i hate about macs is therre picky nature in regards to ram.. funny also how a good reboot or kick can get them started again..

applecollector
20th March 2005, 12:57 PM
yea a kick ,lol well i'm not it currently, it works thats the main thing!

applecollector
20th March 2005, 01:09 PM
wait could it have been because of Virtual memory turned on??

grorr76
20th March 2005, 01:45 PM
I dunno I thought in osx that was all done automatically..

LCGuy
20th March 2005, 02:59 PM
Can you tell us the specifics of the RAM you have installed?

applecollector
20th March 2005, 03:49 PM
Well this currently running mac os 9.2.2 and it has Apple Ram 128Mb!
It's still the original, and the computer is an iMac 350 slot loading mac!

foonster
20th March 2005, 05:15 PM
If you updated to 9.2.2, were you aware of the necessary firmware updates for G3 iMacs?
If not, check out http://docs.info.apple.com/article.html?artnum=75130
and http://docs.info.apple.com/article.html?artnum=58174

Further useful info for older iMacs at http://www.lowendmac.com/imacs/index.shtml