PDA

View Full Version : How to make wireless networking more reliable



The Fluffy Duck
24th February 2008, 10:55 PM
Ok I have two macs soon to be three and they all use wireless. We are all using leopard.
Tiger was great but hang for 5 min if anything wasn't ejected nicely.
Apparently this bug is now eliminated but is replaced by all sorts of unreliability.

AiportDisk aside for those who know my woes. Its a game of chance if I can connect to my ibook.

Sometimes they show up on my side bar other times they do not. IF one laptop goes to sleep or is restarted its Defiantly not picked up on the sidebar.

If it is picked up in the sidebar It may idle forever in a "trying to connect" loop.

Also when I vnc It only works the first time. The second time I try and it makes the computer I try to connect too dissapear.

The only way to fix it is to restart finder.

Is there any ANY way to make wireless networking more stable and more predictible under leopard?

The Fluffy Duck
25th February 2008, 07:34 AM
surely there has to be somebody out there with a good network

Lutze
25th February 2008, 08:01 AM
Both of the wireless networks I've set up have been extremely good. However I've not had to deal with solid brick walls like you have here,

It sounds more like you have a problem with system to system networking than wireless . Do both computers have net access using wireless? If so then it's not your wireless that is the problem.

Brains
25th February 2008, 08:34 AM
surely there has to be somebody out there with a good network

I do, eight machines of various OSes spanning two buildings on a large block ... but it's only good because it's 100% wired :p

Sorry, no idea.

gtext
25th February 2008, 10:21 AM
Ok I have two macs soon to be three and they all use wireless. We are all using leopard.
Tiger was great but hang for 5 min if anything wasn't ejected nicely.
Apparently this bug is now eliminated but is replaced by all sorts of unreliability.

AiportDisk aside for those who know my woes. Its a game of chance if I can connect to my ibook.

Sometimes they show up on my side bar other times they do not. IF one laptop goes to sleep or is restarted its Defiantly not picked up on the sidebar.

If it is picked up in the sidebar It may idle forever in a "trying to connect" loop.

Also when I vnc It only works the first time. The second time I try and it makes the computer I try to connect too dissapear.

The only way to fix it is to restart finder.

Is there any ANY way to make wireless networking more stable and more predictible under leopard?

I've found wireless on a new Mac Pro pretty chronically unreliable. Once it connects it works ok.
Once is not very often.

I feel the issue is with the Mac not the wireless network as other computers (windows) have no such issues using wireless using the Netgear router.

100% reliable though once I plug in a ethernet cable between the Mac and router.
The other computers show up instantly in finder.
That's my fix anyway!!

Hopefully a further update will fix this issue.

Lutze
25th February 2008, 10:29 AM
I've found wireless on a new Mac Pro pretty chronically unreliable. Once it connects it works ok.
Once is not very often.

I feel the issue is with the Mac not the wireless network as other computers (windows) have no such issues using wireless using the Netgear router.

100% reliable though once I plug in a ethernet cable between the Mac and router.
The other computers show up instantly in finder.
That's my fix anyway!!

Hopefully a further update will fix this issue.

I'd say you have a hardware / software or location issue then mate, I think you've got a post about it haven't you? What FD has posted about it entirely different from what you are experiencing. His issue seems to be with network connection to other computers - yours seems to be about wireless networking.

My advice for your issue is to speak to Apple, check the Apple forums as well. Hopefully FD will post back with further information so we can, perhaps, help figure out what's going on with his issue.

Optogamut
25th February 2008, 10:56 AM
I've been on wireless recently after my ethernet got zapped, and it was really flakey, and had trouble reconnecting from sleep.

Changing it from WEP to WPA seems to have fixed it though, so yeah, avoid WEP!

The Fluffy Duck
25th February 2008, 11:14 AM
really? wep makes it flaky? Ill have to try changing

Lutze
25th February 2008, 11:18 AM
You should really not be using WEP anyway - it's extremely weak security!

zeddie2001
25th February 2008, 11:19 AM
The key to reliable wireless networking (http://www.vision-systems.com/images/gigabit-ethernet_icon2.jpg)

Seriously though, the only suggestion I have is to make sure there is no interference - such as cordless phones that are operating on the same channel as your wireless router.

Lutze
25th February 2008, 11:23 AM
Fluffy can you please clarify what your issue is please!

Are you losing net connection on all the computers? OR are you unable to access other computers on your wireless network?

gtext
25th February 2008, 11:35 AM
I'd say you have a hardware / software or location issue then mate, I think you've got a post about it haven't you? What FD has posted about it entirely different from what you are experiencing. His issue seems to be with network connection to other computers - yours seems to be about wireless networking.

My advice for your issue is to speak to Apple, check the Apple forums as well. Hopefully FD will post back with further information so we can, perhaps, help figure out what's going on with his issue.

Thanks for the PM

No FD is having the same issue.

FD comment is : Is there any ANY way to make wireless networking more stable and more predictible under leopard? Sometimes they show up on my side bar other times they do not.

That's the same as I'm having.

Connecting via wireless to the internet has never been a issue. Just connecting to others on the network.
Usually they can connect to me on the Mac ok ( these two indicates the wireless is working) I can't connect to them as I have trouble getting them to show in finder.
Not showing in finder is the main problem.

Again thanks for the PM. Yours and others comments give me a few things to try later.

Lutze
25th February 2008, 11:44 AM
Thanks for the PM

No FD is having the same issue.

FD comment is : Is there any ANY way to make wireless networking more stable and more predictible under leopard? Sometimes they show up on my side bar other times they do not.

That's the same as I'm having.

Connecting via wireless to the internet has never been a issue. Just connecting to others on the network.
Usually they can connect to me on the Mac ok ( these two indicates the wireless is working) I can't connect to them as I have trouble getting them to show in finder.
Not showing in finder is the main problem.

Again thanks for the PM. Yours and others comments give me a few things to try later.

Ok.. then your issue is NOT a wireless issue. And if the issue that FD is reporting is the same then it is categorically not a problem with wireless networking.

The problem you are both reporting is that you are not able to see other computers on your network, I say this because you are advising that your wireless connection is working because you can still get net access through wireless.

I've seen this issue on my own computers, I've found that screen share (the application that Leopard uses to control networked computers works if you launch that. This makes me think that there is a possible issue with bonjour and the sidebar status not updating.

Currawong
25th February 2008, 01:02 PM
Is there anything interesting related to file sharing or wireless in the Console showing up? That may give some clues about the cause.

Linux_insidev2
25th February 2008, 01:07 PM
change the channel on your AP, if there's other people around with wifi networks it'll cause congestion if you're all on the default channel, which is channel 6

try something like channel 11

Lutze
25th February 2008, 01:22 PM
It's really not a wireless issue if you read into what they have both put. It's to do with Finder not picking up the computers on your local network and displaying them correctly in the sidebar - and therefore them not being available on the network.

gtext
25th February 2008, 04:02 PM
Ok.. then your issue is NOT a wireless issue. And if the issue that FD is reporting is the same then it is categorically not a problem with wireless networking.

That's correct. But it's only troublesome wirelessly. Ethernet cable it's perfect.

You're correct I have posted this issue elsewhere. Wasn't after a solution so much as sharing my position with FD in that what I was experiencing was similar.

inux_insidev2 change the channel on your AP, if there's other people around with wifi networks it'll cause congestion if you're all on the default channel, which is channel 6

try something like channel 11

The router channel is 11 at the moment. Can't find where the Airport card on the Mac lists the channel in network preferences. Although it has to be the same to be working at all. Right.

Still to check some of the other suggestions posted as yet.

Lutze
25th February 2008, 04:18 PM
Ok... just to clarify that one from Linux - the channel change is done on your router - not on the card. The card will pick up the channel from the router and use whatever it's told.

I don't think that this will fix your issue - however I find that Channel 11 is the default for almost every bit of kit sold -so it might be worth changing it to something anyway.

This advice will not fix the issue that you, me, fluffy et al. are having however.

I'm almost certain that the issue is somewhere in Bonjour and now that you've said it works perfectly wired then it's going to be Bonjour with wireless / finder specific.

For those with better OS X knowledge I'll try and phrase the issue that we are all having (please note I can't replicate currently as I only have my laptop here in Australia currently.)

Boot up all computers on your wireless network. In the finder sidebar it displays all the known computers and you can network to them. However if you put one of them to sleep they will not come back into finder sidebar again after it's been woken up... until you re-launch finder on the Mac that is not seeing the computer.

Is there a software trick to force finder / network device to repopulate this info? Corrections from Gtext or FluffyDuck welcome,

gtext
25th February 2008, 06:19 PM
Litze,

In my case.

Rebooted all and maybe it was because the Mac rebooted last but anyway all computers can now see each other. If I now shutdown or put to sleep on of the other computers that computer still shows in finder but naturally wont connect. Upon stating or waking up that same computer the icon once again connects in finder.

My issue is more often than not when I open finder in the Mac and select go/network from the menu only a blank window shows. Naturally there is nothing in the sidebar either at this stage.
At this stage the other computers can see and connect to the Mac.

Sometimes I can get the other computers to show by turning airport on/off one or more times.

When I connect to the other computers in finder should it say " connected as guest"?

This problem may be slightly different to FD's.

Lutze
25th February 2008, 06:28 PM
Well what you have described is exactly what I used to get (I miss my iMacs & Cube!!) with my network. What you will certainly find is that if the target computer is put to sleep the finder sidebar window reports the computer but does so inaccurately - with the other iMac for example it would often report it as being a PC.

This still - in my mind at least- is a Bonjour / Finder issue - as it's Bonjour that reports availability on start, wake etc. It might be worth reporting it to Apple.... though it's going to be another minor pesky issue that will take till at least x.5.7 to fix I'd guess, simply because you can work around it.

gtext
25th February 2008, 06:48 PM
This still - in my mind at least- is a Bonjour / Finder issue - as it's Bonjour that reports availability on start, wake etc. It might be worth reporting it to Apple.... though it's going to be another minor pesky issue that will take till at least x.5.7 to fix I'd guess, simply because you can work around it.

I'll go along with that. A future update will hopefully fix it.

Just to try, I turned everything off.

Started the Mac.

Turned on the other computers.

The other computers could see and connect to the Mac immediately.

Open finder on the Mac go/network. Blank finder window.

Withe the blank finder window still open I turned the airport card on/ off.

Other computers now show in window.

Doesn't work that easily every time though.

Thanks for your help and attention Lutze.

zmit
27th February 2008, 12:04 PM
sounds like exactly the same problem im having, havent picked a specific solution or procedure to get it though.

shall try rebooting or turning airport off/on when i get home

so do we have any developers here that might be able to search for a hack to trick bonjour to, i guess, ping or tell it to check for computers that it KNOWS has been on a certain network before?

i guess finding computers for the first time is difficult, but if it can at least make a list saying

X1, X2, X3, X4 have been known to be on XXX network, search for X1, X2, X3, X4 on a regular basis?

i have no coding knowledge at all.... just a thought

gtext
2nd March 2008, 11:33 AM
[QUOTE= It might be worth reporting it to Apple.... though it's going to be another minor pesky issue that will take till at least x.5.7 to fix I'd guess, simply because you can work around it.[/QUOTE]

What's the best way to report this back to Apple?

Lutze
2nd March 2008, 12:02 PM
I've done a bit of looking around on the Apple forum about this and it's looking like a possible work around is to open iChat - it is a Bonjour application and seems to kick the process (At least from what I can see from the posts) Because I don't have a network here to test it on, see signature for details, I can't say if it's made much of a difference.

However iChat does have a feedback option in the iChat Menu - click and it's the second option. Explain that it's regarding the bonjour part maybe?

Hope this helps.

alexc
2nd March 2008, 12:29 PM
Trouble shoot your Wireless first - try something like KISMAC to see whats going on.

Basic Tips:

1. Brick Walls are bad for reception
2. Get your Access Point up high - not on the floor.
3. Trouble shoot by removing variables. Put the devices right next to each other where you are sure environmental factors arnt screwing with the signals.

Just because you seem to be getting decent Internet access doesnt mean you will perceive a good experience with other protocols on your LAN.

Al

gtext
2nd March 2008, 01:01 PM
I've done a bit of looking around on the Apple forum about this and it's looking like a possible work around is to open iChat - it is a Bonjour application and seems to kick the process (At least from what I can see from the posts) Because I don't have a network here to test it on, see signature for details, I can't say if it's made much of a difference.

However iChat does have a feedback option in the iChat Menu - click and it's the second option. Explain that it's regarding the bonjour part maybe?

Hope this helps.

Thanks Lutze. I'll try that next time it play's up. It's so inconsistent.

It seems to connect ok apart from a blank finder window. The other computers can see the Mac but the Mac can't see the other networked computers.(No icons in finder)

gtext
2nd March 2008, 01:06 PM
Trouble shoot your Wireless first - try something like KISMAC to see whats going on.

Basic Tips:

1. Brick Walls are bad for reception
2. Get your Access Point up high - not on the floor.
3. Trouble shoot by removing variables. Put the devices right next to each other where you are sure environmental factors arnt screwing with the signals.

Just because you seem to be getting decent Internet access doesnt mean you will perceive a good experience with other protocols on your LAN.

Al

Thanks alexc. Agree with your comments however the distance between the Mac and router is about 2 mtr with nothing in between. Seems to be confined to the Mac rather that any external cause. Seems that way anyway.

zmit
3rd March 2008, 04:08 PM
try one more thing. if it is the same as what has been happening to me, then it seems to be inconsistency within leopard and showing the links on the sidebar.

ive found that any ordinary "open" dialog box shows the shared computers on my computer (here at uni as well, even though they arent showing up on the sidebar in finder)

the other way is to go to your computer name on the sidebar (the top one above macintosh HD) and go to network from there. can you see the computers in there?

alexc
5th March 2008, 04:52 PM
I was going to rather unhelpfully say that I dont get any problems like this.

Instead I will helpfully say that I have a mOn0wall router handling my DNS and DHCP. :)

My LAN devices all ways appear right away in my sidebar. But I dont know if thats Bonjour handling the detection.

Maybe the presence of a decent router is why it works well for me. Dont know.

zmit
5th March 2008, 05:21 PM
i have a netgear router (not wireless) running my DNS and DHCP

all computers are linked through a network switch (a bloody big one) to which the access point is connected to as well.

note: the path for the internet goes through this switch to get to the AP as well, yet internet is fine.

not trying to hijack, but it seems that i have a similar, if not the same, problem as gtext

gtext
5th March 2008, 06:40 PM
Tried everything suggested here without success.

Nothing except turning wireless off/on seems to help.

Wired it networks 100%

Thanks for trying everyone. I don't think anything short of a fix by Apple will solve this.

I'll get by ok in the mean time.

alexc
7th March 2008, 07:40 AM
Well, sounds like you have a ton of variables there, so you'd need to trouble shoot it top-to-bottom really.