PDA

View Full Version : Constantly changing brightness



reznorism
20th February 2008, 01:39 AM
Hey guys, having a small but annoying issue with my new MBP.

Whilst sitting in bed and when the lights are off, I usually dim the display quite a fair bit. Now, the ambient light sensor keeps adjusting the brightness of the display, be it brighter or dimmer, depending on how much light is coming from the display. Whilst surfing the web it seems to be the worst, going from a site with a bright white theme (youtube etc) to something darker, say DevART or revision3.com.

Is there a way to keep the illumated keyboard on, but stop these annoying automatic changes in brightness?

Huy
20th February 2008, 01:51 AM
Don't you have illumination buttons? Turn it off completely?

What does your F5 and F6 key do? (isn't it dimmer and brighter, for illumination).

reznorism
20th February 2008, 01:57 AM
Well, the keyboard really isn't the problem. The display is. The best way I can think of describing it, is that the MBP has an ambient light sensor designed so that say, if you're outside it will automatically bring the brightness to full, if you then move inside, it will automatically bring the brightness down.

But in a dark room, the sensor is picking up the light from the screen itself, and causing the brightness to change.

Huy
20th February 2008, 02:02 AM
I thought the ambient light sensor was for the illuminated keyboard, which changes the illumination of the keyboard lights based on the ambience (hence ambient/background light sensor).

If you're having trouble with the display (LCD/screen) brightness, adjust that using F1 and F2 I believe (sun with small dots for dimmer, sun with rays, for brighter). Dim one or the other, or disable the illumination is my best advice. Or live with both on full brightness... or turn on some room lights.

Maybe it's an "on battery" issue where it's just dimming to save power. Why not try setting the illuminated keyboard to the second lowest setting (on, but on the lowest dim setting using F5. just one block before off).

Other than that, can't help you sorry. Good luck. :)

hiredgoon
20th February 2008, 02:25 AM
if youre running 10.4

system preferences>display>uncheck the box "automatically adjust brightness as ambient light changes"

yes?

reznorism
20th February 2008, 01:22 PM
if youre running 10.4

system preferences>display>uncheck the box "automatically adjust brightness as ambient light changes" all that seems to have done is stop it dimming after inactivity when running off battery power.

Linux_insidev2
20th February 2008, 01:24 PM
all that seems to have done is stop it dimming after inactivity when running off battery power.

you must've clicked the wrong thing or your eyes are broken
Either that or the inverter is on it's way out

reznorism
20th February 2008, 10:09 PM
i think my eyes are broken, that must be it.

reznorism
21st February 2008, 01:57 PM
i admit, i'm a retard. Display Preferences > Adjust display when ambient light changes.

..lol.