PDA

View Full Version : Wireless Networking after Sleep



gmask1
14th March 2005, 04:50 PM
I have a question.

Everytime I resume my laptop from sleep, I have to reconnect it to the wireless network. It's already got all the authentication, but doesn't appear to even try to reconnect automatically.

Is there a way to make the p'book reconnect with me having to go in and reselect it, then wait for dhcp to kick in?

GregA

purana
14th March 2005, 04:52 PM
I am pretty sure mine reconnects, so I suspect it must be an option not selected when you first joined the wireless preferred AP. Might have to experiment with mine to confirm if mine does indeed reconnect after sleep as I suspect

notb4dinner
14th March 2005, 05:05 PM
Just chiming into say that this has been an intermittent problem for me and that I'd appreciate any suggested solutions.

964RSCS
14th March 2005, 05:08 PM
Mine definately reconnects automatically, not sure how to make it do this automatically though sorry - I always just thought this was how the mac worked, no "setup" required. Also reconnects from cold start as opposed to sleep mode.

I also notice on occassion that there is new mail straight away when I restart from sleep mode. I wonder if it can check and download the mail when asleep?? I wouldn't have thought so, but...

kit
14th March 2005, 05:27 PM
964RSCS - it can't check mail while sleeping, but it's very quick to do it when it's waking (sometimes quicker than it can turn on the display).

Mine connects automatically to whichever network I use (home or Uni). First things to try: make a new Location for wireless. Set that location, and see if it works.

If not and your wireless network is secured (WEP or WPA), go into Keychain Access (in your /Applications/Utilities folder) and delete the certificates for the network. Let the network re-send them and you should be right.

964RSCS
14th March 2005, 05:34 PM
Originally posted by kit@Mar 14 2005, 05:27 PM
964RSCS - it can't check mail while sleeping, but it's very quick to do it when it's waking (sometimes quicker than it can turn on the display).
thanks, that makes sense! I didn't think it could have done it while sleeping :unsure:

jimmy
14th March 2005, 06:08 PM
I had this problem too, try setting your location to automatic or setting your airpot as the default connection

Currawong
14th March 2005, 09:27 PM
I'm sure there's a setting in the Airport settings in Network in System Preferences, because I set up my wife's iBook to auto-connect to our closed network. She wakes it from sleep twice a day and it connects instantly.

notb4dinner
14th March 2005, 09:54 PM
Originally posted by Currawong@Mar 14 2005, 09:27 PM
I'm sure there's a setting in the Airport settings in Network in System Preferences.
System Preferences>Network>Airport>By Default:Join A Specific Network

The above should provide the desired functionality but in my case atleast that doesn't always work.

gmask1
14th March 2005, 10:10 PM
Okey dokey, it's all good and working better now. I did two things, and though the tester in me wants to find out which it was that made things good, it's too late at night and I can't be bothered. :)

1. Like the nice poster mentioned, I switched my location from 'Home' (which I'd set up for Home, as distinct from 'At the Airport', or 'At the Beach under an umbrella with a cocktail') to Automatic.

2. I also, whilst mucking about, went into the Show: Network Configurations in the Network setup pane, and discovered that not only can you turn things on and off, but by reading the text, you can also move things up and down the order that ports are tried for network connectivity. As I don't read, I didn't realise that you could do this. ;)

Why I'd have to do either of these to make the thing pick up the same network it connects to when I'm at home is leading back towards the excuses I left behind with the PC. But it works - I just had to tamper a bit.

Thanks for all your help!

Greg