PDA

View Full Version : Exchange Apple Mail



mvjs
17th January 2008, 03:50 PM
I am trying to configure Apple Mail with an email account which is on the University of Melbourne's Exchange system. I have got Apple Mail to connect to owa.unimelb.edu.au using the default Exchange settings. I also disabled the syncing of Public Folders (making the Public Folder Mailbox read only). But it is extremely unresponsive, taking in some cases a minute to download the messages. Does anyone have any clues on rectifying the responsiveness problem? Or better yet, is there a plain IMAP server available? (I have searched through the documentation to no avail)

Thanks in advance

mvjs
17th January 2008, 08:17 PM
Anyone?

stevekicks
17th January 2008, 08:27 PM
i can't help i'm sorry but i do agree. i've got a couple of macs on our work network and mail+exchange isn't the best.

if there was a caching option that would definitely help.

mvjs
18th January 2008, 10:32 PM
Anyone else have any insight?

bartron
18th January 2008, 10:40 PM
Apple mail + exchange does indeed suck. See if you can disable public folders altogether as even if it's read-only it will probably still want to cache the headers.

Some Exchange servers are set up as IMAP servers as well. You can ask your local admin or just try to connect to your exchange server using imap instead.

mvjs
18th January 2008, 10:45 PM
Apple mail + exchange does indeed suck. See if you can disable public folders altogether as even if it's read-only it will probably still want to cache the headers.

The Get Info Permissions thing doesn't give me an option to give "No Access"

raj
18th January 2008, 11:00 PM
Apple's support for Exchange is extremely bad, as is Entourage for that matter. Neither of them actually run a correct "Exchange" service rather use a IMAP/Exchange faux protocol. I had a major problem when work disabled this IMAP support and couldn't use my Mac there at all for mail. Hopefully Office 2008 actually implements exchange support correctly.

The best method of using an exchange server on a Mac at the moment is one of two options....

1. Install Classic, download Outlook 2004 (I think) from Mactopia (Microsoft's Mac site). It works perfectly and is the best exchange client available for the Mac, you just need OS 9 to run it.

2. Install VMware or Parallels and run Outlook from there.

Fingers crossed for Office 2008!!

BiRDBRAiN
18th January 2008, 11:03 PM
As long as you do it right its not a problem.

Make sure you use the IP address of the Exchange server and that the exchange server has IMAP enabled because even though you use the type 'Exchange' as the client it still uses IMAP for syncing the folders.

We use it at work (Although we will eventually retire Exchange).

As long as Exchange has the Outlook Web Access enabled u put in the IP address with /OWA after it for the OWA address, e.g. 192.168.1.5/OWA

You then need to right-click on the inbox and tell it to sync. It takes a bit to kick in depending on the size of the Exchange mailbox, but it works eventually.

mvjs
18th January 2008, 11:17 PM
As long as you do it right its not a problem.

Make sure you use the IP address of the Exchange server and that the exchange server has IMAP enabled because even though you use the type 'Exchange' as the client it still uses IMAP for syncing the folders.

We use it at work (Although we will eventually retire Exchange).

As long as Exchange has the Outlook Web Access enabled u put in the IP address with /OWA after it for the OWA address, e.g. 192.168.1.5/OWA

You then need to right-click on the inbox and tell it to sync. It takes a bit to kick in depending on the size of the Exchange mailbox, but it works eventually.

Thanks, I'm trying this now. Unfortunately, I get this certificate message (because the certificate is in the domain name not the IP) every time Mail is launched, and always trust doesn't always trust the certificate. Is there any way to avoid this popup?

elSpike
18th January 2008, 11:56 PM
You can try putting your server in as mailserver.blah.edu.au/exchange/username@domain.com

That solves pretty much every problem with speed when connecting entourage so maybe mail.app will be the same.

elSpike out.

mvjs
19th January 2008, 08:46 AM
just try to connect to your exchange server using imap instead.

Thanks Bartron! That seems to have worked a treat. I thought it'd just be the same because the Exchange setting actually communicates over IMAP. I haven't even had to turn off public folders because there aren't any speed issues.

Thanks everyone for your help.

mvjs
20th January 2008, 09:03 AM
The setup using the IMAP setting instead of Exchange has been going well, except: when a message is deleted that doesn't seem to get reflected on the server until an indeterminable time afterwards, sometimes minutes, sometimes hours. Any idea how to get the message deletion to be immediately reflection on the server?